summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-04-04 18:07:18 +0000
committerDane Smith <c1pher@gentoo.org>2011-04-04 18:07:18 +0000
commit68c0c5531f09205ac74f41d0a8a875d2e7c50e19 (patch)
treebd682ece3d0d7916bf6ef3e9ebd48ec654761a16 /net-ftp
parentx86 stable per bug 361525 (diff)
downloadgentoo-2-68c0c5531f09205ac74f41d0a8a875d2e7c50e19.tar.gz
gentoo-2-68c0c5531f09205ac74f41d0a8a875d2e7c50e19.tar.bz2
gentoo-2-68c0c5531f09205ac74f41d0a8a875d2e7c50e19.zip
net-ftp/yafc: New upstream. Version bump. Add proxy maintainer. Closes bugs 275795, 350277, 352401.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/ChangeLog14
-rw-r--r--net-ftp/yafc/metadata.xml7
-rw-r--r--net-ftp/yafc/yafc-1.1.2.ebuild53
3 files changed, 71 insertions, 3 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index 6fe42ac9ba03..dbfddbaa96ee 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-ftp/yafc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.37 2010/08/05 17:11:33 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.38 2011/04/04 18:07:18 c1pher Exp $
+
+*yafc-1.1.2 (04 Apr 2011)
+
+ 04 Apr 2011; Dane Smith <c1pher@gentoo.org> +yafc-1.1.2.ebuild,
+ metadata.xml:
+ Version bump. Add proxy maintainer Carles Pagès, who is now
+ maintaining the new upstream since the old one has had no development
+ since
+ 2005. Upsteam fixes to bug 350277 and bug 352401. Local fix for
+ kerebos support wrt bug 275795.
05 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> yafc-1.1.1-r1.ebuild:
Remove built_with_use check for app-crypt/mit-krb5 because krb4 support
diff --git a/net-ftp/yafc/metadata.xml b/net-ftp/yafc/metadata.xml
index 54494c4bb860..7222e8ef87d6 100644
--- a/net-ftp/yafc/metadata.xml
+++ b/net-ftp/yafc/metadata.xml
@@ -3,6 +3,11 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
-<email>maintainer-needed@gentoo.org</email>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
+</maintainer>
+<maintainer>
+ <email>page@cubata.homelinux.net</email>
+ <name>Carles Pagès</name>
</maintainer>
</pkgmetadata>
diff --git a/net-ftp/yafc/yafc-1.1.2.ebuild b/net-ftp/yafc/yafc-1.1.2.ebuild
new file mode 100644
index 000000000000..32141c8ceed8
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.2.ebuild,v 1.1 2011/04/04 18:07:18 c1pher Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="http://yafc.sourceforge.net/"
+SRC_URI="http://github.com/downloads/cpages/yafc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="readline kerberos socks5"
+
+DEPEND="readline? ( >=sys-libs/readline-6 )
+ kerberos? ( virtual/krb5 )
+ socks5? ( net-proxy/dante )"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-3"
+
+src_configure() {
+ local myconf=""
+
+ if use kerberos; then
+ if has_version app-crypt/heimdal; then
+ myconf="${myconf} --with-krb5=/usr/ --with-krb4=no --with-gssapi=/usr"
+ elif has_version app-crypt/mit-krb5; then
+ myconf="${myconf} --with-krb5=/usr/ --with-krb4=no --with-gssapi=/usr"
+ else
+ ewarn "No supported kerberos providers detected"
+ myconf="${myconf} --without-krb4 --without-krb5"
+ fi
+ else
+ myconf="${myconf} --without-krb4 --without-krb5"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socks5=/usr" \
+ || myconf="${myconf} --with-socks5=no"
+
+ use readline && myconf="${myconf} --with-readline=/usr" \
+ || myconf="${myconf} --with-readline=no"
+
+ econf \
+ $(use_with readline) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS NEWS README THANKS TODO *.sample || die
+}