summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-02 03:25:51 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-02 03:25:51 +0000
commit8cb8edf2c54e7160897ec779b7c1c15842b8f873 (patch)
tree571ef31b16b51bea7f3767a5eb1571266bb63653 /net-ftp
parentlibnids 1.16: Libnids is an implementation of an E-component of Network Intr... (diff)
downloadgentoo-2-8cb8edf2c54e7160897ec779b7c1c15842b8f873.tar.gz
gentoo-2-8cb8edf2c54e7160897ec779b7c1c15842b8f873.tar.bz2
gentoo-2-8cb8edf2c54e7160897ec779b7c1c15842b8f873.zip
miscellaneous doo-dads.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/curl/curl-7.9-r1.ebuild33
-rw-r--r--net-ftp/curl/curl-7.9.1.ebuild33
-rw-r--r--net-ftp/curl/files/digest-curl-7.9.11
3 files changed, 67 insertions, 0 deletions
diff --git a/net-ftp/curl/curl-7.9-r1.ebuild b/net-ftp/curl/curl-7.9-r1.ebuild
new file mode 100644
index 000000000000..7509ebb9b7c0
--- /dev/null
+++ b/net-ftp/curl/curl-7.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.9-r1.ebuild,v 1.1 2001/12/02 03:25:51 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Client that groks URLs"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+HOMEPAGE="http://curl.haxx.se"
+
+DEPEND=">=sys-libs/glibc-2.1.3 >=sys-libs/pam-0.75 ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ]
+ then
+ myconf="--with-ssl"
+ else
+ myconf="--without-ssl"
+ fi
+ cd ${S}
+ ./configure --prefix=/usr --mandir=/usr/share/man $myconf || die
+ emake || die
+
+}
+
+src_install () {
+ cd ${S}
+ make install DESTDIR=${D} || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-ftp/curl/curl-7.9.1.ebuild b/net-ftp/curl/curl-7.9.1.ebuild
new file mode 100644
index 000000000000..1c033c1b1d02
--- /dev/null
+++ b/net-ftp/curl/curl-7.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.9.1.ebuild,v 1.1 2001/12/02 03:25:51 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Client that groks URLs"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.gz"
+HOMEPAGE="http://curl.haxx.se"
+
+DEPEND=">=sys-libs/glibc-2.1.3 >=sys-libs/pam-0.75 ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ]
+ then
+ myconf="--with-ssl"
+ else
+ myconf="--without-ssl"
+ fi
+ cd ${S}
+ ./configure --prefix=/usr --mandir=/usr/share/man $myconf || die
+ emake || die
+
+}
+
+src_install () {
+ cd ${S}
+ make install DESTDIR=${D} || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-ftp/curl/files/digest-curl-7.9.1 b/net-ftp/curl/files/digest-curl-7.9.1
new file mode 100644
index 000000000000..8d9517dd54b3
--- /dev/null
+++ b/net-ftp/curl/files/digest-curl-7.9.1
@@ -0,0 +1 @@
+MD5 73cf0be342f8c3c8ef789e958d41bfdf curl-7.9.1.tar.gz 643072