summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-06-10 19:34:49 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-06-10 19:34:49 +0000
commitac9cd019e2289181ce693ea44d355d7717d84841 (patch)
treee954dfa21064615a08cd6dbd5969a81df79566fa /net-ftp
parentAdding ~amd64 to rox-base/pager (diff)
downloadgentoo-2-ac9cd019e2289181ce693ea44d355d7717d84841.tar.gz
gentoo-2-ac9cd019e2289181ce693ea44d355d7717d84841.tar.bz2
gentoo-2-ac9cd019e2289181ce693ea44d355d7717d84841.zip
Fixes bug #178866.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/ChangeLog9
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2-r2 (renamed from net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2)0
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.1_rc2-bug178866.patch68
-rw-r--r--net-ftp/proftpd/proftpd-1.3.1_rc2-r2.ebuild (renamed from net-ftp/proftpd/proftpd-1.3.1_rc2.ebuild)10
4 files changed, 84 insertions, 3 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index 0fcf9d5c1fb1..4494f6c12aca 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.156 2007/05/16 20:21:47 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.157 2007/06/10 19:34:49 chtekk Exp $
+
+*proftpd-1.3.1_rc2-r2 (10 Jun 2007)
+
+ 10 Jun 2007; Luca Longinotti <chtekk@gentoo.org>
+ +files/proftpd-1.3.1_rc2-bug178866.patch, -proftpd-1.3.1_rc2.ebuild,
+ +proftpd-1.3.1_rc2-r2.ebuild:
+ Fixes bug #178866.
16 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
proftpd-1.3.1_rc2-r1.ebuild:
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2 b/net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2-r2
index b18daddb66a6..b18daddb66a6 100644
--- a/net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2
+++ b/net-ftp/proftpd/files/digest-proftpd-1.3.1_rc2-r2
diff --git a/net-ftp/proftpd/files/proftpd-1.3.1_rc2-bug178866.patch b/net-ftp/proftpd/files/proftpd-1.3.1_rc2-bug178866.patch
new file mode 100644
index 000000000000..206ffb0d6384
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.1_rc2-bug178866.patch
@@ -0,0 +1,68 @@
+--- src/auth.c 2007/04/17 21:33:40 1.48
++++ src/auth.c 2007/05/21 15:19:41 1.49
+@@ -442,6 +442,32 @@
+
+ cmd = make_cmd(p, 2, name, pw);
+
++ /* First, check for the mod_auth_pam.c module.
++ *
++ * PAM is a bit of hack in this Auth API, because PAM only provides
++ * yes/no checks, and is not a source of user information.
++ */
++ m = pr_module_get("mod_auth_pam.c");
++ if (m) {
++ pr_trace_msg(trace_channel, 4,
++ "using module 'mod_auth_pam.c' to authenticate user '%s'", name);
++
++ mr = dispatch_auth(cmd, "auth", &m);
++
++ if (MODRET_ISHANDLED(mr)) {
++ res = MODRET_HASDATA(mr) ? PR_AUTH_RFC2228_OK : PR_AUTH_OK;
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
++ m = NULL;
++ }
++
+ if (auth_tab) {
+
+ /* Fetch the specific module to be used for authenticating this user. */
+@@ -479,6 +505,32 @@
+
+ cmd = make_cmd(p, 3, cpw, name, pw);
+
++ /* First, check for the mod_auth_pam.c module.
++ *
++ * PAM is a bit of hack in this Auth API, because PAM only provides
++ * yes/no checks, and is not a source of user information.
++ */
++ m = pr_module_get("mod_auth_pam.c");
++ if (m) {
++ pr_trace_msg(trace_channel, 4,
++ "using module 'mod_auth_pam.c' to authenticate user '%s'", name);
++
++ mr = dispatch_auth(cmd, "auth", &m);
++
++ if (MODRET_ISHANDLED(mr)) {
++ res = MODRET_HASDATA(mr) ? PR_AUTH_RFC2228_OK : PR_AUTH_OK;
++
++ if (cmd->tmp_pool) {
++ destroy_pool(cmd->tmp_pool);
++ cmd->tmp_pool = NULL;
++ }
++
++ return res;
++ }
++
++ m = NULL;
++ }
++
+ if (auth_tab) {
+
+ /* Fetch the specific module to be used for authenticating this user. */
diff --git a/net-ftp/proftpd/proftpd-1.3.1_rc2.ebuild b/net-ftp/proftpd/proftpd-1.3.1_rc2-r2.ebuild
index 7fb172f04ad5..9ae2ab1bdd49 100644
--- a/net-ftp/proftpd/proftpd-1.3.1_rc2.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.1_rc2-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.1_rc2.ebuild,v 1.2 2007/05/08 22:34:42 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.1_rc2-r2.ebuild,v 1.1 2007/06/10 19:34:49 chtekk Exp $
inherit eutils flag-o-matic toolchain-funcs
-KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="acl authfile clamav hardened ifsession ipv6 ldap mysql ncurses nls noauthunix opensslcrypt pam postgres radius rewrite selinux shaper sitemisc softquota ssl tcpd vroot xinetd"
@@ -53,6 +53,12 @@ src_unpack() {
cd "${S}"
+ # Fix bugs #164612, #167003, #175082 and #178866
+ epatch "${FILESDIR}/${P}-bug164612.patch"
+ epatch "${FILESDIR}/${P}-bug167003.patch"
+ epatch "${FILESDIR}/${P}-bug175082.patch"
+ epatch "${FILESDIR}/${P}-bug178866.patch"
+
# Fix stripping of files
sed -e "s| @INSTALL_STRIP@||g" -i Make*