summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-20 15:53:40 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-20 15:53:40 +0000
commitf532d7b5ed59d51ebc69736e56212fd7c7144c7b (patch)
tree2deb1b99f1c3e69b533c27958e1928e52dfe408a /net-ftp
parentfix ${ROOT} (thanks blubb) (diff)
downloadgentoo-2-f532d7b5ed59d51ebc69736e56212fd7c7144c7b.tar.gz
gentoo-2-f532d7b5ed59d51ebc69736e56212fd7c7144c7b.tar.bz2
gentoo-2-f532d7b5ed59d51ebc69736e56212fd7c7144c7b.zip
Gcc41 patch thanks to Piotr Jaroszynski <peper@aster.pl> in bug 135713 thanks to Frank T. Lofaro Jr. <ftlofaro@yahoo.com>, add maintainer-needed metadata.xml
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpd/ChangeLog8
-rw-r--r--net-ftp/ftpd/files/ftpd-0.17-gcc41.patch33
-rw-r--r--net-ftp/ftpd/ftpd-0.17-r3.ebuild33
-rw-r--r--net-ftp/ftpd/metadata.xml5
4 files changed, 61 insertions, 18 deletions
diff --git a/net-ftp/ftpd/ChangeLog b/net-ftp/ftpd/ChangeLog
index 85b5a2844148..469b3c15a349 100644
--- a/net-ftp/ftpd/ChangeLog
+++ b/net-ftp/ftpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/ftpd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ChangeLog,v 1.24 2006/01/30 19:03:56 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ChangeLog,v 1.25 2006/06/20 15:53:40 genstef Exp $
+
+ 20 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/ftpd-0.17-gcc41.patch, +metadata.xml, ftpd-0.17-r3.ebuild:
+ Gcc41 patch thanks to Piotr Jaroszynski <peper@aster.pl> in bug 135713
+ thanks to Frank T. Lofaro Jr. <ftlofaro@yahoo.com>, add maintainer-needed
+ metadata.xml
28 Jan 2006; Simon Stelling <blubb@gentoo.org> ftpd-0.17.ebuild,
ftpd-0.17-r1.ebuild, ftpd-0.17-r2.ebuild:
diff --git a/net-ftp/ftpd/files/ftpd-0.17-gcc41.patch b/net-ftp/ftpd/files/ftpd-0.17-gcc41.patch
new file mode 100644
index 000000000000..11a0ae2cb6c1
--- /dev/null
+++ b/net-ftp/ftpd/files/ftpd-0.17-gcc41.patch
@@ -0,0 +1,33 @@
+diff -ur linux-ftpd-0.17-orig/ftpd/ftpcmd.y linux-ftpd-0.17/ftpd/ftpcmd.y
+--- linux-ftpd-0.17-orig/ftpd/ftpcmd.y 2006-06-06 15:00:29.000000000 +0200
++++ linux-ftpd-0.17/ftpd/ftpcmd.y 2006-06-06 15:23:10.000000000 +0200
+@@ -125,7 +125,14 @@
+ char cbuf[512];
+ char *fromname;
+
+-struct tab;
++struct tab {
++ const char *name;
++ short token;
++ short state;
++ short implemented; /* 1 if command is implemented */
++ const char *help;
++};
++
+ static int yylex __P((void));
+ static void sizecmd __P((char *));
+ static void help __P((struct tab *, char *));
+@@ -891,13 +898,6 @@
+ #define SITECMD 7 /* SITE command */
+ #define NSTR 8 /* Number followed by a string */
+
+-struct tab {
+- const char *name;
+- short token;
+- short state;
+- short implemented; /* 1 if command is implemented */
+- const char *help;
+-};
+
+ struct tab cmdtab[] = { /* In order defined in RFC 765 */
+ { "AUTH", AUTH, STR1, 1, "<sp> auth_type" },
diff --git a/net-ftp/ftpd/ftpd-0.17-r3.ebuild b/net-ftp/ftpd/ftpd-0.17-r3.ebuild
index 8e8246bf78d1..5ce7e3ea6145 100644
--- a/net-ftp/ftpd/ftpd-0.17-r3.ebuild
+++ b/net-ftp/ftpd/ftpd-0.17-r3.ebuild
@@ -1,33 +1,34 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17-r3.ebuild,v 1.5 2005/11/11 15:43:40 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17-r3.ebuild,v 1.6 2006/06/20 15:53:40 genstef Exp $
inherit eutils ssl-cert
-IUSE="ssl"
-
-S=${WORKDIR}/linux-${P}
DESCRIPTION="The netkit FTP server with optional SSL support"
HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/linux-${P}.tar.gz
- mirror://gentoo/linux-${P}-ssl.patch"
+ mirror://gentoo/linux-${P}-ssl.patch"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="alpha amd64 ~ppc sparc x86"
+IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
virtual/inetd"
+S=${WORKDIR}/linux-${P}
+
src_unpack() {
unpack ${A}
- cd ${S}
- if use ssl; then
- epatch ${DISTDIR}/linux-${P}-ssl.patch
- fi
- epatch ${FILESDIR}/${P}-shadowfix.patch
+ cd "${S}"
+ use ssl && epatch "${DISTDIR}/linux-${P}-ssl.patch"
+ epatch "${FILESDIR}/${P}-shadowfix.patch"
+
+ # fixes gcc 4.1 compatibility
+ epatch "${FILESDIR}/${P}-gcc41.patch"
}
src_compile() {
@@ -42,17 +43,15 @@ src_install() {
doman ftpd/ftpd.8
dodoc README ChangeLog
insinto /etc/xinetd.d
- newins ${FILESDIR}/ftp.xinetd ftp
- if use ssl;
- then
+ newins "${FILESDIR}/ftp.xinetd" ftp
+ if use ssl; then
insinto /etc/ssl/certs/
docert ftpd
fi
}
pkg_postinst() {
- if use ssl;
- then
+ if use ssl; then
einfo "In order to start the server with SSL support"
einfo "You need a certificate /etc/ssl/certs/ftpd.pem."
einfo "A temporary certificiate has been created."
diff --git a/net-ftp/ftpd/metadata.xml b/net-ftp/ftpd/metadata.xml
new file mode 100644
index 000000000000..0e9416707c4e
--- /dev/null
+++ b/net-ftp/ftpd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-needed</herd>
+</pkgmetadata>