summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-04 08:35:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-04 08:35:07 +0000
commitff7a3fe8a4925e38bb8ebb8ce243a7c469c38c75 (patch)
tree3329a35a1eb21847732ee6891cc8f9b26cc9063e /net-ftp
parentDependancy dev-libs/libgcrypt added to fix bug #52127 (Manifest recommit) (diff)
downloadgentoo-2-ff7a3fe8a4925e38bb8ebb8ce243a7c469c38c75.tar.gz
gentoo-2-ff7a3fe8a4925e38bb8ebb8ce243a7c469c38c75.tar.bz2
gentoo-2-ff7a3fe8a4925e38bb8ebb8ce243a7c469c38c75.zip
version bump
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.0.51
-rw-r--r--net-ftp/lftp/lftp-3.0.5.ebuild62
3 files changed, 70 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index f9c74a84d496..1fa68fe05d5e 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.42 2004/05/13 02:48:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.43 2004/06/04 08:35:07 dragonheart Exp $
+
+*lftp-3.0.5 (04 Jun 2004)
+
+ 04 Jun 2004; Daniel Black <dragonheart@gentoo.org> +lftp-3.0.5.ebuild:
+ version bump thanks to #gentoo.pl Team - sekretarz <sekretarz@dukato.net> in
+ bug #52021
*lftp-3.0.3 (13 May 2004)
diff --git a/net-ftp/lftp/files/digest-lftp-3.0.5 b/net-ftp/lftp/files/digest-lftp-3.0.5
new file mode 100644
index 000000000000..a6dfb2084a80
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.0.5
@@ -0,0 +1 @@
+MD5 f8283b4a7f23c39167bbc127637e869e lftp-3.0.5.tar.bz2 1218826
diff --git a/net-ftp/lftp/lftp-3.0.5.ebuild b/net-ftp/lftp/lftp-3.0.5.ebuild
new file mode 100644
index 000000000000..633ca97de425
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.0.5.ebuild,v 1.1 2004/06/04 08:35:07 dragonheart Exp $
+
+IUSE="ssl socks5 nls"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )
+ virtual/glibc
+ sys-libs/readline
+ sys-libs/pam"
+
+RDEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ virtual/glibc
+ sys-libs/readline
+ sys-libs/pam
+ socks5? ( >=net-misc/dante-1.1.12 )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}