summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-12-05 21:57:35 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-12-05 21:57:35 +0000
commited8bdc43a585db7623017475608050f5a32dd95a (patch)
treedc0efc11db5113a484db5018a0755526c940cfa6 /net-im/climm
parentbump to 2.20.2 (diff)
downloadgentoo-2-ed8bdc43a585db7623017475608050f5a32dd95a.tar.gz
gentoo-2-ed8bdc43a585db7623017475608050f5a32dd95a.tar.bz2
gentoo-2-ed8bdc43a585db7623017475608050f5a32dd95a.zip
Fix up gnutls dep as notified in bug #198132
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/ChangeLog5
-rw-r--r--net-im/climm/climm-0.6.1-r1.ebuild22
2 files changed, 23 insertions, 4 deletions
diff --git a/net-im/climm/ChangeLog b/net-im/climm/ChangeLog
index d70788eabaed..42ec607d47f0 100644
--- a/net-im/climm/ChangeLog
+++ b/net-im/climm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/climm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.4 2007/10/28 11:25:40 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.5 2007/12/05 21:57:35 jokey Exp $
+
+ 05 Dec 2007; Markus Ullmann <jokey@gentoo.org> climm-0.6.1-r1.ebuild:
+ Fix up gnutls dep as notified in bug #198132
28 Oct 2007; Markus Ullmann <jokey@gentoo.org> climm-0.6.1-r1.ebuild:
Add a dep to otr 3.0 for bug #195862 and add a check for ssl/gloox useflags
diff --git a/net-im/climm/climm-0.6.1-r1.ebuild b/net-im/climm/climm-0.6.1-r1.ebuild
index 2aef15826474..037e684367fe 100644
--- a/net-im/climm/climm-0.6.1-r1.ebuild
+++ b/net-im/climm/climm-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.6.1-r1.ebuild,v 1.2 2007/10/28 11:25:40 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.6.1-r1.ebuild,v 1.3 2007/12/05 21:57:35 jokey Exp $
DESCRIPTION="ICQ text-mode client with many features"
HOMEPAGE="http://www.climm.org/"
@@ -9,10 +9,12 @@ SRC_URI="http://www.climm.org/source/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gloox otr tcl ssl"
+IUSE="gloox gnutls otr tcl ssl"
DEPEND="gloox? ( net-libs/gloox )
- ssl? ( >=net-libs/gnutls-0.8.10 dev-libs/openssl )
+ ssl? (
+ || ( gnutls? ( >=net-libs/gnutls-0.8.10 )
+ dev-libs/openssl ) )
tcl? ( dev-lang/tcl )
otr? ( >=net-libs/libotr-3.0.0 )"
@@ -25,11 +27,25 @@ pkg_setup() {
}
src_compile() {
+ local myconf
+ if use ssl ; then
+ if ! use gnutls ; then
+ elog "Using openSSL"
+ myconf = "--enable-ssl=openssl"
+ else
+ elog "Using gnutls"
+ myconf = "--enable-ssl=gnutls"
+ fi
+ else
+ myconf = "--disable-ssl"
+ fi
+
econf \
$(use_enable gloox) \
$(use_enable otr) \
$(use_enable ssl) \
$(use_enable tcl) \
+ ${myconf} \
|| die "econf failed"
emake || die "emake failed"