summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-03 11:38:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-03 11:38:40 +0000
commite4c85520a27dac1aa71ba44fcb6ab177f735b339 (patch)
treead3d5364beff3cc0c1aa4fab32137b98e2cab358 /net-im/cpop/cpop-0.0.4.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.tar.gz
gentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.tar.bz2
gentoo-2-e4c85520a27dac1aa71ba44fcb6ab177f735b339.zip
#include fix and clean up wrt #343935
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-im/cpop/cpop-0.0.4.ebuild')
-rw-r--r--net-im/cpop/cpop-0.0.4.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/net-im/cpop/cpop-0.0.4.ebuild b/net-im/cpop/cpop-0.0.4.ebuild
index 6fa23d7b56c5..17d98ba2125d 100644
--- a/net-im/cpop/cpop-0.0.4.ebuild
+++ b/net-im/cpop/cpop-0.0.4.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/cpop-0.0.4.ebuild,v 1.5 2004/08/08 00:01:06 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/cpop/cpop-0.0.4.ebuild,v 1.6 2010/11/03 11:38:40 ssuominen Exp $
+
+EAPI=2
+inherit eutils
DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol."
HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
@@ -8,13 +11,18 @@ SRC_URI="http://www.draxil.uklinux.net/hip/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2.2.0
- >=dev-libs/glib-2.0.0"
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+}
src_install() {
- einstall || die
- dodoc COPYING ChangeLog INSTALL README
+ emake DESTDIR="${D}" install || die
+ dodoc README
}