summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-07-29 13:29:00 +0000
committerDon Seiler <rizzo@gentoo.org>2004-07-29 13:29:00 +0000
commit8e378c6b0333f6393d24e335af9fbdce67a9018e (patch)
tree70ce3a5f5ad8e0a7c57071f09832ce5ab8e4a03c /net-im/gaim
parentrevision bump to force updating, peaple that upgraded from 5.0.18 will otherw... (diff)
downloadgentoo-2-8e378c6b0333f6393d24e335af9fbdce67a9018e.tar.gz
gentoo-2-8e378c6b0333f6393d24e335af9fbdce67a9018e.tar.bz2
gentoo-2-8e378c6b0333f6393d24e335af9fbdce67a9018e.zip
Removing obsolete versions and patches
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/files/digest-gaim-0.79-r11
-rw-r--r--net-im/gaim/files/digest-gaim-0.79-r21
-rw-r--r--net-im/gaim/files/gaim-0.79-buddyicon.patch178
-rw-r--r--net-im/gaim/files/gaim-0.80cvs-login.diff16
-rw-r--r--net-im/gaim/gaim-0.79-r1.ebuild133
-rw-r--r--net-im/gaim/gaim-0.79-r2.ebuild134
6 files changed, 0 insertions, 463 deletions
diff --git a/net-im/gaim/files/digest-gaim-0.79-r1 b/net-im/gaim/files/digest-gaim-0.79-r1
deleted file mode 100644
index fed11afa4e60..000000000000
--- a/net-im/gaim/files/digest-gaim-0.79-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8d8758e4ef00187fcfe3ab14e4a3283e gaim-0.79.tar.bz2 4377687
diff --git a/net-im/gaim/files/digest-gaim-0.79-r2 b/net-im/gaim/files/digest-gaim-0.79-r2
deleted file mode 100644
index fed11afa4e60..000000000000
--- a/net-im/gaim/files/digest-gaim-0.79-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8d8758e4ef00187fcfe3ab14e4a3283e gaim-0.79.tar.bz2 4377687
diff --git a/net-im/gaim/files/gaim-0.79-buddyicon.patch b/net-im/gaim/files/gaim-0.79-buddyicon.patch
deleted file mode 100644
index bb67801cf3ee..000000000000
--- a/net-im/gaim/files/gaim-0.79-buddyicon.patch
+++ /dev/null
@@ -1,178 +0,0 @@
-===================================================================
-RCS file: /cvsroot/gaim/gaim/src/buddyicon.c,v
-retrieving revision 1.12
-retrieving revision 1.13
-diff -u -r1.12 -r1.13
---- gaim/gaim/src/buddyicon.c 2004/06/20 08:02:39 1.12
-+++ gaim/gaim/src/buddyicon.c 2004/06/25 05:30:10 1.13
-@@ -32,6 +32,31 @@
- static char *cache_dir = NULL;
- static gboolean icon_caching = TRUE;
-
-+static GaimBuddyIcon *
-+gaim_buddy_icon_create(GaimAccount *account, const char *username)
-+{
-+ GaimBuddyIcon *icon;
-+ GHashTable *icon_cache;
-+
-+ icon = g_new0(GaimBuddyIcon, 1);
-+
-+ gaim_buddy_icon_set_account(icon, account);
-+ gaim_buddy_icon_set_username(icon, username);
-+
-+ icon_cache = g_hash_table_lookup(account_cache, account);
-+
-+ if (icon_cache == NULL)
-+ {
-+ icon_cache = g_hash_table_new(g_str_hash, g_str_equal);
-+
-+ g_hash_table_insert(account_cache, account, icon_cache);
-+ }
-+
-+ g_hash_table_insert(icon_cache,
-+ (char *)gaim_buddy_icon_get_username(icon), icon);
-+ return icon;
-+}
-+
- GaimBuddyIcon *
- gaim_buddy_icon_new(GaimAccount *account, const char *username,
- void *icon_data, size_t icon_len)
-@@ -46,26 +71,7 @@
- icon = gaim_buddy_icons_find(account, username);
-
- if (icon == NULL)
-- {
-- GHashTable *icon_cache;
--
-- icon = g_new0(GaimBuddyIcon, 1);
--
-- gaim_buddy_icon_set_account(icon, account);
-- gaim_buddy_icon_set_username(icon, username);
--
-- icon_cache = g_hash_table_lookup(account_cache, account);
--
-- if (icon_cache == NULL)
-- {
-- icon_cache = g_hash_table_new(g_str_hash, g_str_equal);
--
-- g_hash_table_insert(account_cache, account, icon_cache);
-- }
--
-- g_hash_table_insert(icon_cache,
-- (char *)gaim_buddy_icon_get_username(icon), icon);
-- }
-+ icon = gaim_buddy_icon_create(account, username);
-
- gaim_buddy_icon_ref(icon);
- gaim_buddy_icon_set_data(icon, icon_data, icon_len);
-@@ -335,19 +341,44 @@
- }
-
- GaimBuddyIcon *
--gaim_buddy_icons_find(const GaimAccount *account, const char *username)
-+gaim_buddy_icons_find(GaimAccount *account, const char *username)
- {
- GHashTable *icon_cache;
-+ GaimBuddyIcon *ret = NULL;
-
- g_return_val_if_fail(account != NULL, NULL);
- g_return_val_if_fail(username != NULL, NULL);
-
- icon_cache = g_hash_table_lookup(account_cache, account);
-
-- if (icon_cache == NULL)
-- return NULL;
-+ if ((icon_cache == NULL) || ((ret = g_hash_table_lookup(icon_cache, username)) == NULL)) {
-+ const char *file;
-+ struct stat st;
-+ GaimBuddy *b = gaim_find_buddy(account, username);
-+
-+ if (!b)
-+ return NULL;
-+
-+ if ((file = gaim_blist_node_get_string((GaimBlistNode*)b, "buddy_icon")) == NULL)
-+ return NULL;
-+
-+ if (!stat(file, &st)) {
-+ FILE *f = fopen(file, "rb");
-+ if (f) {
-+ char *data = g_malloc(st.st_size);
-+ fread(data, 1, st.st_size, f);
-+ fclose(f);
-+ ret = gaim_buddy_icon_create(account, username);
-+ gaim_buddy_icon_ref(ret);
-+ gaim_buddy_icon_set_data(ret, data, st.st_size);
-+ gaim_buddy_icon_unref(ret);
-+ g_free(data);
-+ return ret;
-+ }
-+ }
-+ }
-
-- return g_hash_table_lookup(icon_cache, username);
-+ return ret;
- }
-
- void
-===================================================================
-RCS file: /cvsroot/gaim/gaim/src/buddyicon.h,v
-retrieving revision 1.5
-retrieving revision 1.6
-diff -u -r1.5 -r1.6
---- gaim/gaim/src/buddyicon.h 2004/01/10 04:04:55 1.5
-+++ gaim/gaim/src/buddyicon.h 2004/06/25 05:30:10 1.6
-@@ -182,7 +182,7 @@
- *
- * @return The icon data if found, or @c NULL if not found.
- */
--GaimBuddyIcon *gaim_buddy_icons_find(const GaimAccount *account,
-+GaimBuddyIcon *gaim_buddy_icons_find(GaimAccount *account,
- const char *username);
-
- /**
-===================================================================
-RCS file: /cvsroot/gaim/gaim/src/gtkblist.c,v
-retrieving revision 1.127
-retrieving revision 1.128
-diff -u -r1.127 -r1.128
---- gaim/gaim/src/gtkblist.c 2004/06/22 01:05:42 1.127
-+++ gaim/gaim/src/gtkblist.c 2004/06/25 05:30:10 1.128
-@@ -2623,36 +2623,19 @@
-
- static GdkPixbuf *gaim_gtk_blist_get_buddy_icon(GaimBuddy *b)
- {
-- const char *file;
- GdkPixbuf *buf, *ret;
- GdkPixbufLoader *loader;
- GaimBuddyIcon *icon;
- const char *data;
- size_t len;
-- struct stat st;
-
- if (!gaim_prefs_get_bool("/gaim/gtk/blist/show_buddy_icons"))
- return NULL;
-
-- if (!(icon = gaim_buddy_get_icon(b))) {
-- if ((file = gaim_blist_node_get_string((GaimBlistNode*)b, "buddy_icon")) == NULL)
-+ if (!(icon = gaim_buddy_get_icon(b)))
-+ if (!(icon = gaim_buddy_icons_find(b->account, b->name))) /* Not sure I like this...*/
- return NULL;
-
-- /* This is a hack, we should be loading up the GaimBuddyIcon's somewhere
-- * else, like the core, like when we parse the blist.xml file. */
-- if (!stat(file, &st)) {
-- FILE *f = fopen(file, "rb");
-- if (f) {
-- char *data = g_malloc(st.st_size);
-- fread(data, 1, st.st_size, f);
-- fclose(f);
-- gaim_buddy_icons_set_for_user(b->account, b->name, data, st.st_size);
-- g_free(data);
-- }
-- }
--
-- return NULL; /* Either no icon, or we just set one and so this will get called again */
-- }
-
- loader = gdk_pixbuf_loader_new();
- data = gaim_buddy_icon_get_data(icon, &len);
diff --git a/net-im/gaim/files/gaim-0.80cvs-login.diff b/net-im/gaim/files/gaim-0.80cvs-login.diff
deleted file mode 100644
index 38d28eae5049..000000000000
--- a/net-im/gaim/files/gaim-0.80cvs-login.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-===================================================================
-RCS file: /cvsroot/gaim/gaim/src/account.c,v
-retrieving revision 1.91
-retrieving revision 1.92
-diff -u -r1.91 -r1.92
---- gaim/gaim/src/account.c 2004/06/15 02:37:22 1.91
-+++ gaim/gaim/src/account.c 2004/06/29 12:29:22 1.92
-@@ -1253,7 +1253,7 @@
- fprintf(fp, " <setting name='%s' type='int'>%d</setting>\n",
- name, setting->value.integer);
- }
-- else if (setting->type == GAIM_PREF_STRING) {
-+ else if (setting->type == GAIM_PREF_STRING && setting->value.string != NULL) {
- fprintf(fp, " <setting name='%s' type='string'>%s</setting>\n",
- name, setting->value.string);
- }
diff --git a/net-im/gaim/gaim-0.79-r1.ebuild b/net-im/gaim/gaim-0.79-r1.ebuild
deleted file mode 100644
index fcee03206932..000000000000
--- a/net-im/gaim/gaim-0.79-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.79-r1.ebuild,v 1.10 2004/07/19 01:32:30 kloeri Exp $
-
-inherit flag-o-matic eutils gcc
-use debug && inherit debug
-
-IUSE="nls perl spell nas debug crypt cjk gnutls silc evo krb4"
-
-DESCRIPTION="GTK Instant Messenger client"
-HOMEPAGE="http://gaim.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc amd64 ~ppc alpha ~ia64 ~mips ~hppa"
-
-DEPEND=">=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
- nas? ( >=media-libs/nas-1.4.1-r1 )
- sys-devel/gettext
- media-libs/libao
- >=media-libs/audiofile-0.2.0
- perl? ( >=dev-lang/perl-5.8.2-r1
- !<dev-perl/ExtUtils-MakeMaker-6.17 )
- spell? ( >=app-text/gtkspell-2.0.2 )
- dev-libs/nss
- gnutls? ( net-libs/gnutls )
- krb4? ( app-crypt/mit-krb5 )
- !mips? (
- !ia64? ( evo? ( mail-client/evolution ) )
- silc? ( >=net-im/silc-toolkit-0.9.12-r2 )
- )"
-PDEPEND="crypt? ( >=x11-plugins/gaim-encryption-2.27 )"
-
-pkg_setup() {
- ewarn
- ewarn "If you are merging ${P} from an earlier version, you will need"
- ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
- ewarn
- ewarn "If you experience problems with gaim, file them as bugs with"
- ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
- ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
- ewarn "seek help in #gaim."
- ewarn
- ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
- ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
- ewarn "backtraces."
- ewarn
- ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
- ewarn
- for TICKER in 1 2 3 4 5; do
- # Double beep here.
- echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
- echo -ne "\a" ; sleep 1
- done
- sleep 8
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
- epatch ${FILESDIR}/gaim-0.79-buddyicon.patch
-}
-
-src_compile() {
- einfo "Replacing -Os CFLAG with -O2"
- replace-flags -Os -O2
-
- # -msse2 doesn't play nice on gcc 3.2
- [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
-
- local myconf
- use perl || myconf="${myconf} --disable-perl"
- use spell || myconf="${myconf} --disable-gtkspell"
- use nls || myconf="${myconf} --disable-nls"
- use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
- use evo || myconf="${myconf} --disable-gevolution"
- use krb4 && myconf="${myconf} --with-krb4=/usr"
-
- if use gnutls ; then
- myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
- myconf="${myconf} --with-gnutls-libs=/usr/lib"
- else
- myconf="${myconf} --enable-gnutls=no"
- fi
-
- if ! use mips ; then
- if use silc ; then
- myconf="${myconf} --with-silc-includes=/usr/include/silc-toolkit"
- myconf="${myconf} --with-silc-libs=/usr/lib"
- fi
- fi
-
- myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
- myconf="${myconf} --with-nss-includes=/usr/include/nss"
- myconf="${myconf} --with-nspr-libs=/usr/lib"
- myconf="${myconf} --with-nss-libs=/usr/lib"
-
- econf ${myconf} || die "Configuration failed"
-
- emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "Install failed"
- dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If you are merging ${P} from an earlier version, you will need"
- ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
- ewarn
- ewarn "If you experience problems with gaim, file them as bugs with"
- ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
- ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
- ewarn "seek help in #gaim."
- ewarn
- ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
- ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
- ewarn "backtraces."
- ewarn
- ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
- ewarn
- for TICKER in 1 2 3 4 5; do
- # Double beep here.
- echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
- echo -ne "\a" ; sleep 1
- done
- sleep 8
-}
diff --git a/net-im/gaim/gaim-0.79-r2.ebuild b/net-im/gaim/gaim-0.79-r2.ebuild
deleted file mode 100644
index a544851fbc4e..000000000000
--- a/net-im/gaim/gaim-0.79-r2.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.79-r2.ebuild,v 1.2 2004/07/08 15:33:59 rizzo Exp $
-
-inherit flag-o-matic eutils gcc
-use debug && inherit debug
-
-IUSE="nls perl spell nas debug crypt cjk gnutls silc evo krb4"
-
-DESCRIPTION="GTK Instant Messenger client"
-HOMEPAGE="http://gaim.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~mips ~hppa"
-
-DEPEND=">=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
- nas? ( >=media-libs/nas-1.4.1-r1 )
- sys-devel/gettext
- media-libs/libao
- >=media-libs/audiofile-0.2.0
- perl? ( >=dev-lang/perl-5.8.2-r1
- !<dev-perl/ExtUtils-MakeMaker-6.17 )
- spell? ( >=app-text/gtkspell-2.0.2 )
- dev-libs/nss
- gnutls? ( net-libs/gnutls )
- krb4? ( app-crypt/mit-krb5 )
- !mips? (
- !ia64? ( evo? ( mail-client/evolution ) )
- silc? ( >=net-im/silc-toolkit-0.9.12-r2 )
- )"
-PDEPEND="crypt? ( >=x11-plugins/gaim-encryption-2.27 )"
-
-pkg_setup() {
- ewarn
- ewarn "If you are merging ${P} from an earlier version, you will need"
- ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
- ewarn
- ewarn "If you experience problems with gaim, file them as bugs with"
- ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
- ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
- ewarn "seek help in #gaim."
- ewarn
- ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
- ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
- ewarn "backtraces."
- ewarn
- ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
- ewarn
- for TICKER in 1 2 3 4 5; do
- # Double beep here.
- echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
- echo -ne "\a" ; sleep 1
- done
- sleep 8
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
- epatch ${FILESDIR}/gaim-0.79-buddyicon.patch
- epatch ${FILESDIR}/gaim-0.80cvs-login.diff
-}
-
-src_compile() {
- einfo "Replacing -Os CFLAG with -O2"
- replace-flags -Os -O2
-
- # -msse2 doesn't play nice on gcc 3.2
- [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
-
- local myconf
- use perl || myconf="${myconf} --disable-perl"
- use spell || myconf="${myconf} --disable-gtkspell"
- use nls || myconf="${myconf} --disable-nls"
- use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
- use evo || myconf="${myconf} --disable-gevolution"
- use krb4 && myconf="${myconf} --with-krb4=/usr"
-
- if use gnutls ; then
- myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
- myconf="${myconf} --with-gnutls-libs=/usr/lib"
- else
- myconf="${myconf} --enable-gnutls=no"
- fi
-
- if ! use mips ; then
- if use silc ; then
- myconf="${myconf} --with-silc-includes=/usr/include/silc-toolkit"
- myconf="${myconf} --with-silc-libs=/usr/lib"
- fi
- fi
-
- myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
- myconf="${myconf} --with-nss-includes=/usr/include/nss"
- myconf="${myconf} --with-nspr-libs=/usr/lib"
- myconf="${myconf} --with-nss-libs=/usr/lib"
-
- econf ${myconf} || die "Configuration failed"
-
- emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "Install failed"
- dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If you are merging ${P} from an earlier version, you will need"
- ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
- ewarn
- ewarn "If you experience problems with gaim, file them as bugs with"
- ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
- ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
- ewarn "seek help in #gaim."
- ewarn
- ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
- ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
- ewarn "backtraces."
- ewarn
- ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
- ewarn
- for TICKER in 1 2 3 4 5; do
- # Double beep here.
- echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
- echo -ne "\a" ; sleep 1
- done
- sleep 8
-}