summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-15 17:52:52 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-15 17:52:52 +0000
commitb6c0bb773382e6807e138a4654fc9951baddd576 (patch)
tree18e5b1db1f3dc793a74fcd556c5a1020acc57945 /net-im/licq
parentUnmasked qt-3.0.5-r1 (diff)
downloadgentoo-2-b6c0bb773382e6807e138a4654fc9951baddd576.tar.gz
gentoo-2-b6c0bb773382e6807e138a4654fc9951baddd576.tar.bz2
gentoo-2-b6c0bb773382e6807e138a4654fc9951baddd576.zip
Fixes compilation issues with gcc-3.1. Closes #5826.
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog9
-rw-r--r--net-im/licq/files/1.2.0a-config.patch22
-rw-r--r--net-im/licq/files/digest-licq-1.2.0a-r11
-rw-r--r--net-im/licq/licq-1.2.0a-r1.ebuild71
4 files changed, 102 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index c570d182d78f..515d58069417 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.4 2002/08/13 14:45:08 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.5 2002/08/15 17:52:52 agenkin Exp $
+
+*licq-1.2.0a-r1 (13 Aug 2002)
+
+ 15 Aug 2002; Arcady Genkin <agenkin@thpoon.com> licq-1.2.0a-r1.ebuild :
+
+ Added configure patch by <matt@schick.mine.nu> to fix compilation under
+ gcc-3.
*licq-1.2.0a (13 Aug 2002)
diff --git a/net-im/licq/files/1.2.0a-config.patch b/net-im/licq/files/1.2.0a-config.patch
new file mode 100644
index 000000000000..34593b947c44
--- /dev/null
+++ b/net-im/licq/files/1.2.0a-config.patch
@@ -0,0 +1,22 @@
+--- configure.old Wed Jul 31 08:40:07 2002
++++ configure Wed Jul 31 08:40:26 2002
+@@ -2952,7 +2952,7 @@
+
+ ac_ext=C
+ # CXXFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
+-ac_cpp='$CXXCPP $CPPFLAGS'
++ac_cpp='-Wno-deprecated $CXXCPP $CPPFLAGS'
+ ac_compile='${CXX-g++} -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
+ ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ cross_compiling=$ac_cv_prog_cxx_cross
+--- plugins/qt-gui-1.2.0/configure.old Wed Jul 31 08:46:10 2002
++++ plugins/qt-gui-1.2.0/configure Wed Jul 31 08:48:00 2002
+@@ -4544,7 +4544,7 @@
+
+ ac_ext=C
+ # CXXFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
+-ac_cpp='$CXXCPP $CPPFLAGS'
++ac_cpp='-Wno-deprecated $CXXCPP $CPPFLAGS'
+ ac_compile='${CXX-g++} -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
+ ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ cross_compiling=$ac_cv_prog_cxx_cross
diff --git a/net-im/licq/files/digest-licq-1.2.0a-r1 b/net-im/licq/files/digest-licq-1.2.0a-r1
new file mode 100644
index 000000000000..7b91e3648cbf
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.0a-r1
@@ -0,0 +1 @@
+MD5 3f977d83b36b26d1bc716be3e3336315 licq-1.2.0a.tar.bz2 1741476
diff --git a/net-im/licq/licq-1.2.0a-r1.ebuild b/net-im/licq/licq-1.2.0a-r1.ebuild
new file mode 100644
index 000000000000..6a979e9f582e
--- /dev/null
+++ b/net-im/licq/licq-1.2.0a-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.0a-r1.ebuild,v 1.1 2002/08/15 17:52:52 agenkin Exp $
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="x86"
+S=${WORKDIR}/${P}
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PV}-config.patch || die
+}
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui-1.2.0
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.2.0
+ make DESTDIR=${D} install || die
+ fi
+
+}