summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-19 19:32:38 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-19 19:32:38 +0000
commitcd037213148d1ee27abd052f1ef83cde8c847358 (patch)
tree1ae961eee05f5d4dcc373bded03acb2d058f57e5 /net-im/naim
parentInitial addition of the Ratpoison window manager. (diff)
downloadgentoo-2-cd037213148d1ee27abd052f1ef83cde8c847358.tar.gz
gentoo-2-cd037213148d1ee27abd052f1ef83cde8c847358.tar.bz2
gentoo-2-cd037213148d1ee27abd052f1ef83cde8c847358.zip
New version, just worked out with upstream dev, only ~arching for a
short period of time.
Diffstat (limited to 'net-im/naim')
-rw-r--r--net-im/naim/ChangeLog11
-rw-r--r--net-im/naim/files/digest-naim-0.11.4.8_pre11
-rw-r--r--net-im/naim/naim-0.11.4.8_pre1.ebuild51
3 files changed, 62 insertions, 1 deletions
diff --git a/net-im/naim/ChangeLog b/net-im/naim/ChangeLog
index 44025080b052..96e5d21dded0 100644
--- a/net-im/naim/ChangeLog
+++ b/net-im/naim/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-im/naim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.2 2002/10/01 23:08:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.3 2002/10/19 19:32:38 lostlogic Exp $
+
+*naim-0.11.4.8_pre1 (19 Oct 2002)
+
+ 19 Oct 2002; Brandon Low <lostlogic@gentoo.org> naim-0.11.4.8_pre1.ebuild :
+
+ New version thanks to RPI Dan (upstream dev) who I worked with today
+ to get a bug I was experiencing fixed. This version should allow
+ those of us with hugs buddy lists to sign on and not get kicked off
+ immediatly.
*naim-0.11.4p1 (01 Oct 2002)
diff --git a/net-im/naim/files/digest-naim-0.11.4.8_pre1 b/net-im/naim/files/digest-naim-0.11.4.8_pre1
new file mode 100644
index 000000000000..5a7e2f73b316
--- /dev/null
+++ b/net-im/naim/files/digest-naim-0.11.4.8_pre1
@@ -0,0 +1 @@
+MD5 9349be7c4b63df743da9f18f855801ed naim-0.11.4.8-2002-10-19-1516.tar.gz 362848
diff --git a/net-im/naim/naim-0.11.4.8_pre1.ebuild b/net-im/naim/naim-0.11.4.8_pre1.ebuild
new file mode 100644
index 000000000000..771b7dab9c12
--- /dev/null
+++ b/net-im/naim/naim-0.11.4.8_pre1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.4.8_pre1.ebuild,v 1.1 2002/10/19 19:32:38 lostlogic Exp $
+
+MY_P="${PN}-0.11.4.8"
+SRC_URI="http://128.113.139.111/~n/.naim_archive/naim-0.11.4.8-2002-10-19-1516.tar.gz"
+DESCRIPTION="An ncurses AOL Instant Messenger."
+HOMEPAGE="http://site.rpi-acm.org/info/naim/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/glibc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld --enable-detach"
+ use pic && myconf="${myconf} --with-pic"
+ use static && myconf="${myconf} --enable-static=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/naim
+
+ doman naim.1
+
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README doc/*
+
+ insinto /usr/share/${P}
+ newins contrib/README.aimconvert README.aimconvert
+ newins contrib/aimconvert.tcl aimconvert.tcl
+ newins contrib/extractbuddy.sh extractbuddy.sh
+ newins contrib/sendim.sh sendim.sh
+ newins src/cmplhlp2.sh cmplhlp2.sh
+ newins src/cmplhelp.sh cmplhelp.sh
+ newins src/cmplsample.sh cmplsample.sh
+ newins src/genkeys.sh genkeys.sh
+
+ insinto /usr/include/${PN}
+ newins include/modutil.h modutil.h
+ newins include/naim.h naim.h
+ newins include/config.h config.h
+}