summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-09-13 16:01:23 +0000
committerHanno Böck <hanno@gentoo.org>2013-09-13 16:01:23 +0000
commitfa7275ce550576836229c048f43f060ce81d8a5b (patch)
tree7d2aabac498212f31cf317ded53cab8c4b68ec5d /net-im/pyicq-t
parentfix DESCRIPTION (diff)
downloadgentoo-2-fa7275ce550576836229c048f43f060ce81d8a5b.tar.gz
gentoo-2-fa7275ce550576836229c048f43f060ce81d8a5b.tar.bz2
gentoo-2-fa7275ce550576836229c048f43f060ce81d8a5b.zip
pyicq-t: fix deprecated PIL imports, switch to new eclass
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-im/pyicq-t')
-rw-r--r--net-im/pyicq-t/ChangeLog8
-rw-r--r--net-im/pyicq-t/files/pyicq-t-0.8.1.5-pillow-imaging.patch36
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild52
3 files changed, 95 insertions, 1 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index 18c288450120..699beedeb282 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/pyicq-t
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.25 2013/08/03 09:45:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.26 2013/09/13 16:01:23 hanno Exp $
+
+*pyicq-t-0.8.1.5-r2 (13 Sep 2013)
+
+ 13 Sep 2013; <hanno@gentoo.org> +pyicq-t-0.8.1.5-r2.ebuild,
+ +files/pyicq-t-0.8.1.5-pillow-imaging.patch:
+ Fix deprecated PIL imports, switch to new eclass.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> pyicq-t-0.8.1.5.ebuild,
pyicq-t-0.8.1.5-r1.ebuild:
diff --git a/net-im/pyicq-t/files/pyicq-t-0.8.1.5-pillow-imaging.patch b/net-im/pyicq-t/files/pyicq-t-0.8.1.5-pillow-imaging.patch
new file mode 100644
index 000000000000..62df75873c08
--- /dev/null
+++ b/net-im/pyicq-t/files/pyicq-t-0.8.1.5-pillow-imaging.patch
@@ -0,0 +1,36 @@
+diff -Naur pyicqt-0.8.1.5/src/contact.py pyicqt-0.8.1.5-1/src/contact.py
+--- pyicqt-0.8.1.5/src/contact.py 2009-08-24 14:37:59.000000000 +0200
++++ pyicqt-0.8.1.5-1/src/contact.py 2013-09-11 22:19:01.320467367 +0200
+@@ -13,7 +13,7 @@
+ import globals
+ import base64
+ if not config.disableAvatars:
+- import Image
++ import PIL.Image as Image
+ import StringIO
+
+
+diff -Naur pyicqt-0.8.1.5/src/imgmanip.py pyicqt-0.8.1.5-1/src/imgmanip.py
+--- pyicqt-0.8.1.5/src/imgmanip.py 2009-08-24 14:37:59.000000000 +0200
++++ pyicqt-0.8.1.5-1/src/imgmanip.py 2013-09-11 22:19:25.257168117 +0200
+@@ -5,7 +5,7 @@
+
+ if not config.disableAvatars:
+ try:
+- import Image
++ import PIL.Image as Image
+ import StringIO
+
+ def convertToPNG(imageData):
+diff -Naur pyicqt-0.8.1.5/tools/infodump.py pyicqt-0.8.1.5-1/tools/infodump.py
+--- pyicqt-0.8.1.5/tools/infodump.py 2009-08-24 14:37:59.000000000 +0200
++++ pyicqt-0.8.1.5-1/tools/infodump.py 2013-09-11 22:18:34.084807860 +0200
+@@ -41,7 +41,7 @@
+ print "Nevow Version: Unknown or Not Installed"
+
+ try:
+- from Image import VERSION
++ from PIL.Image import VERSION
+ print "Python Imaging Library (PIL) Version: " + VERSION
+ except:
+ print "Python Imaging Library (PIL) Version: Unknown or Not Installed"
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild
new file mode 100644
index 000000000000..fd366a76c279
--- /dev/null
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild,v 1.1 2013/09/13 16:01:23 hanno Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1
+
+MY_P="${P/pyicq-t/pyicqt}"
+
+DESCRIPTION="Python based jabber transport for ICQ"
+HOMEPAGE="http://code.google.com/p/pyicqt/"
+SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ >=dev-python/twisted-core-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-words-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-0.5.0[${PYTHON_USEDEP}]
+ webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python26-warnings.diff"
+ "${FILESDIR}/${P}-pillow-imaging.patch"
+)
+
+src_install() {
+ python_moduleinto ${PN}
+ cp PyICQt.py pyicq-t.py || die
+ python_domodule pyicq-t.py data tools src
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ fperms 755 "$(python_get_sitedir)/${PN}/pyicq-t.py"
+ sed -i \
+ -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ "${ED}/etc/jabber/${PN}.xml"
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
+ sed -i -e "s:INSPATH:$(python_get_sitedir):" "${ED}/etc/init.d/${PN}"
+ python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
+}