summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-05-06 14:38:12 +0000
committerKevin McCarthy <signals@gentoo.org>2011-05-06 14:38:12 +0000
commit0b1148148578680a17423845ba955c24e6304784 (patch)
tree7563d0c0b999cfc4d0a64ea359c6ab6e73b27695 /net-im/reaim/reaim-0.8-r1.ebuild
parentUnmasking boost (diff)
downloadgentoo-2-0b1148148578680a17423845ba955c24e6304784.tar.gz
gentoo-2-0b1148148578680a17423845ba955c24e6304784.tar.bz2
gentoo-2-0b1148148578680a17423845ba955c24e6304784.zip
Respect CC,CFLAGS #365863. Use dohtml -r #365861. Install CREDITS file. EAPI=4 bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'net-im/reaim/reaim-0.8-r1.ebuild')
-rw-r--r--net-im/reaim/reaim-0.8-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-im/reaim/reaim-0.8-r1.ebuild b/net-im/reaim/reaim-0.8-r1.ebuild
new file mode 100644
index 000000000000..76da44190a77
--- /dev/null
+++ b/net-im/reaim/reaim-0.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/reaim/reaim-0.8-r1.ebuild,v 1.1 2011/05/06 14:38:12 signals Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="AIM transport proxy over NAT firewalls"
+HOMEPAGE="http://reaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/reaim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="net-firewall/iptables"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's/gcc/$(CC) $(CFLAGS) $(LDFLAGS)/' \
+ -e 's/ -g / /' Makefile || die "sed failed" #365863
+}
+
+src_install() {
+ dosbin reaim || die
+ doman reaim.8
+ dodoc CREDITS
+ dohtml -r -x CVS html/*
+ newinitd "${FILESDIR}"/reaim reaim
+}