summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-04-14 23:07:44 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-04-14 23:07:44 +0000
commitb14b428892c38694b3b2ad2aea468484021230d6 (patch)
tree08c2d920a6e4d55ebc8b46b9970e433e1e579ccc /net-im/twinkle
parentBashism-- (diff)
downloadgentoo-2-b14b428892c38694b3b2ad2aea468484021230d6.tar.gz
gentoo-2-b14b428892c38694b3b2ad2aea468484021230d6.tar.bz2
gentoo-2-b14b428892c38694b3b2ad2aea468484021230d6.zip
version bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-im/twinkle')
-rw-r--r--net-im/twinkle/ChangeLog7
-rw-r--r--net-im/twinkle/twinkle-1.4.2.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-im/twinkle/ChangeLog b/net-im/twinkle/ChangeLog
index 857f913e3718..fa3c806b88c4 100644
--- a/net-im/twinkle/ChangeLog
+++ b/net-im/twinkle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/twinkle
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.46 2009/02/17 07:07:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/ChangeLog,v 1.47 2009/04/14 23:07:44 dragonheart Exp $
+
+*twinkle-1.4.2 (14 Apr 2009)
+
+ 14 Apr 2009; Daniel Black <dragonheart@gentoo.org> +twinkle-1.4.2.ebuild:
+ version bump
17 Feb 2009; Daniel Black <dragonheart@gentoo.org> twinkle-1.4.1.ebuild:
bad use of kde eclass in EAPI=2. Used a couple of workarounds to fix bug
diff --git a/net-im/twinkle/twinkle-1.4.2.ebuild b/net-im/twinkle/twinkle-1.4.2.ebuild
new file mode 100644
index 000000000000..f940cc548393
--- /dev/null
+++ b/net-im/twinkle/twinkle-1.4.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twinkle/twinkle-1.4.2.ebuild,v 1.1 2009/04/14 23:07:44 dragonheart Exp $
+
+EAPI=2
+ARTS_REQUIRED="never"
+inherit eutils qt3 kde autotools
+
+DESCRIPTION="a soft phone for your VOIP communcations using SIP"
+HOMEPAGE="http://www.twinklephone.com/"
+SRC_URI="http://www.xs4all.nl/~mfnboer/twinkle/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde arts speex ilbc zrtp kdehiddenvisibility"
+
+# Requires libqt-mt actually... Is that *always* built, or do we need to check?
+RDEPEND=">=net-libs/ccrtp-1.6.0
+ >=dev-cpp/commoncpp2-1.6.1
+ x11-libs/qt:3
+ media-libs/libsndfile
+ dev-libs/boost
+ speex? ( media-libs/speex )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ zrtp? ( >=net-libs/libzrtpcpp-1.3.0 )
+ media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use speex && has_version '~media-libs/speex-1.2_beta2' &&
+ ! built_with_use 'media-libs/speex' 'wideband' ; then
+ eerror "You need to build media-libs/speex with USE=wideband enabled."
+ die "Speex w/o wideband-support detected."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.1-kdedetect.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=" \
+ $(use_with kde) \
+ $(use_with ilbc) \
+ $(use_with arts) \
+ $(use_with zrtp) \
+ $(use_with speex)"
+ set-kdedir
+ kde_src_compile configure
+}
+
+src_compile() {
+ kde_src_compile make
+}
+
+src_install() {
+ kde_src_install
+ domenu twinkle.desktop
+ dodoc THANKS
+}