summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-28 13:48:58 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-28 13:48:58 +0000
commit409f2937f6436a43360abbd5a2f3e0776f553406 (patch)
tree0e25f05f874cbb58133ec2ed3d0257a070505b86 /net-im
parentRemove old (diff)
downloadgentoo-2-409f2937f6436a43360abbd5a2f3e0776f553406.tar.gz
gentoo-2-409f2937f6436a43360abbd5a2f3e0776f553406.tar.bz2
gentoo-2-409f2937f6436a43360abbd5a2f3e0776f553406.zip
Revision bump by Michael (kensington) <gentoo@scribeofthenile.com>. Bumps to EAPI 4, fixes QA issues and build with gold linker bug #369449.
(Portage version: 2.2.0_alpha95/cvs/Linux i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog10
-rw-r--r--net-im/qtwitter/files/qtwitter-0.10.0-gold.patch12
-rw-r--r--net-im/qtwitter/qtwitter-0.10.0-r1.ebuild65
-rw-r--r--net-im/qtwitter/qtwitter-0.10.0.ebuild4
4 files changed, 88 insertions, 3 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index ffbfd37f1468..986468c2573a 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.26 2012/03/25 19:16:22 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.27 2012/03/28 13:48:58 johu Exp $
+
+*qtwitter-0.10.0-r1 (28 Mar 2012)
+
+ 28 Mar 2012; Johannes Huber <johu@gentoo.org>
+ +files/qtwitter-0.10.0-gold.patch, +qtwitter-0.10.0-r1.ebuild,
+ qtwitter-0.10.0.ebuild:
+ Revision bump by Michael (kensington) <gentoo@scribeofthenile.com>. Bumps to
+ EAPI 4, fixes QA issues and build with gold linker bug #369449.
25 Mar 2012; Johannes Huber <johu@gentoo.org> -qtwitter-0.9.2.ebuild:
Remove old.
diff --git a/net-im/qtwitter/files/qtwitter-0.10.0-gold.patch b/net-im/qtwitter/files/qtwitter-0.10.0-gold.patch
new file mode 100644
index 000000000000..d5aff527bead
--- /dev/null
+++ b/net-im/qtwitter/files/qtwitter-0.10.0-gold.patch
@@ -0,0 +1,12 @@
+--- qtwitter-app/qtwitter-app.pro
++++ qtwitter-app/qtwitter-app.pro
+@@ -82,7 +82,8 @@
+ else:unix {
+ LIBS += -L$${DESTDIR} \
+ -Wl,-rpath,$${DESTDIR} \
+- $$TWITTERAPI_LIB
++ $$TWITTERAPI_LIB \
++ -lX11
+ target.path = $${INSTALL_PREFIX}/bin
+ PLUGINS_DIR = $${INSTALL_PREFIX}/lib$${LIB_SUFFIX}/$${TARGET}/plugins
+ DEFINES += PLUGINS_DIR='\\\"$${PLUGINS_DIR}\\\"' \ No newline at end of file
diff --git a/net-im/qtwitter/qtwitter-0.10.0-r1.ebuild b/net-im/qtwitter/qtwitter-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..f6550e6859ad
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.10.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.10.0-r1.ebuild,v 1.1 2012/03/28 13:48:58 johu Exp $
+
+EAPI=4
+
+LANGS="nb_NO pt_BR"
+LANGSLONG="ca_ES cs_CZ de_DE es_ES fr_FR it_IT ja_JP pl_PL"
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt-based microblogging client"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/libX11
+ >=x11-libs/qt-core-4.5:4
+ >=x11-libs/qt-gui-4.5:4
+ >=x11-libs/qt-dbus-4.5:4
+ >=dev-libs/qoauth-1.0"
+RDEPEND="${DEPEND}"
+
+DOCS="README CHANGELOG"
+PATCHES=( "${FILESDIR}/${P}-gold.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $LANGS; then
+ langs="$langs ${lingua}"
+ else
+ for a in $LANGSLONG; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -e '/^ *LANGS/,/^$/s/^/#/' \
+ -e "/LANGS =/s/.*/LANGS = ${langs}/" \
+ -i translations/translations.pri || die "sed translations failed"
+
+ # fix insecure runpaths
+ sed -e '/-Wl,-rpath,\$\${DESTDIR}/d' \
+ -i qtwitter-app/qtwitter-app.pro || die "sed rpath failed"
+
+ # to pass validation
+ sed -e 's/Instant Messaging/InstantMessaging/' \
+ -i qtwitter-app/x11/qtwitter.desktop || die "sed .desktop failed"
+}
+
+src_configure() {
+ eqmake4 PREFIX="/usr"
+}
diff --git a/net-im/qtwitter/qtwitter-0.10.0.ebuild b/net-im/qtwitter/qtwitter-0.10.0.ebuild
index 2e668238c533..a5eff13f9e7d 100644
--- a/net-im/qtwitter/qtwitter-0.10.0.ebuild
+++ b/net-im/qtwitter/qtwitter-0.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.10.0.ebuild,v 1.4 2010/01/02 14:05:29 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.10.0.ebuild,v 1.5 2012/03/28 13:48:58 johu Exp $
EAPI="2"