summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-01-13 17:37:34 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-01-13 17:37:34 +0000
commit57dec8f4d56692231be6175a4a6d35dc5e25d604 (patch)
tree0e6843feeb470699dc7c31c997213c298dab5e69 /net-im
parentDisable pypy1.8 to fix broken deps. (diff)
downloadgentoo-2-57dec8f4d56692231be6175a4a6d35dc5e25d604.tar.gz
gentoo-2-57dec8f4d56692231be6175a4a6d35dc5e25d604.tar.bz2
gentoo-2-57dec8f4d56692231be6175a4a6d35dc5e25d604.zip
Bump to 1.2.1, thanks to Nikoli
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/vacuum/ChangeLog9
-rw-r--r--net-im/vacuum/vacuum-1.2.1.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/net-im/vacuum/ChangeLog b/net-im/vacuum/ChangeLog
index 54bc246872f0..e85c6f8e7b2e 100644
--- a/net-im/vacuum/ChangeLog
+++ b/net-im/vacuum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/vacuum
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.8 2012/10/08 17:44:54 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.9 2013/01/13 17:37:34 maksbotan Exp $
+
+*vacuum-1.2.1 (13 Jan 2013)
+
+ 13 Jan 2013; Maxim Koltsov <maksbotan@gentoo.org> +vacuum-1.2.1.ebuild:
+ Bump to 1.2.1, thanks to Nikoli
08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> vacuum-9999.ebuild,
metadata.xml:
diff --git a/net-im/vacuum/vacuum-1.2.1.ebuild b/net-im/vacuum/vacuum-1.2.1.ebuild
new file mode 100644
index 000000000000..9848e16d5438
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.2.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.2.1.ebuild,v 1.1 2013/01/13 17:37:34 maksbotan Exp $
+
+EAPI="4"
+LANGS="de pl ru uk"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Crossplatform Jabber client."
+HOMEPAGE="http://code.google.com/p/vacuum-im"
+SRC_URI="http://vacuum-im.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries"
+IUSE="${PLUGINS// / +}"
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ birthdayreminder? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filemessagearchive? ( messagearchiver )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ pepmanager? ( servicediscovery )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ servermessagearchive? ( messagearchiver )
+ sessionnegotiation? ( dataforms )
+"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.5:4[ssl]
+ >=x11-libs/qt-gui-4.5:4
+ >=dev-libs/openssl-0.9.8k
+ adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
+ net-dns/libidn
+ x11-libs/libXScrnSaver
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS CHANGELOG README TRANSLATORS"
+
+src_prepare() {
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{idn,minizip,zlib}
+}
+
+src_configure() {
+ # linguas
+ local langs="none;" x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+="${x};"
+ done
+
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="${langs}"
+ -DINSTALL_DOCS=OFF
+ -DFORCE_BUNDLED_MINIZIP=OFF
+ )
+
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
+ done
+
+ cmake-utils_src_configure
+}