summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-28 17:56:46 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-28 17:56:46 +0000
commit6d5cad40779671ea4380e617ff1e6efd93abb51b (patch)
tree4f2d2355827df777bf5ccdb76dc7e2805deeca51 /net-im
parentVersion bump (diff)
downloadgentoo-2-6d5cad40779671ea4380e617ff1e6efd93abb51b.tar.gz
gentoo-2-6d5cad40779671ea4380e617ff1e6efd93abb51b.tar.bz2
gentoo-2-6d5cad40779671ea4380e617ff1e6efd93abb51b.zip
Added python3 support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin/ChangeLog6
-rw-r--r--net-im/pidgin/pidgin-2.10.8-r1.ebuild9
-rw-r--r--net-im/pidgin/pidgin-2.10.8.ebuild9
3 files changed, 19 insertions, 5 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 088b78a072fa..c3a229ecf261 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.317 2014/01/28 17:05:37 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.318 2014/01/28 17:56:46 polynomial-c Exp $
+
+ 28 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> pidgin-2.10.8.ebuild,
+ pidgin-2.10.8-r1.ebuild:
+ Added python3 support.
*pidgin-2.10.8-r1 (28 Jan 2014)
*pidgin-2.10.8 (28 Jan 2014)
diff --git a/net-im/pidgin/pidgin-2.10.8-r1.ebuild b/net-im/pidgin/pidgin-2.10.8-r1.ebuild
index c90fa9eec207..d3c904bad6e9 100644
--- a/net-im/pidgin/pidgin-2.10.8-r1.ebuild
+++ b/net-im/pidgin/pidgin-2.10.8-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.8-r1.ebuild,v 1.1 2014/01/28 17:05:37 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.8-r1.ebuild,v 1.2 2014/01/28 17:56:46 polynomial-c Exp $
EAPI=5
GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
inherit autotools flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 python-single-r1
DESCRIPTION="GTK Instant Messenger client"
@@ -231,6 +231,11 @@ src_install() {
fi
use perl && fixlocalpod
+ if use python || use dbus ; then
+ python-optimize
+ python_fix_shebang "${D}"
+ fi
+
dodoc finch/plugins/pietray.py
docompress -x /usr/share/doc/${PF}/pietray.py
diff --git a/net-im/pidgin/pidgin-2.10.8.ebuild b/net-im/pidgin/pidgin-2.10.8.ebuild
index fb0e4e25881a..e94fc4e6b653 100644
--- a/net-im/pidgin/pidgin-2.10.8.ebuild
+++ b/net-im/pidgin/pidgin-2.10.8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.8.ebuild,v 1.1 2014/01/28 17:05:37 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.8.ebuild,v 1.2 2014/01/28 17:56:46 polynomial-c Exp $
EAPI=5
GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
inherit autotools flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 python-single-r1
DESCRIPTION="GTK Instant Messenger client"
@@ -229,6 +229,11 @@ src_install() {
fi
use perl && fixlocalpod
+ if use python || use dbus ; then
+ python_optimize
+ python_fix_shebang "${D}"
+ fi
+
dodoc finch/plugins/pietray.py
docompress -x /usr/share/doc/${PF}/pietray.py