summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-02-17 17:37:55 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-02-17 17:37:55 +0000
commit74b0fa5faa2897b74464b253dbc21c8ebd70e1dc (patch)
treebb3522bd6eac12d9a4a6682ce52d0bb8a23fb1b1 /net-im
parentreversed patch (diff)
downloadgentoo-2-74b0fa5faa2897b74464b253dbc21c8ebd70e1dc.tar.gz
gentoo-2-74b0fa5faa2897b74464b253dbc21c8ebd70e1dc.tar.bz2
gentoo-2-74b0fa5faa2897b74464b253dbc21c8ebd70e1dc.zip
Added patch to source to solve bug 40930
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnophone/ChangeLog10
-rw-r--r--net-im/gnophone/Manifest6
-rw-r--r--net-im/gnophone/files/digest-gnophone-0.2.4-r11
-rw-r--r--net-im/gnophone/files/gnophone-0.2.4-mkdtmf.c.patch34
-rw-r--r--net-im/gnophone/files/gnophone-0.2.4-raw2h.c.patch36
-rw-r--r--net-im/gnophone/gnophone-0.2.4-r1.ebuild60
-rw-r--r--net-im/gnophone/gnophone-0.2.4.ebuild4
7 files changed, 147 insertions, 4 deletions
diff --git a/net-im/gnophone/ChangeLog b/net-im/gnophone/ChangeLog
index 3f938d389de4..e407bbbcdac4 100644
--- a/net-im/gnophone/ChangeLog
+++ b/net-im/gnophone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/gnophone
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/ChangeLog,v 1.3 2003/04/16 17:52:58 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/ChangeLog,v 1.4 2004/02/17 17:37:54 humpback Exp $
+
+*gnophone-0.2.4-r1 (17 Feb 2004)
+
+ 17 Feb 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ gnophone-0.2.4-r1.ebuild, gnophone-0.2.4.ebuild,
+ files/gnophone-0.2.4-mkdtmf.c.patch, files/gnophone-0.2.4-raw2h.c.patch:
+ Added patch to source to solve bug 40930. Credits go to Russell Cloran
+ <russell@rucus.net> for the patch. Also cleaned up dependencies.
*gnophone-0.2.4 (27 Jul 2002)
diff --git a/net-im/gnophone/Manifest b/net-im/gnophone/Manifest
index 7e134c0daca7..5c1a95f353dc 100644
--- a/net-im/gnophone/Manifest
+++ b/net-im/gnophone/Manifest
@@ -1,3 +1,7 @@
MD5 7ccc41f9d92d1c162d92033671c451f5 ChangeLog 522
-MD5 df618f77b50c1901925980c5477b9175 gnophone-0.2.4.ebuild 1461
+MD5 b293f1e6af44ddc2091b880c76a24524 gnophone-0.2.4-r1.ebuild 1345
+MD5 36b2439321505d0d59aff4da9a52265d gnophone-0.2.4.ebuild 1461
+MD5 4491f5ada043c04c52d153a8ca3e3e1a files/gnophone-0.2.4-raw2h.c.patch 1109
MD5 caf70915f318d848269f9905180332bb files/digest-gnophone-0.2.4 66
+MD5 6cd74b6387f8377850159ed555dc1af0 files/gnophone-0.2.4-mkdtmf.c.patch 873
+MD5 caf70915f318d848269f9905180332bb files/digest-gnophone-0.2.4-r1 66
diff --git a/net-im/gnophone/files/digest-gnophone-0.2.4-r1 b/net-im/gnophone/files/digest-gnophone-0.2.4-r1
new file mode 100644
index 000000000000..d9f49af9de92
--- /dev/null
+++ b/net-im/gnophone/files/digest-gnophone-0.2.4-r1
@@ -0,0 +1 @@
+MD5 75cee76acbd930ccdf473352b1beab30 gnophone-0.2.4.tar.gz 467136
diff --git a/net-im/gnophone/files/gnophone-0.2.4-mkdtmf.c.patch b/net-im/gnophone/files/gnophone-0.2.4-mkdtmf.c.patch
new file mode 100644
index 000000000000..5a07c14b6fb3
--- /dev/null
+++ b/net-im/gnophone/files/gnophone-0.2.4-mkdtmf.c.patch
@@ -0,0 +1,34 @@
+--- sounds/mkdtmf.c.orig 2001-09-21 21:37:37.000000000 +0200
++++ sounds/mkdtmf.c 2004-02-17 17:22:40.781403496 +0200
+@@ -25,19 +25,18 @@
+ if (argc != 3)
+ exit(1);
+
+- printf(
+-"/*
+- * Signed 16-bit audio data representing '%s' in dtmf
+- *
+- * Copyright (C) 2000, Linux Support Services, Inc.
+- *
+- * Distributed under the terms of the GNU General
+- * Public License
+- *
+- */
+-
+-static short %s[] = {
+-", argv[1], argv[2]);
++ printf("/* \n"
++ " * Signed 16-bit audio data representing '%s' in dtmf\n"
++ " * \n"
++ " * Copyright (C) 2000, Linux Support Services, Inc.\n"
++ " * \n"
++ " * Distributed under the terms of the GNU General\n"
++ " * Public License\n"
++ " *\n"
++ " */\n"
++ "\n"
++ "static short %s[] = { \n",
++ argv[1], argv[2]);
+
+ ap = argv[1];
+ while (*ap) {
diff --git a/net-im/gnophone/files/gnophone-0.2.4-raw2h.c.patch b/net-im/gnophone/files/gnophone-0.2.4-raw2h.c.patch
new file mode 100644
index 000000000000..003a525f4b4e
--- /dev/null
+++ b/net-im/gnophone/files/gnophone-0.2.4-raw2h.c.patch
@@ -0,0 +1,36 @@
+--- sounds/raw2h.c.orig 2001-09-21 21:37:37.000000000 +0200
++++ sounds/raw2h.c 2004-02-17 17:18:07.678921384 +0200
+@@ -28,20 +28,19 @@
+ res = read(i, buf, sizeof(buf));
+ assert(res >= 0);
+ assert(res < sizeof(buf));
+- fprintf(o,
+-"/*
+- * Signed 16-bit audio data
+- *
+- * Source: %s
+- *
+- * Copyright (C) 1999, Mark Spencer and Linux Support Services
+- *
+- * Distributed under the terms of the GNU General Public License
+- *
+- */
+-
+-static signed short %s[] = {
+-", argv[1], n);
++ fprintf(o, "/*\n"
++ " * Signed 16-bit audio data\n"
++ " *\n"
++ " * Source: %s\n"
++ " *\n"
++ " * Copyright (C) 1999, Mark Spencer and Linux Support Services\n"
++ " *\n"
++ " * Distributed under the terms of the GNU General Public License\n"
++ " *\n"
++ " */\n"
++ "\n"
++ "static signed short %s[] = {\n",
++ argv[1], n);
+ for (x=0;x<res/2 - 1;x++) {
+ fprintf(o, "%#06hx, ", buf[x]);
+ if ((x % 10) == 9)
diff --git a/net-im/gnophone/gnophone-0.2.4-r1.ebuild b/net-im/gnophone/gnophone-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..1a0b2a3b63c8
--- /dev/null
+++ b/net-im/gnophone/gnophone-0.2.4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/gnophone-0.2.4-r1.ebuild,v 1.1 2004/02/17 17:37:54 humpback Exp $
+
+DESCRIPTION="internet telephone"
+HOMEPAGE="http://www.gnophone.com/"
+SRC_URI="ftp://ftp.gnophone.com/pub/gnophone/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="media-sound/gsm
+ net-libs/iax
+ media-sound/sox
+ mozilla? ( net-www/mozilla )
+ esd? ( media-sound/esound )
+ x11-libs/gtk+
+ media-libs/gdk-pixbuf
+ dev-libs/glib
+ x11-base/xfree
+ media-libs/imlib
+ virtual/glibc"
+
+
+D_PREFIX=/usr
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-raw2h.c.patch
+ epatch ${FILESDIR}/${P}-mkdtmf.c.patch
+}
+
+src_compile() {
+ local myconf
+
+ use mozilla \
+ && myconf="${myconf}
+ --with-mozilla-home=/usr/lib/mozilla
+ --with-mozilla-lib=/usr/lib/mozilla
+ --with-mozilla-include=/usr/lib/mozilla/include" \
+ || myconf="${myconf} --disable-mozilla"
+ use esd \
+ || myconf="${myconf} --disable-esd"
+
+ ./configure ${myconf} \
+ --prefix=${D_PREFIX} --enable-upgrade --disable-zaptel \
+ || die "./configure failed"
+
+ pushd ${S}/sounds && make && popd # -j2 breaks the sound build
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/${D_PREFIX} install
+ dodoc NEWS COPYING AUTHORS README
+}
diff --git a/net-im/gnophone/gnophone-0.2.4.ebuild b/net-im/gnophone/gnophone-0.2.4.ebuild
index 30f374e32b92..350ebf80b455 100644
--- a/net-im/gnophone/gnophone-0.2.4.ebuild
+++ b/net-im/gnophone/gnophone-0.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/gnophone-0.2.4.ebuild,v 1.4 2003/09/05 23:58:58 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/gnophone-0.2.4.ebuild,v 1.5 2004/02/17 17:37:54 humpback Exp $
IUSE=""