summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-01 20:09:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-01 20:09:46 +0000
commit8796e99425d79a0bd26cb0fc2c6f3c60d82970b6 (patch)
tree4be2d6aeb4c332ed660e139a603d6a71ae1e2c99 /net-im
parentStable on amd64 (bug #142427). (diff)
downloadgentoo-2-8796e99425d79a0bd26cb0fc2c6f3c60d82970b6.tar.gz
gentoo-2-8796e99425d79a0bd26cb0fc2c6f3c60d82970b6.tar.bz2
gentoo-2-8796e99425d79a0bd26cb0fc2c6f3c60d82970b6.zip
Add patch from Marco Gulino to get the correct updated MSN profile URL.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog8
-rw-r--r--net-im/kopete/files/digest-kopete-0.12.1-r43
-rw-r--r--net-im/kopete/files/kopete-0.12-msnprofile.diff12
-rw-r--r--net-im/kopete/kopete-0.12.1-r4.ebuild138
4 files changed, 160 insertions, 1 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index 8ca5d13823d4..d131f64f6e36 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.76 2006/07/31 18:53:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.77 2006/08/01 20:09:46 flameeyes Exp $
+
+*kopete-0.12.1-r4 (01 Aug 2006)
+
+ 01 Aug 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-0.12-msnprofile.diff, +kopete-0.12.1-r4.ebuild:
+ Add patch from Marco Gulino to get the correct updated MSN profile URL.
*kopete-0.12.1-r3 (31 Jul 2006)
diff --git a/net-im/kopete/files/digest-kopete-0.12.1-r4 b/net-im/kopete/files/digest-kopete-0.12.1-r4
new file mode 100644
index 000000000000..2f6f75f34afa
--- /dev/null
+++ b/net-im/kopete/files/digest-kopete-0.12.1-r4
@@ -0,0 +1,3 @@
+MD5 b646f2f45fc0fbcd56ada5078fb540fb kopete-0.12.1.tar.bz2 5309636
+RMD160 0bb66fb0a8a0d12b0d19845d5a39993520cb368d kopete-0.12.1.tar.bz2 5309636
+SHA256 a18174bf48257361c6a337073e2fa1c7dc0b0eba274d558ac9fd5bc84275927e kopete-0.12.1.tar.bz2 5309636
diff --git a/net-im/kopete/files/kopete-0.12-msnprofile.diff b/net-im/kopete/files/kopete-0.12-msnprofile.diff
new file mode 100644
index 000000000000..6ad62759679d
--- /dev/null
+++ b/net-im/kopete/files/kopete-0.12-msnprofile.diff
@@ -0,0 +1,12 @@
+diff -ru kopete-0.12.1.orig/kopete/protocols/msn/msncontact.cpp kopete-0.12.1/kopete/protocols/msn/msncontact.cpp
+--- kopete-0.12.1.orig/kopete/protocols/msn/msncontact.cpp 2006-07-13 02:55:41.000000000 +0200
++++ kopete-0.12.1/kopete/protocols/msn/msncontact.cpp 2006-08-01 14:24:20.000000000 +0200
+@@ -577,7 +577,7 @@
+
+ void MSNContact::slotShowProfile()
+ {
+- KRun::runURL( KURL( QString::fromLatin1("http://members.msn.com/default.msnw?mem=") + contactId()) , "text/html" );
++ KRun::runURL( KURL( QString::fromLatin1("http://members.msn.com/?pgmarket=it-it&mem=") + contactId()) , "text/html" );
+ }
+
+
diff --git a/net-im/kopete/kopete-0.12.1-r4.ebuild b/net-im/kopete/kopete-0.12.1-r4.ebuild
new file mode 100644
index 000000000000..1cdae425189c
--- /dev/null
+++ b/net-im/kopete/kopete-0.12.1-r4.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.1-r4.ebuild,v 1.1 2006/08/01 20:09:46 flameeyes Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/-}"
+MY_P="${MY_P/.0/}"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ slp? ( net-libs/openslp )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ latex? ( virtual/tetex )
+ crypt? ( app-crypt/gnupg )"
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) <virtual/x11-7 )"
+
+need-kde 3.4
+
+#dev-libs/ilbc-rfc3951: could not see any benifit in it
+#sed -i 's:ilbc_found="no":ilbc_found="yes":' ${S}/kopete/protocols/jabber/jingle/configure.in.in
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+ # use ekiga instead of gnomemeeting by default
+ epatch "${FILESDIR}/gnomemeeting-ekiga.patch"
+ # Bug #141675
+ epatch "${FILESDIR}/${P}-oscarcontacts.patch"
+ # KDE BUG #130630
+ epatch "${FILESDIR}/${P}-icqfix3.patch"
+ # KDE revision 568520
+ epatch "${FILESDIR}/${PN}-0.12-msnprofile.diff"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}"/usr/bin/{stun,relay}server
+}