summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2014-03-30 12:49:40 +0000
committerWolfram Schlich <wschlich@gentoo.org>2014-03-30 12:49:40 +0000
commita7c15b6b8692360a70d72416747c1d2ec15536ab (patch)
tree53c56c47ddfd7171001d4d04c6f136f1efecc57c /net-im
parentRestore old (without py2.6 though) since it is required by OpenStack packages. (diff)
downloadgentoo-2-a7c15b6b8692360a70d72416747c1d2ec15536ab.tar.gz
gentoo-2-a7c15b6b8692360a70d72416747c1d2ec15536ab.tar.bz2
gentoo-2-a7c15b6b8692360a70d72416747c1d2ec15536ab.zip
fix bug #409499
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog11
-rw-r--r--net-im/mcabber/files/mcabber-0.10.2_p20131025-vim-ftdetect.patch12
-rw-r--r--net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild118
3 files changed, 139 insertions, 2 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index 12725eea63b2..4d7de3eca5ef 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/mcabber
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.61 2013/11/09 19:20:45 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.62 2014/03/30 12:49:40 wschlich Exp $
+
+*mcabber-0.10.2_p20131025-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Wolfram Schlich <wschlich@gentoo.org>
+ +files/mcabber-0.10.2_p20131025-vim-ftdetect.patch,
+ +mcabber-0.10.2_p20131025-r1.ebuild:
+ fix bug #409499
*mcabber-0.10.2_p20131025 (09 Nov 2013)
diff --git a/net-im/mcabber/files/mcabber-0.10.2_p20131025-vim-ftdetect.patch b/net-im/mcabber/files/mcabber-0.10.2_p20131025-vim-ftdetect.patch
new file mode 100644
index 000000000000..015d3693ee97
--- /dev/null
+++ b/net-im/mcabber/files/mcabber-0.10.2_p20131025-vim-ftdetect.patch
@@ -0,0 +1,12 @@
+diff -urN mcabber-a18e1b488f1c.orig/mcabber/contrib/vim/mcabber_log-ftdetect.vim mcabber-a18e1b488f1c/mcabber/contrib/vim/mcabber_log-ftdetect.vim
+--- mcabber-a18e1b488f1c.orig/mcabber/contrib/vim/mcabber_log-ftdetect.vim 2013-10-25 22:20:23.000000000 +0200
++++ mcabber-a18e1b488f1c/mcabber/contrib/vim/mcabber_log-ftdetect.vim 2014-03-30 14:41:31.975129825 +0200
+@@ -1,7 +1,7 @@
+ "
+ " Save this file in your ~/.vim/ftdetect/ folder
+
+-function MCabber_log_ftdetect()
++function! MCabber_log_ftdetect()
+ if getline(1) =~ '^\u. \d\{8}T\d\d:\d\d:\d\dZ \d\{3} '
+ setlocal filetype=mcabber_log
+ endif
diff --git a/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild b/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild
new file mode 100644
index 000000000000..7ab5dba91683
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild,v 1.1 2014/03/30 12:49:40 wschlich Exp $
+
+EAPI=5
+
+inherit flag-o-matic autotools-utils
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://mcabber.com/"
+REV="a18e1b488f1c"
+SRC_URI="http://mcabber.com/hg/index.cgi/archive/${REV}.tar.gz -> ${P}.tar.gz"
+
+S=${WORKDIR}/${PN}-${REV}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="aspell crypt idn modules otr spell ssl vim-syntax"
+
+LANGS="cs de fr it nl pl ru uk"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( >=net-libs/libotr-3.1.0 )
+ aspell? ( app-text/aspell )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ idn? ( net-dns/libidn )
+ spell? ( app-text/enchant )
+ dev-libs/glib:2
+ sys-libs/ncurses
+ >=net-libs/loudmouth-1.4.3-r1[ssl?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt )
+PATCHES=(
+ "${FILESDIR}/${P}-vim-ftdetect.patch"
+)
+
+pkg_setup() {
+ if use aspell && use spell; then
+ ewarn "NOTE: You have both USE flags 'aspell' and 'spell' enabled, enchant (USE flag 'spell') will be preferred."
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable crypt gpgme) \
+ $(use_enable otr) \
+ $(use_enable aspell) \
+ $(use_enable spell enchant) \
+ $(use_enable modules) \
+ $(use_with idn libidn)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ use linguas_${i} || rm -rf "${ED}"/usr/share/${PN}/help/${i}
+ done
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins "${S}"/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe "${S}"/contrib/*.{pl,py}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe "${S}"/contrib/events/*
+
+ if use vim-syntax; then
+ cd contrib/vim/ || die
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins mcabber_log-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins mcabber_log-ftdetect.vim
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ echo
+ einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts."
+ echo
+}