summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-03-20 23:34:40 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-03-20 23:34:40 +0000
commitc681437d1599f05b3674fa1ca33a83b827e8e2d7 (patch)
tree3372f2a9eeb19c2caebab71fa0432ba54f887760 /net-im
parentnew release (diff)
downloadgentoo-2-c681437d1599f05b3674fa1ca33a83b827e8e2d7.tar.gz
gentoo-2-c681437d1599f05b3674fa1ca33a83b827e8e2d7.tar.bz2
gentoo-2-c681437d1599f05b3674fa1ca33a83b827e8e2d7.zip
Backported spec_config function, which change libs paths in arts_sound module, bug #85994
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kadu/ChangeLog6
-rw-r--r--net-im/kadu/kadu-0.3.9.ebuild15
2 files changed, 18 insertions, 3 deletions
diff --git a/net-im/kadu/ChangeLog b/net-im/kadu/ChangeLog
index 69846cd65960..553f9d95ec57 100644
--- a/net-im/kadu/ChangeLog
+++ b/net-im/kadu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/kadu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.19 2005/03/20 11:24:30 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.20 2005/03/20 23:34:40 sekretarz Exp $
+
+ 21 Mar 2005; Karol Wojtaszek <sekretarz@gentoo.org> kadu-0.3.9.ebuild:
+ Backported spec_config function, which change libs paths in arts_sound
+ module, bug #85994
*kadu-0.4.0_rc2-r1 (20 Mar 2005)
diff --git a/net-im/kadu/kadu-0.3.9.ebuild b/net-im/kadu/kadu-0.3.9.ebuild
index 7ff078d2059f..46a8f26548e6 100644
--- a/net-im/kadu/kadu-0.3.9.ebuild
+++ b/net-im/kadu/kadu-0.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.3.9.ebuild,v 1.4 2005/03/18 15:11:32 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.3.9.ebuild,v 1.5 2005/03/20 23:34:40 sekretarz Exp $
inherit flag-o-matic eutils
@@ -26,6 +26,11 @@ DEPEND=">=x11-libs/qt-3.0.1
S=${WORKDIR}/${PN}
+spec_config() {
+ sed -i -r "s/(^${2}\\s*=\\s*).*//" modules/${1}/spec
+ echo "${2}=${3}" >> modules/${1}/spec
+}
+
module_config() {
sed -i -r "s/(^module_${1}\\s*=\\s*).*/\\1${2}/" .config
}
@@ -42,8 +47,14 @@ src_compile() {
# dynamic modules
use alsa || use oss || module_config dsp_sound n
- use arts && module_config arts_sound m
use esd && module_config esd_sound m
+ if use arts; then
+ module_config arts_sound m
+ # Fix kde libs paths
+ spec_config arts_sound MODULE_INCLUDES_PATH "\"$(kde-config --prefix)/include $(kde-config --prefix)/include/arts\""
+ spec_config arts_sound MODULE_LIBS_PATH $(kde-config --prefix)/lib
+ fi
+
if use nas; then
module_config nas_sound m
epatch "${FILESDIR}/${P}-nas-gentoo.diff"