summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-08 19:23:35 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-08 19:23:35 +0000
commitc89ee3906d5a8d4ffa66fae350b6853071995642 (patch)
tree5d6a95fda68ffb0fd9558a89e223cdf9cb574592 /net-im
parentAdded first version of patch against font problems. (diff)
downloadgentoo-2-c89ee3906d5a8d4ffa66fae350b6853071995642.tar.gz
gentoo-2-c89ee3906d5a8d4ffa66fae350b6853071995642.tar.bz2
gentoo-2-c89ee3906d5a8d4ffa66fae350b6853071995642.zip
Version bump wrt #182274
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-toolkit/ChangeLog9
-rw-r--r--net-im/silc-toolkit/files/digest-silc-toolkit-1.1.23
-rw-r--r--net-im/silc-toolkit/silc-toolkit-1.1.2.ebuild55
3 files changed, 65 insertions, 2 deletions
diff --git a/net-im/silc-toolkit/ChangeLog b/net-im/silc-toolkit/ChangeLog
index a79ff92427b1..6eaa3f3ae74d 100644
--- a/net-im/silc-toolkit/ChangeLog
+++ b/net-im/silc-toolkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/silc-toolkit
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/ChangeLog,v 1.58 2006/11/23 22:11:33 dertobi123 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/ChangeLog,v 1.59 2007/07/08 19:23:35 armin76 Exp $
+
+*silc-toolkit-1.1.2 (08 Jul 2007)
+
+ 08 Jul 2007; Raúl Porcel <armin76@gentoo.org> +silc-toolkit-1.1.2.ebuild:
+ Version bump wrt #182274
23 Nov 2006; Tobias Scherbaum <dertobi123@gentoo.org>
silc-toolkit-1.0.2.ebuild:
diff --git a/net-im/silc-toolkit/files/digest-silc-toolkit-1.1.2 b/net-im/silc-toolkit/files/digest-silc-toolkit-1.1.2
new file mode 100644
index 000000000000..7368389ac056
--- /dev/null
+++ b/net-im/silc-toolkit/files/digest-silc-toolkit-1.1.2
@@ -0,0 +1,3 @@
+MD5 9392d160a5654eef3e24829c064d7602 silc-toolkit-1.1.2.tar.bz2 1928386
+RMD160 4f000736a93db71487e9e67ef294f2a2ff9a71f4 silc-toolkit-1.1.2.tar.bz2 1928386
+SHA256 ac0aab6d1d633683bfe57de5d7a3efc38fe66e3b9e055cdb9493887e9d0d4ef3 silc-toolkit-1.1.2.tar.bz2 1928386
diff --git a/net-im/silc-toolkit/silc-toolkit-1.1.2.ebuild b/net-im/silc-toolkit/silc-toolkit-1.1.2.ebuild
new file mode 100644
index 000000000000..a7d6f4160c28
--- /dev/null
+++ b/net-im/silc-toolkit/silc-toolkit-1.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-toolkit/silc-toolkit-1.1.2.ebuild,v 1.1 2007/07/08 19:23:35 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="SDK for the SILC protocol"
+HOMEPAGE="http://silcnet.org/"
+SRC_URI="http://silcnet.org/download/toolkit/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug ipv6"
+
+RDEPEND=""
+DEPEND="dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ # They have incorrect DESTDIR usage
+ sed -i '/\$(srcdir)\/tutorial/s/\$(prefix)/\$(docdir)/' "${S}"/Makefile.{am,in}
+}
+
+src_compile() {
+ local myconf=""
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ econf \
+ --datadir=/usr/share/${PN} \
+ --datarootdir=/usr/share/${PN} \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include/${PN} \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/${PN}/help \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-optimizations \
+ $(use_enable debug)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm -rf \
+ "${D}"/etc/${PN}/silcd.conf \
+ "${D}"/usr/share/man \
+ "${D}"/usr/share/doc/${PF}/examples \
+ "${D}"/usr/share/silc-toolkit \
+ "${D}"/var/log/silc-toolkit \
+ "${D}"/etc/silc
+}