summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-11-19 23:08:00 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-11-19 23:08:00 +0000
commitcc41013129dd5c28d19dd516ee40139137c62a57 (patch)
treec6e2eca6681aa247c521a96286c4bd1292397877 /net-im
parentInitial virtual ebuilds and package for Java Servlet API implemenations. (diff)
downloadgentoo-2-cc41013129dd5c28d19dd516ee40139137c62a57.tar.gz
gentoo-2-cc41013129dd5c28d19dd516ee40139137c62a57.tar.bz2
gentoo-2-cc41013129dd5c28d19dd516ee40139137c62a57.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog7
-rw-r--r--net-im/mcabber/files/digest-mcabber-0.9.43
-rw-r--r--net-im/mcabber/mcabber-0.9.4.ebuild87
3 files changed, 96 insertions, 1 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index 6f1e1d4a1002..abacc46b461c 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/mcabber
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.17 2007/06/26 16:18:19 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.18 2007/11/19 23:07:59 wschlich Exp $
+
+*mcabber-0.9.4 (19 Nov 2007)
+
+ 19 Nov 2007; Wolfram Schlich <wschlich@gentoo.org> +mcabber-0.9.4.ebuild:
+ version bump
26 Jun 2007; Wolfram Schlich <wschlich@gentoo.org> mcabber-0.9.3.ebuild:
added aspell support wrt bug #182760
diff --git a/net-im/mcabber/files/digest-mcabber-0.9.4 b/net-im/mcabber/files/digest-mcabber-0.9.4
new file mode 100644
index 000000000000..31993e829ca1
--- /dev/null
+++ b/net-im/mcabber/files/digest-mcabber-0.9.4
@@ -0,0 +1,3 @@
+MD5 5ac405d0661c7c0c2893e65893c8ae8e mcabber-0.9.4.tar.bz2 484395
+RMD160 ee1c7ffdf45e1278304233a0f0de835309f08923 mcabber-0.9.4.tar.bz2 484395
+SHA256 1a8a0bc4a7b89b4a6b351295750a541f1bda4facb1c48726477cd309c29619ef mcabber-0.9.4.tar.bz2 484395
diff --git a/net-im/mcabber/mcabber-0.9.4.ebuild b/net-im/mcabber/mcabber-0.9.4.ebuild
new file mode 100644
index 000000000000..b8c0a3c42004
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.4.ebuild,v 1.1 2007/11/19 23:07:59 wschlich Exp $
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+SRC_URI="http://www.lilotux.net/~mikael/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="crypt spell ssl"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ spell? ( app-text/aspell )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable spell aspell) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins ${S}/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe ${S}/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe ${S}/contrib/events/*
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "As of MCabber version 0.8.2, there is also a wizard script"
+ elog "with which you can create all necessary configuration options."
+ elog "To use it, simply execute the following command:"
+ elog
+ elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ elog
+ elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ elog
+}