summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-01-29 22:44:48 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-01-29 22:44:48 +0000
commitd56c6a97f90b590291b5703caa3705af3c2b5b6d (patch)
treec5d9953105f34b7a413eebb5e8d872080558bb7e /net-im
parentMake libsamplerate dependency both explicit & optional. Patch by Rafa? Mu?y?o... (diff)
downloadgentoo-2-d56c6a97f90b590291b5703caa3705af3c2b5b6d.tar.gz
gentoo-2-d56c6a97f90b590291b5703caa3705af3c2b5b6d.tar.bz2
gentoo-2-d56c6a97f90b590291b5703caa3705af3c2b5b6d.zip
Bump to 5.6.1, mostly bugfixes
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-mission-control/ChangeLog10
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.6.1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/net-im/telepathy-mission-control/ChangeLog b/net-im/telepathy-mission-control/ChangeLog
index 4287bc96c44a..79dba8d283a7 100644
--- a/net-im/telepathy-mission-control/ChangeLog
+++ b/net-im/telepathy-mission-control/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/telepathy-mission-control
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.35 2010/09/29 18:30:58 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/ChangeLog,v 1.36 2011/01/29 22:44:48 nirbheek Exp $
+
+*telepathy-mission-control-5.6.1 (29 Jan 2011)
+
+ 29 Jan 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +telepathy-mission-control-5.6.1.ebuild:
+ Bump to 5.6.1, mostly bugfixes
*telepathy-mission-control-5.6.0 (29 Sep 2010)
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.6.1.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.6.1.ebuild
new file mode 100644
index 000000000000..eafe530fdee9
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-5.6.1.ebuild,v 1.1 2011/01/29 22:44:48 nirbheek Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Telepathy Mission Control"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/telepathy-mission-control/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome-keyring test"
+
+RDEPEND=">=net-libs/telepathy-glib-0.11.9
+ >=dev-libs/dbus-glib-0.82
+ >=gnome-base/gconf-2
+ gnome-keyring? ( || ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? ( >=virtual/python-2.5
+ dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334
+RESTRICT="test"
+
+src_configure() {
+ # creds is not available and no support mcd-plugins for now
+ econf $(use_enable gnome-keyring) \
+ --disable-mcd-plugins
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog || die
+}