summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2009-07-30 11:47:41 +0000
committerWolfram Schlich <wschlich@gentoo.org>2009-07-30 11:47:41 +0000
commitdfb28f0d371b9137af5d5bf71190e69ecca073d0 (patch)
treed4334b3f484b5dc6d4768eb435c07295ebf5465a /net-im
parentFix building with GCC 4.4 wrt #277659. (diff)
downloadgentoo-2-dfb28f0d371b9137af5d5bf71190e69ecca073d0.tar.gz
gentoo-2-dfb28f0d371b9137af5d5bf71190e69ecca073d0.tar.bz2
gentoo-2-dfb28f0d371b9137af5d5bf71190e69ecca073d0.zip
fix bugs #276512 and #277888
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/ChangeLog10
-rw-r--r--net-im/mcabber/mcabber-0.9.9-r1.ebuild97
2 files changed, 105 insertions, 2 deletions
diff --git a/net-im/mcabber/ChangeLog b/net-im/mcabber/ChangeLog
index e9b852dae4bf..a3729b571d3f 100644
--- a/net-im/mcabber/ChangeLog
+++ b/net-im/mcabber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/mcabber
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.41 2008/12/17 21:06:41 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/ChangeLog,v 1.42 2009/07/30 11:47:41 wschlich Exp $
+
+*mcabber-0.9.9-r1 (30 Jul 2009)
+
+ 30 Jul 2009; Wolfram Schlich <wschlich@gentoo.org>
+ +mcabber-0.9.9-r1.ebuild:
+ fix bugs #276512 and #277888
17 Dec 2008; Markus Meier <maekke@gentoo.org> mcabber-0.9.9.ebuild:
amd64/x86 stable, bug #251139
diff --git a/net-im/mcabber/mcabber-0.9.9-r1.ebuild b/net-im/mcabber/mcabber-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..faa954e6a31b
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.9.9-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.9-r1.ebuild,v 1.1 2009/07/30 11:47:41 wschlich Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://mcabber.com/"
+SRC_URI="http://mcabber.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="crypt otr spell ssl"
+
+LANGS="de en fr nl pl uk ru"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( >=net-libs/libotr-3.1.0 )
+ spell? ( app-text/aspell )
+ >=dev-libs/glib-2.0.0
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ use crypt && x86 && append-flags -D_FILE_OFFSET_BITS=64 # bug #277888
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable otr) \
+ $(use_enable spell aspell) \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
+ dodoc doc/README_PGP.txt
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins "${S}"/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe "${S}"/contrib/*.{pl,py,rb}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe "${S}"/contrib/events/*
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${ROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "As of MCabber version 0.8.2, there is also a wizard script"
+ elog "with which you can create all necessary configuration options."
+ elog "To use it, simply execute the following command (please note that you need"
+ elog "to have dev-lang/ruby installed for it to work!):"
+ elog
+ elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
+ elog
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ elog
+ elog "Check out ${ROOT}usr/share/${PN} for contributed themes and event scripts."
+ elog
+}