summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2008-08-07 17:25:41 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2008-08-07 17:25:41 +0000
commitf4058c156f9a445527b9182e73ce03166d91e32c (patch)
treec4904bdfc55c85f3de5c65c443148feff93d100b /net-im
parentfix build without libvorbis and use=-vorbis, by tangram <tangram1@tlen.pl>, b... (diff)
downloadgentoo-2-f4058c156f9a445527b9182e73ce03166d91e32c.tar.gz
gentoo-2-f4058c156f9a445527b9182e73ce03166d91e32c.tar.bz2
gentoo-2-f4058c156f9a445527b9182e73ce03166d91e32c.zip
Fixed connection issues with current MSN servers (bug #234049).
(Portage version: 2.2_rc3/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pymsn-t/ChangeLog9
-rw-r--r--net-im/pymsn-t/files/pymsn-t-0.11.3-protocol-version.patch12
-rw-r--r--net-im/pymsn-t/pymsn-t-0.11.3-r1.ebuild71
3 files changed, 91 insertions, 1 deletions
diff --git a/net-im/pymsn-t/ChangeLog b/net-im/pymsn-t/ChangeLog
index cf4d5c7ba2aa..6d4255ca5472 100644
--- a/net-im/pymsn-t/ChangeLog
+++ b/net-im/pymsn-t/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pymsn-t
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.12 2008/05/29 17:41:37 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.13 2008/08/07 17:25:41 griffon26 Exp $
+
+*pymsn-t-0.11.3-r1 (07 Aug 2008)
+
+ 07 Aug 2008; Maurice van der Pot <griffon26@gentoo.org>
+ +files/pymsn-t-0.11.3-protocol-version.patch, +pymsn-t-0.11.3-r1.ebuild:
+ Added patch to fix connection issues with current MSN servers as reported by
+ Goudal Francois <goudalf@free.fr> in bug #234049.
29 May 2008; Ali Polatel <hawking@gentoo.org> pymsn-t-0.11.2.ebuild,
pymsn-t-0.11.3.ebuild, pymsn-t-0.11a-r4.ebuild:
diff --git a/net-im/pymsn-t/files/pymsn-t-0.11.3-protocol-version.patch b/net-im/pymsn-t/files/pymsn-t-0.11.3-protocol-version.patch
new file mode 100644
index 000000000000..ffb6ae8339cb
--- /dev/null
+++ b/net-im/pymsn-t/files/pymsn-t-0.11.3-protocol-version.patch
@@ -0,0 +1,12 @@
+diff -a -u -d -r pymsnt.a/src/legacy/msn/msn.py pymsnt.b/src/legacy/msn/msn.py
+--- pymsnt.a/src/legacy/msn/msn.py 2008-02-08 16:55:07.000000000 +0300
++++ pymsnt.b/src/legacy/msn/msn.py 2008-08-05 20:40:46.000000000 +0400
+@@ -110,7 +110,7 @@
+ from urllib import quote, unquote
+
+
+-MSN_PROTOCOL_VERSION = "MSNP11 CVR0" # protocol version
++MSN_PROTOCOL_VERSION = "MSNP11" # protocol version
+ MSN_PORT = 1863 # default dispatch server port
+ MSN_MAX_MESSAGE = 1664 # max message length
+ MSN_CVR_STR = "0x040c winnt 5.1 i386 MSNMSGR 7.0.0777 msmsgs"
diff --git a/net-im/pymsn-t/pymsn-t-0.11.3-r1.ebuild b/net-im/pymsn-t/pymsn-t-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..b8d7bc64ae1e
--- /dev/null
+++ b/net-im/pymsn-t/pymsn-t-0.11.3-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/pymsn-t-0.11.3-r1.ebuild,v 1.1 2008/08/07 17:25:41 griffon26 Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils multilib python
+
+MY_PN="pymsnt"
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="Python based jabber transport for MSN"
+HOMEPAGE="http://msn-transport.jabberstudio.org/"
+SRC_URI="http://msn-transport.jabberstudio.org/tarballs/${MY_PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ >=dev-python/twisted-2.5.0
+ >=dev-python/twisted-words-0.5.0
+ >=dev-python/twisted-web-0.7.0
+ >=dev-python/imaging-1.1"
+
+src_unpack() {
+ unpack ${A} && cd "${S}" || die "unpack failed"
+ epatch "${FILESDIR}/${P}-protocol-version.patch"
+}
+
+src_install() {
+ local inspath
+
+ python_version
+ inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ insinto ${inspath}
+ doins -r data src
+ newins PyMSNt.py ${PN}.py
+
+ insinto /etc/jabber
+ newins config-example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ dosed \
+ "s:<!-- <spooldir>[^\<]*</spooldir> -->:<spooldir>/var/spool/jabber</spooldir>:" \
+ /etc/jabber/${PN}.xml
+ dosed \
+ "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ /etc/jabber/${PN}.xml
+ dosed \
+ "s:<host>[^\<]*</host>:<host>example.org</host>:" \
+ /etc/jabber/${PN}.xml
+ dosed \
+ "s:<jid>msn</jid>:<jid>msn.example.org</jid>:" \
+ /etc/jabber/${PN}.xml
+
+ newinitd "${FILESDIR}/${PN}-0.11.2-initd" ${PN}
+ dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+
+ elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
+ elog "Please edit it and the configuration of your Jabber server to match."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
+}