summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-07-27 15:11:37 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-07-27 15:11:37 +0000
commit621927fe322f74eb86e4fc90390bb7cc97fc3911 (patch)
tree33647ced1dd0ed1aa2b9fa2961fddd42f44bd9bb /net-irc/atheme-services
parentFix for default mailbox location in configure (diff)
downloadgentoo-2-621927fe322f74eb86e4fc90390bb7cc97fc3911.tar.gz
gentoo-2-621927fe322f74eb86e4fc90390bb7cc97fc3911.tar.bz2
gentoo-2-621927fe322f74eb86e4fc90390bb7cc97fc3911.zip
Bump to atheme-7.0.0_alpha6 which has perl scripting support.
(Portage version: 2.2.0_alpha46-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/ChangeLog9
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.0_alpha6.ebuild108
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.0.0_alpha6-destdir-perl.patch46
3 files changed, 162 insertions, 1 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index 072b2df93bcb..9fab8b66c597 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.9 2011/07/22 03:22:12 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.10 2011/07/27 15:11:36 binki Exp $
+
+*atheme-services-7.0.0_alpha6 (27 Jul 2011)
+
+ 27 Jul 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +atheme-services-7.0.0_alpha6.ebuild,
+ +files/atheme-services-7.0.0_alpha6-destdir-perl.patch:
+ Bump to atheme-7.0.0_alpha6 which has perl scripting support.
*atheme-services-6.0.8-r2 (22 Jul 2011)
diff --git a/net-irc/atheme-services/atheme-services-7.0.0_alpha6.ebuild b/net-irc/atheme-services/atheme-services-7.0.0_alpha6.ebuild
new file mode 100644
index 000000000000..2ec81873137b
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.0.0_alpha6.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.0_alpha6.ebuild,v 1.1 2011/07/27 15:11:36 binki Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic perl-module prefix
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND=">=dev-libs/libmowgli-0.9.50
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-destdir-perl.patch
+
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with perl) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/files/atheme-services-7.0.0_alpha6-destdir-perl.patch b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha6-destdir-perl.patch
new file mode 100644
index 000000000000..b709e73c922e
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha6-destdir-perl.patch
@@ -0,0 +1,46 @@
+diff --git a/modules/scripting/perl/Makefile b/modules/scripting/perl/Makefile
+index ec006ba..b7e4dbd 100644
+--- a/modules/scripting/perl/Makefile
++++ b/modules/scripting/perl/Makefile
+@@ -12,7 +12,7 @@ include ../../../buildsys.mk
+
+ plugindir = $(MODDIR)/modules/scripting
+
+-CPPFLAGS += -I../../../include -I. $(PERL_CFLAGS)
++CPPFLAGS += -I../../../include -I. $(PERL_CFLAGS) -DPERL_MODDIR='"$(plugindir)"'
+ CFLAGS += $(PLUGIN_CFLAGS)
+ LDFLAGS += $(PLUGIN_LDFLAGS) $(PERL_LIBS)
+ LIBS += -L../../../libathemecore -lathemecore ${LDFLAGS_RPATH}
+@@ -28,11 +28,11 @@ perlxsi.c:
+ perl -MExtUtils::Embed -e xsinit
+
+ install-extra:
+- ${MKDIR_P} ${plugindir}/lib
+- ${INSTALL} -m644 lib/*.pl lib/*.pm ${plugindir}/lib
+- ${MKDIR_P} ${plugindir}/lib/Atheme
+- ${INSTALL} -m644 lib/Atheme/*.pm ${plugindir}/lib/Atheme
+- ${MKDIR_P} ${plugindir}/lib/Atheme/Internal
+- ${INSTALL} -m644 lib/Atheme/Internal/*.pm ${plugindir}/lib/Atheme/Internal
+- ${MKDIR_P} ${plugindir}/examples
+- ${INSTALL} -m644 examples/*.pl ${plugindir}/examples
++ ${MKDIR_P} '${DESTDIR}'${plugindir}/lib
++ ${INSTALL} -m644 lib/*.pl lib/*.pm '${DESTDIR}'${plugindir}/lib
++ ${MKDIR_P} '${DESTDIR}'${plugindir}/lib/Atheme
++ ${INSTALL} -m644 lib/Atheme/*.pm '${DESTDIR}'${plugindir}/lib/Atheme
++ ${MKDIR_P} '${DESTDIR}'${plugindir}/lib/Atheme/Internal
++ ${INSTALL} -m644 lib/Atheme/Internal/*.pm '${DESTDIR}'${plugindir}/lib/Atheme/Internal
++ ${MKDIR_P} '${DESTDIR}'${plugindir}/examples
++ ${INSTALL} -m644 examples/*.pl '${DESTDIR}'${plugindir}/examples
+diff --git a/modules/scripting/perl/perl_module.c b/modules/scripting/perl/perl_module.c
+index ba93cdf..dfa8622 100644
+--- a/modules/scripting/perl/perl_module.c
++++ b/modules/scripting/perl/perl_module.c
+@@ -24,7 +24,7 @@ DECLARE_MODULE_V1
+ * Definitions:
+ * PERL_INIT_FILE is the perl script that is used to boot the Atheme interface.
+ */
+-#define PERL_INIT_FILE PREFIX "/modules/scripting/lib/init.pl"
++#define PERL_INIT_FILE PERL_MODDIR "/lib/init.pl"
+
+ /*
+ * External functions: