summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2009-11-17 00:10:50 +0000
committerDawid Węgliński <cla@gentoo.org>2009-11-17 00:10:50 +0000
commit44b70268ca922c1e85479a0f0a1633ab97556ce3 (patch)
tree22734297a325ed9d1eae0e0705d2cacf48aef076 /net-irc/bitchx
parentStable for HPPA (bug #292962). (diff)
downloadgentoo-2-44b70268ca922c1e85479a0f0a1633ab97556ce3.tar.gz
gentoo-2-44b70268ca922c1e85479a0f0a1633ab97556ce3.tar.bz2
gentoo-2-44b70268ca922c1e85479a0f0a1633ab97556ce3.zip
Pass mode to O_CREATE (bug #285374)
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/ChangeLog8
-rw-r--r--net-irc/bitchx/bitchx-1.1-r4.ebuild5
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-open-mode.patch33
3 files changed, 42 insertions, 4 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index 69a7580a1160..49e8a8ad918e 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bitchx
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.68 2008/03/11 18:07:32 cla Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.69 2009/11/17 00:10:50 cla Exp $
+
+ 17 Nov 2009; Dawid Węgliński <cla@gentoo.org> bitchx-1.1-r4.ebuild,
+ +files/1.1/bitchx-1.1-open-mode.patch:
+ Pass mode to O_CREAT bug #285374
11 Mar 2008; Dawid Węgliński <cla@gentoo.org> bitchx-1.1-r4.ebuild:
Use sane unpack(), add lowercase symlink.
diff --git a/net-irc/bitchx/bitchx-1.1-r4.ebuild b/net-irc/bitchx/bitchx-1.1-r4.ebuild
index 6fd6843eebb5..5a56096f83fd 100644
--- a/net-irc/bitchx/bitchx-1.1-r4.ebuild
+++ b/net-irc/bitchx/bitchx-1.1-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.1-r4.ebuild,v 1.4 2008/03/11 18:07:32 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.1-r4.ebuild,v 1.5 2009/11/17 00:10:50 cla Exp $
inherit flag-o-matic eutils
@@ -30,6 +30,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}/${P}-inline.patch
epatch "${FILESDIR}"/${PV}/${P}-headers.patch
epatch "${FILESDIR}"/${PV}/${P}-build.patch
+ epatch "${FILESDIR}"/${PV}/${P}-open-mode.patch
epatch "${FILESDIR}"/fPIC.patch
epatch "${FILESDIR}"/BitchX-64bit.patch
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-open-mode.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-open-mode.patch
new file mode 100644
index 000000000000..1eeba358eb30
--- /dev/null
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-open-mode.patch
@@ -0,0 +1,33 @@
+diff -Naur BitchX.old/source/commands2.c BitchX/source/commands2.c
+--- BitchX.old/source/commands2.c 2003-04-11 03:09:07.000000000 +0200
++++ BitchX/source/commands2.c 2009-11-17 00:51:56.000000000 +0100
+@@ -2575,7 +2575,7 @@
+ {
+ char buf[BIG_BUFFER_SIZE+1];
+ sprintf(buf, socket_path, port);
+- if ((u = open(buf, O_CREAT|O_WRONLY)) != -1)
++ if ((u = open(buf, O_CREAT|O_WRONLY, 0644)) != -1)
+ {
+ chmod(buf, SOCKMODE);
+ chown(buf, getuid(), getgid());
+diff -Naur BitchX.old/source/dcc.c BitchX/source/dcc.c
+--- BitchX.old/source/dcc.c 2003-04-11 03:09:07.000000000 +0200
++++ BitchX/source/dcc.c 2009-11-17 00:52:56.000000000 +0100
+@@ -1818,7 +1818,7 @@
+ flags |= DCC_ACTIVE;
+ set_socketflags(new_s, flags);
+ set_socketinfo(new_s, n);
+- if ((n->file = open(n->filename, O_RDONLY | O_BINARY)) == -1)
++ if ((n->file = open(n->filename, O_RDONLY | O_BINARY, 0644)) == -1)
+ {
+ erase_dcc_info(new_s, 1, "%s", convert_output_format("$G %RDCC%n Unable to open $0: $1-", "%s %s", n->filename, errno ? strerror(errno) : "Unknown Host"));
+ close_socketread(new_s);
+@@ -2273,7 +2273,7 @@
+ tmp = m_strdup(new->filename);
+ if (!(fullname = expand_twiddle(tmp)))
+ malloc_strcpy(&fullname, tmp);
+- if ((new->file = open(fullname, O_WRONLY | O_CREAT | O_BINARY)) != -1)
++ if ((new->file = open(fullname, O_WRONLY | O_CREAT | O_BINARY, 0644)) != -1)
+ {
+ if ((new = dcc_create(nick, new->filename, passwd, 0, port? atol(port) : 0, DCC_REFILEREAD, (tdcc?DCC_TDCC:0) | DCC_TWOCLIENTS|DCC_OFFER, start_dcc_get)))
+ new->blocksize = blocksize;