summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-07-17 10:51:53 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-07-17 10:51:53 +0000
commit72546c7ae6db5eefd254d8cd126dc23ef0a545ca (patch)
tree848c202849151eb75db3e6bf3eadaa32ce9115ad /net-irc/bitchx
parentbump (diff)
downloadgentoo-2-72546c7ae6db5eefd254d8cd126dc23ef0a545ca.tar.gz
gentoo-2-72546c7ae6db5eefd254d8cd126dc23ef0a545ca.tar.bz2
gentoo-2-72546c7ae6db5eefd254d8cd126dc23ef0a545ca.zip
fix bug #183149
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/ChangeLog10
-rw-r--r--net-irc/bitchx/bitchx-1.1-r4.ebuild85
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-pbxs.patch15
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.1-r43
4 files changed, 111 insertions, 2 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index e318ab67d10d..c259d141e0de 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/bitchx
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.63 2006/11/19 02:16:29 compnerd Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.64 2007/07/17 10:51:53 lu_zero Exp $
+
+*bitchx-1.1-r4 (17 Jul 2007)
+
+ 17 Jul 2007; Luca Barbato <lu_zero@gentoo.org>
+ +files/1.1/bitchx-1.1-pbxs.patch, +bitchx-1.1-r4.ebuild:
+ fix bug #183149
19 Nov 2006; Saleem Abdulrasool <compnerd@gentoo.org> -bitchx-1.1-r1.ebuild,
-bitchx-1.1-r2.ebuild:
diff --git a/net-irc/bitchx/bitchx-1.1-r4.ebuild b/net-irc/bitchx/bitchx-1.1-r4.ebuild
new file mode 100644
index 000000000000..a6fdf645ec96
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.1-r4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.1-r4.ebuild,v 1.1 2007/07/17 10:51:53 lu_zero Exp $
+
+inherit flag-o-matic eutils
+
+MY_P=ircii-pana-${PV}-final
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+HOMEPAGE="http://www.bitchx.org/"
+SRC_URI="http://www.bitchx.org/files/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc sh sparc x86"
+IUSE="cjk ipv6 ssl"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ use cjk && epatch "${FILESDIR}"/${PV}/${P}-cjk.patch
+ epatch "${FILESDIR}"/${PV}/${P}-pbxs.patch
+ epatch "${FILESDIR}"/${PV}/${P}-hebrew.patch
+ epatch "${FILESDIR}"/${PV}/${P}-freenode.patch
+ epatch "${FILESDIR}"/${PV}/${P}-gcc34.patch
+ epatch "${FILESDIR}"/${PV}/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${PV}/${P}-headers.patch
+ epatch "${FILESDIR}"/${PV}/${P}-build.patch
+ epatch "${FILESDIR}"/fPIC.patch
+ epatch "${FILESDIR}"/BitchX-64bit.patch
+
+ sed -i \
+ -e "s/#undef LATIN1/#define LATIN1 ON/;" \
+ include/config.h
+}
+
+src_compile() {
+ replace-flags -O[3-9] -O2
+ append-flags -fno-strict-aliasing
+
+ # Disable CDROM or else it will take over your CDROM drive
+ local myconf="--disable-cdrom --disable-sound --without-gtk"
+
+ # lamer@gentoo.org BROKEN, will not work with our socks
+ # implementations, is looking for a SOCKSConnect function that our
+ # dante packages don't have :-(
+ # use socks5 \
+ # && myconf="${myconf} --with-socks=5" \
+ # || myconf="${myconf} --without-socks"
+
+ econf \
+ --with-plugins \
+ $(use_with ssl) \
+ $(use_enable ipv6) \
+ ${myconf} || die
+
+ emake || die "make failed"
+ emake -C contrib vh1 || die "make vh1 failed"
+}
+
+src_install () {
+ einstall || die
+ dobin contrib/vh1 || die
+ dosym BitchX-1.1-final /usr/bin/BitchX
+
+ cd "${S}"
+ dodoc bugs Changelog README* IPv6-support
+
+ cd "${S}"/doc
+ insinto /usr/include/X11/bitmaps
+ doins BitchX.xpm || die
+ dodoc README.* *.txt */*.txt tcl/*
+ dohtml -r *
+
+ cd "${S}"/dll
+ docinto plugins
+ dodoc nap/README.nap
+ newdoc acro/README README.acro
+ newdoc arcfour/README README.arcfour
+ newdoc blowfish/README README.blowfish
+ newdoc qbx/README README.qbx
+}
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-pbxs.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-pbxs.patch
new file mode 100644
index 000000000000..550dda05e14f
--- /dev/null
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-pbxs.patch
@@ -0,0 +1,15 @@
+--- source/hook.c.orig 2003-04-11 03:09:07.000000000 +0200
++++ source/hook.c 2007-07-17 12:02:07.000000000 +0200
+@@ -836,7 +836,11 @@
+
+ #ifdef WANT_TCL
+ int tcl_ret = 0;
+-#endif
++#endif
++
++ if (which >= NUMBER_OF_LISTS)
++ return NO_ACTION_TAKEN;
++
+ /*
+ * Figure out where the hooks are for the event type were asserting
+ */
diff --git a/net-irc/bitchx/files/digest-bitchx-1.1-r4 b/net-irc/bitchx/files/digest-bitchx-1.1-r4
new file mode 100644
index 000000000000..5721630b3fc2
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.1-r4
@@ -0,0 +1,3 @@
+MD5 611d2dda222f00c10140236f4c331572 ircii-pana-1.1-final.tar.gz 2532476
+RMD160 4105de2587964146e2391a26a8a16e3d0059a93f ircii-pana-1.1-final.tar.gz 2532476
+SHA256 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57 ircii-pana-1.1-final.tar.gz 2532476