summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-10-09 20:28:36 +0000
committerSven Wegener <swegener@gentoo.org>2004-10-09 20:28:36 +0000
commit4aced28ec60c36c4e4d676785c9d98b8f19447c5 (patch)
tree6a5919a65c5ead32894944df8caf6d7eef69039d /net-irc/bnc
parentStable on x86, alpha and ppc. (Manifest recommit) (diff)
downloadgentoo-2-4aced28ec60c36c4e4d676785c9d98b8f19447c5.tar.gz
gentoo-2-4aced28ec60c36c4e4d676785c9d98b8f19447c5.tar.bz2
gentoo-2-4aced28ec60c36c4e4d676785c9d98b8f19447c5.zip
Version bump for security bug #66912. Made CFLAGS aware.
Diffstat (limited to 'net-irc/bnc')
-rw-r--r--net-irc/bnc/ChangeLog7
-rw-r--r--net-irc/bnc/Manifest10
-rw-r--r--net-irc/bnc/bnc-2.8.9.ebuild35
-rw-r--r--net-irc/bnc/files/digest-bnc-2.8.91
4 files changed, 48 insertions, 5 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index be009dee9f43..2a59e76fc943 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/bnc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.12 2004/07/17 22:14:51 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.13 2004/10/09 20:28:36 swegener Exp $
+
+*bnc-2.8.9 (09 Oct 2004)
+
+ 09 Oct 2004; Sven Wegener <swegener@gentoo.org> +bnc-2.8.9.ebuild:
+ Version bump for security bug #66912. Made CFLAGS aware.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> bnc-2.6.4.ebuild,
bnc-2.8.6-r1.ebuild, bnc-2.8.6.ebuild:
diff --git a/net-irc/bnc/Manifest b/net-irc/bnc/Manifest
index d38736ad99c9..0207b3af538a 100644
--- a/net-irc/bnc/Manifest
+++ b/net-irc/bnc/Manifest
@@ -1,10 +1,12 @@
+MD5 90ed2e2ccf6080a1626d984b95654b9b ChangeLog 1727
+MD5 dcb93d671a834bea2437822c46b3c214 bnc-2.6.4.ebuild 905
MD5 08815a69732a76b4717dcdeb6da7e229 bnc-2.8.6-r1.ebuild 1145
MD5 f15575a42abc7635cb3c7691eb3b4a38 bnc-2.8.6.ebuild 1015
-MD5 dcb93d671a834bea2437822c46b3c214 bnc-2.6.4.ebuild 905
-MD5 90ed2e2ccf6080a1626d984b95654b9b ChangeLog 1727
MD5 b548677db8b820721075cb8c151fe399 metadata.xml 250
-MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6-r1 59
+MD5 926e0ad9504196f75bb0a36b94a4660d bnc-2.8.9.ebuild 937
MD5 cab5a601ff0bb6f73c793cbe7a278f4e files/bnc-2.8.6-gotofail-labelfix.patch 538
+MD5 e8809f89a22004c0092dcb8502e17bfa files/bncsetup.patch 1212
MD5 3aecb068876402e1030f940f6caa829a files/digest-bnc-2.6.4 59
MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6 59
-MD5 e8809f89a22004c0092dcb8502e17bfa files/bncsetup.patch 1212
+MD5 b9427cecfd47491ea920651f047adb36 files/digest-bnc-2.8.6-r1 59
+MD5 abfd9014770224aa08ceed9439d9e0d5 files/digest-bnc-2.8.9 59
diff --git a/net-irc/bnc/bnc-2.8.9.ebuild b/net-irc/bnc/bnc-2.8.9.ebuild
new file mode 100644
index 000000000000..43ff85d70931
--- /dev/null
+++ b/net-irc/bnc/bnc-2.8.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.9.ebuild,v 1.1 2004/10/09 20:28:36 swegener Exp $
+
+inherit eutils
+
+MY_P=${P/-/}
+DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
+HOMEPAGE="http://gotbnc.com/"
+SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~arm"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ mv mkpasswd bncmkpasswd
+}
+
+src_install() {
+ dobin bnc bncchk bncsetup bncmkpasswd || die "dobin failed"
+ dodoc CHANGES README example.conf motd || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo "You can find an example motd/conf file here:"
+ einfo " /usr/share/doc/${PF}/{example.conf,motd}.gz"
+}
diff --git a/net-irc/bnc/files/digest-bnc-2.8.9 b/net-irc/bnc/files/digest-bnc-2.8.9
new file mode 100644
index 000000000000..5435745e55e7
--- /dev/null
+++ b/net-irc/bnc/files/digest-bnc-2.8.9
@@ -0,0 +1 @@
+MD5 4cabd254443c803fc759b1f062e7bedb bnc2.8.9.tar.gz 57527