summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-06-15 04:06:52 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-06-15 04:06:52 +0000
commit9955ea39b1aff9f830bb344635ff87cfba9662cd (patch)
treedc16f4ade67b12471f628603c9e89aa9233a90a4 /net-irc/bobotpp
parentVersion bump. (diff)
downloadgentoo-2-9955ea39b1aff9f830bb344635ff87cfba9662cd.tar.gz
gentoo-2-9955ea39b1aff9f830bb344635ff87cfba9662cd.tar.bz2
gentoo-2-9955ea39b1aff9f830bb344635ff87cfba9662cd.zip
Bump to bobotpp-2.2.3 and to EAPI=4.
(Portage version: 2.2.0_alpha37-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/bobotpp')
-rw-r--r--net-irc/bobotpp/ChangeLog10
-rw-r--r--net-irc/bobotpp/bobotpp-2.2.3.ebuild54
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch13
3 files changed, 75 insertions, 2 deletions
diff --git a/net-irc/bobotpp/ChangeLog b/net-irc/bobotpp/ChangeLog
index 3fa3c4f643df..584a96e51abb 100644
--- a/net-irc/bobotpp/ChangeLog
+++ b/net-irc/bobotpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/bobotpp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/ChangeLog,v 1.22 2010/12/03 00:40:33 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/ChangeLog,v 1.23 2011/06/15 04:06:52 binki Exp $
+
+*bobotpp-2.2.3 (15 Jun 2011)
+
+ 15 Jun 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +bobotpp-2.2.3.ebuild, +files/bobotpp-2.2.3-stdout.patch:
+ Bump to bobotpp-2.2.3 and to EAPI=4.
03 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> bobotpp-2.2.2.ebuild:
Use modern autotools for rebuilding.
diff --git a/net-irc/bobotpp/bobotpp-2.2.3.ebuild b/net-irc/bobotpp/bobotpp-2.2.3.ebuild
new file mode 100644
index 000000000000..0f733b60bd4e
--- /dev/null
+++ b/net-irc/bobotpp/bobotpp-2.2.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/bobotpp-2.2.3.ebuild,v 1.1 2011/06/15 04:06:52 binki Exp $
+
+EAPI=4
+
+inherit autotools autotools-utils eutils
+
+DESCRIPTION="A flexible IRC bot scriptable in scheme"
+HOMEPAGE="http://unknownlamer.org/code/bobot.html"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="guile"
+
+DEPEND="guile? ( dev-scheme/guile )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.2-asneeded.patch \
+ "${FILESDIR}"/${P}-stdout.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-crypt
+ $(use_enable guile scripting)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dosym bobot++.info /usr/share/info/bobotpp.info
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml documentation/index.html
+
+ docinto examples/config
+ dodoc examples/config/*
+
+ docinto examples/scripts
+ dodoc examples/scripts/*
+}
+
+pkg_postinst() {
+ elog "You can find a sample configuration file set in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/example-config"
+}
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
new file mode 100644
index 000000000000..8bbb78be966c
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
@@ -0,0 +1,13 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Reduce amount of noise printed to stdout.
+
+--- a/source/Utils.C
++++ b/source/Utils.C
+@@ -97,7 +97,6 @@
+ if (host == "") host = "*";
+ }
+
+- std::cout << nick + "!" + user + "@" + host << std::endl;
+
+ return nick + "!" + user + "@" + host;
+ }