summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-21 12:12:35 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-21 12:12:35 +0000
commitdcc2ddd57570e5867563c4d43b5705b1c9bcafba (patch)
tree0aee59797fb1e165cf817db8822ef88ee0a5931c /net-irc/eggdrop
parentUse sys-apps/gentoo-functions, bug #504418. (diff)
downloadgentoo-2-dcc2ddd57570e5867563c4d43b5705b1c9bcafba.tar.gz
gentoo-2-dcc2ddd57570e5867563c4d43b5705b1c9bcafba.tar.bz2
gentoo-2-dcc2ddd57570e5867563c4d43b5705b1c9bcafba.zip
Revbump to make sure people do not end up with broken eggdrop-installer.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/ChangeLog7
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
index b7ab6d29c4e9..2fa26aeade86 100644
--- a/net-irc/eggdrop/ChangeLog
+++ b/net-irc/eggdrop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/eggdrop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.94 2014/12/21 12:08:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.95 2014/12/21 12:12:35 mgorny Exp $
+
+*eggdrop-1.6.21-r1 (21 Dec 2014)
+
+ 21 Dec 2014; Michał Górny <mgorny@gentoo.org> +eggdrop-1.6.21-r1.ebuild:
+ Revbump to make sure people do not end up with broken eggdrop-installer.
21 Dec 2014; Michał Górny <mgorny@gentoo.org> eggdrop-1.6.21.ebuild,
files/eggdrop-installer:
diff --git a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
new file mode 100644
index 000000000000..507d2cac1d7f
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild,v 1.1 2014/12/21 12:12:35 mgorny Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P="eggdrop${PV}"
+PATCHSET_V="1.0"
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="http://www.eggheads.org/"
+SRC_URI="ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~binki/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCHSET_V}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug mysql postgres ssl static vanilla"
+REQUIRED_USE="vanilla? ( !mysql !postgres !ssl )"
+
+DEPEND="dev-lang/tcl
+ sys-apps/gentoo-functions
+ !vanilla? (
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql[server] )
+ ssl? ( dev-libs/openssl )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use vanilla; then
+ rm -f "${WORKDIR}"/patch/[1-6]*.patch || die
+ fi
+
+ EPATCH_SUFFIX="patch" epatch
+
+ # fix bug #335230
+ sed -i \
+ -e '/\$(LD)/s/-o/$(CFLAGS) $(LDFLAGS) &/' \
+ src/mod/*.mod/Makefile* src/Makefile.in || die
+}
+
+src_configure() {
+ use mysql || ( echo mysql ; echo mystats ) >>disabled_modules
+ use postgres || echo pgstats >>disabled_modules
+ use static && ( echo rijndael ; echo twofish ) >>disabled_modules
+
+ econf $(use_with ssl)
+
+ emake config
+}
+
+src_compile() {
+ local target=""
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ local a b
+ emake DEST="${D}"/opt/eggdrop install
+
+ for a in doc/*; do
+ [ -f ${a} ] && dodoc ${a}
+ done
+
+ for a in src/mod/*.mod; do
+ for b in README UPDATES INSTALL TODO CONTENTS; do
+ [[ -f ${a}/${b} ]] && newdoc ${a}/${b} ${b}.${a##*/}
+ done
+ done
+
+ dodoc text/motd.*
+
+ use vanilla || dodoc \
+ src/mod/botnetop.mod/botnetop.conf \
+ src/mod/gseen.mod/gseen.conf \
+ src/mod/mc_greet.mod/mc_greet.conf \
+ src/mod/stats.mod/stats.conf \
+ src/mod/away.mod/away.doc \
+ src/mod/rcon.mod/matchbot.tcl \
+ src/mod/mystats.mod/tools/mystats.{conf,sql} \
+ src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
+
+ dohtml doc/html/*.html
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ elog "Please run /usr/bin/eggdrop-installer to install your eggdrop bot."
+}