summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-06-12 00:48:44 +0000
committerAlec Warner <antarus@gentoo.org>2006-06-12 00:48:44 +0000
commitdf99c09939a579ce433d81d780b4278fbc9fba51 (patch)
tree3df51777b48e4d1d39043c4083e463965aa3ce39 /net-irc/emech/emech-3.0.2.ebuild
parentAdded a new patch to support compile fixes for gcc 3 and gcc4. Fixes for gcc4... (diff)
downloadgentoo-2-df99c09939a579ce433d81d780b4278fbc9fba51.tar.gz
gentoo-2-df99c09939a579ce433d81d780b4278fbc9fba51.tar.bz2
gentoo-2-df99c09939a579ce433d81d780b4278fbc9fba51.zip
bumping 3.0.2 for bug # 132749
(Portage version: 2.1)
Diffstat (limited to 'net-irc/emech/emech-3.0.2.ebuild')
-rw-r--r--net-irc/emech/emech-3.0.2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-irc/emech/emech-3.0.2.ebuild b/net-irc/emech/emech-3.0.2.ebuild
new file mode 100644
index 000000000000..f889bd87cd64
--- /dev/null
+++ b/net-irc/emech/emech-3.0.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/emech/emech-3.0.2.ebuild,v 1.1 2006/06/12 00:48:44 antarus Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="The EnergyMech is a UNIX compatible IRC bot programmed in the C language"
+HOMEPAGE="http://www.energymech.net/"
+SRC_URI="http://www.energymech.net/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug session tcltk"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e 's: "help/":"/usr/share/energymech/help/":' \
+ -e 's: "messages/":"/usr/share/energymech/messages/":' \
+ "${S}"/src/config.h.in
+}
+
+src_compile() {
+ ./configure \
+ --with-alias \
+ --with-botnet \
+ --with-bounce \
+ --with-ctcp \
+ --with-dccfile \
+ --with-dynamode \
+ --with-dyncmd \
+ --with-greet \
+ --with-ircd_ext \
+ --with-md5 \
+ --with-newbie \
+ --with-note \
+ --with-notify \
+ --with-rawdns \
+ --with-redirect \
+ --with-seen \
+ --with-stats \
+ --with-telnet \
+ --with-toybox \
+ --with-trivia \
+ --with-uptime \
+ --with-web \
+ --with-wingate \
+ --without-profiling \
+ $(use_with tcltk tcl) \
+ $(use_with session) \
+ $(use_with debug) \
+ || die "./configure failed"
+ emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin src/energymech || die "dobin failed"
+
+ insinto /usr/share/energymech/help
+ doins help/* || die "doins failed"
+
+ insinto /usr/share/energymech/messages
+ doins messages/*.txt || die "doins failed"
+
+ dodoc sample.* README* TODO VERSIONS CREDITS checkmech || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can find a sample config file at"
+ einfo "/usr/share/doc/${PF}/sample.conf.gz"
+ einfo
+}