summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-07-01 02:54:41 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-07-01 02:54:41 +0000
commitf47dc5ab44ff44116d15cc0e00968a4a45af964f (patch)
tree73608e416778c487ec192aa37320d5048537b3fd /net-irc/epic4
parentAdd patch from upstream for crypt linking #357249 by J.Taimr. (diff)
downloadgentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.tar.gz
gentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.tar.bz2
gentoo-2-f47dc5ab44ff44116d15cc0e00968a4a45af964f.zip
Bump to epic4-2.10.1, with gentoo-prefix support and EAPI=4 and some build fixes.
(Portage version: 2.2.0_alpha41-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/ChangeLog11
-rw-r--r--net-irc/epic4/epic4-2.10.1.ebuild94
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-make-recursion.patch10
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-perl.patch54
4 files changed, 167 insertions, 2 deletions
diff --git a/net-irc/epic4/ChangeLog b/net-irc/epic4/ChangeLog
index 558121df80a0..d946ed2e9654 100644
--- a/net-irc/epic4/ChangeLog
+++ b/net-irc/epic4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/epic4
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.88 2010/10/18 08:11:39 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.89 2011/07/01 02:54:41 binki Exp $
+
+*epic4-2.10.1 (01 Jul 2011)
+
+ 01 Jul 2011; Nathan Phillip Brink <binki@gentoo.org> +epic4-2.10.1.ebuild,
+ +files/epic4-2.10.1-make-recursion.patch, +files/epic4-2.10.1-perl.patch:
+ Bump to epic4-2.10.1, with gentoo-prefix support and EAPI=4 and some build
+ fixes.
18 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org> epic4-2.10.ebuild:
Fix phases for EAPI=2 add quote around $D.
diff --git a/net-irc/epic4/epic4-2.10.1.ebuild b/net-irc/epic4/epic4-2.10.1.ebuild
new file mode 100644
index 000000000000..46bc8cd57488
--- /dev/null
+++ b/net-irc/epic4/epic4-2.10.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-2.10.1.ebuild,v 1.1 2011/07/01 02:54:41 binki Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+HELP_V="20050315"
+
+DESCRIPTION="Epic4 IRC Client"
+HOMEPAGE="http://epicsol.org/"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-${HELP_V}.tar.gz
+ mirror://gentoo/epic4-local.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6 perl ssl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/epic-defaultserver.patch \
+ "${FILESDIR}"/${P}-make-recursion.patch \
+ "${FILESDIR}"/${P}-perl.patch
+
+ eautoconf
+
+ rm -f "${WORKDIR}"/help/Makefile || die
+ find "${WORKDIR}"/help -type d -name CVS -print0 | xargs -0 rm -r
+}
+
+src_configure() {
+ replace-flags "-O?" "-O"
+
+ # copied from alt overlay
+ [[ ${CHOST} == *-interix* ]] && export ac_cv_func_getpgrp_void=yes
+
+ econf \
+ --libexecdir="${EPREFIX}"/usr/libexec/${PN} \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ einstall \
+ sharedir="${ED}"/usr/share \
+ libexecdir="${ED}"/usr/libexec/${PN}
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd "${S}"/doc || die
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp SILLINESS TS4
+
+ insinto /usr/share/epic/help
+ doins -r "${WORKDIR}"/help/*
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/usr/share/epic/script/local ]; then
+ elog "/usr/share/epic/script/local does not exist, I will now"
+ elog "create it. If you do not like the look/feel of this file, or"
+ elog "if you'd prefer to use your own script, simply remove this"
+ elog "file. If you want to prevent this file from being installed"
+ elog "in the future, simply create an empty file with this name."
+ cp "${WORKDIR}"/epic4-local "${EROOT}"/usr/share/epic/script/local
+ elog
+ elog "This provided local startup script adds a number of nifty"
+ elog "features to Epic including tab completion, a comprehensive set"
+ elog "of aliases, and channel-by-channel logging. To prevent"
+ elog "unintentional conflicts with your own scripting, if either the"
+ elog "~/.ircrc or ~/.epicrc script files exist, then the local script"
+ elog "is *not* run. If you like the script but want to make careful"
+ elog "additions (such as selecting your usual servers or setting your"
+ elog "nickname), simply copy /usr/share/epic/script/local to ~/.ircrc"
+ elog "and then add your additions to the copy."
+ fi
+
+ # Fix for bug 59075
+ chmod 755 "${EROOT}"/usr/share/epic/help
+}
diff --git a/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
new file mode 100644
index 000000000000..68d7e4c460b6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -210,6 +210,6 @@
+ $(RM) Makefile source/Makefile include/sig.inc config.status config.cache config.log include/defs.h source/info.c.sh
+
+ depend:
+- (cd source;make depend)
++ (cd source;$(MAKE) depend)
+
+ # This is the end of the file.
diff --git a/net-irc/epic4/files/epic4-2.10.1-perl.patch b/net-irc/epic4/files/epic4-2.10.1-perl.patch
new file mode 100644
index 000000000000..ce41d153abc6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-perl.patch
@@ -0,0 +1,54 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix broken perl detection somewhat.
+
+--- a/configure.in
++++ b/configure.in
+@@ -636,25 +636,27 @@
+ dnl
+
+ AC_MSG_CHECKING(whether to support Perl)
+-AC_ARG_WITH(perl,
+-[ --with-perl[=PATH] Compile with perl support.],
+-[ test -z "$withval" && withval=yes ],
+-)
+-test "xno" != "x$withval" && for base in $withval /usr/local /usr /
+-do
+- FOUND=
+- for ext in so a dll ; do
+- test -r $base/lib/libperl.$ext && FOUND=1
+- test -r $base/libperl.$ext && FOUND=1
+- done
+- test -n "$FOUND" || continue
+- AC_MSG_RESULT(yes)
+- LIBS="$LIBS `perl -MExtUtils::Embed -e ldopts`"
+- PERLDOTOH="perl.o"
+- AC_DEFINE(PERL)
+- break
+-done
+-test -z "$PERLDOTOH" && AC_MSG_RESULT(no)
++AC_ARG_WITH([perl],
++ [AS_HELP_STRING([--with-perl[=PATH]], [Compile with perl support.])],
++ [],
++ [with_perl=maybe])
++AS_IF([test "xno" != "x$with_perl"],
++ [
++ PERL_LIBS="`perl -MExtUtils::Embed -e ldopts`"
++ AS_IF([test -n "$PERL_LIBS"],
++ [
++ AC_MSG_RESULT([yes])
++ LIBS="$LIBS $PERL_LIBS"
++ AC_DEFINE([PERL], [], [Define if perl support should be compiled])
++ PERLDOTOH="perl.o"
++ ],
++ [
++ AC_MSG_RESULT([no])
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([You specified --with-perl, but I was unable to find libperl])])
++ ])
++ ])
++
+ withval=''
+
+ dnl ----------------------------------------------------------
+
+Diff finished. Thu Jun 30 22:15:26 2011