summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-07 16:27:50 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-07 16:27:50 +0000
commitb1be9fe96a75b32b89e8e6a19c9064a54b64bd0f (patch)
tree7f26b384cfb0cddb3f059ebc7be741924e9a35f1 /net-irc/miau/miau-0.5.4.ebuild
parentppc stable (diff)
downloadgentoo-2-b1be9fe96a75b32b89e8e6a19c9064a54b64bd0f.tar.gz
gentoo-2-b1be9fe96a75b32b89e8e6a19c9064a54b64bd0f.tar.bz2
gentoo-2-b1be9fe96a75b32b89e8e6a19c9064a54b64bd0f.zip
Version bump, bug #93928. Marked 0.5.3 stable on x86.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-irc/miau/miau-0.5.4.ebuild')
-rw-r--r--net-irc/miau/miau-0.5.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-irc/miau/miau-0.5.4.ebuild b/net-irc/miau/miau-0.5.4.ebuild
new file mode 100644
index 000000000000..26551c662d72
--- /dev/null
+++ b/net-irc/miau/miau-0.5.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/miau-0.5.4.ebuild,v 1.1 2005/07/07 16:27:50 swegener Exp $
+
+DESCRIPTION="Persistent IRC bouncer with multi-client support - a fork of muh"
+HOMEPAGE="http://miau.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ipv6"
+
+DEPEND=""
+
+src_compile() {
+ econf \
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable debug enduserdebug) \
+ $(use_enable debug pingstat) \
+ $(use_enable debug dumpstatus) \
+ || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog TODO README || die "dodoc failed"
+
+ mv "${D}"/usr/share/doc/miau/examples/miaurc "${D}"/usr/share/doc/${PF}/miaurc.sample
+ rm -rf "${D}"/usr/share/doc/miau
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You'll need to configure miau before running it."
+ einfo "Put your config in ~/.miau/miaurc"
+ einfo "A sample config is /usr/share/doc/${PF}/miaurc.sample"
+ einfo "For more information, see the documentation."
+ einfo
+}