summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-05-12 19:55:42 +0000
committerJon Portnoy <avenj@gentoo.org>2003-05-12 19:55:42 +0000
commit906d9f8ad49d28e090c63b8ef28ff1e33ac6b34b (patch)
treec2f8dcecc57a96089789eb81681745331ddff539 /net-irc/ninja
parentInitial import (diff)
downloadgentoo-2-906d9f8ad49d28e090c63b8ef28ff1e33ac6b34b.tar.gz
gentoo-2-906d9f8ad49d28e090c63b8ef28ff1e33ac6b34b.tar.bz2
gentoo-2-906d9f8ad49d28e090c63b8ef28ff1e33ac6b34b.zip
Initial import
Diffstat (limited to 'net-irc/ninja')
-rw-r--r--net-irc/ninja/ChangeLog9
-rw-r--r--net-irc/ninja/Manifest4
-rw-r--r--net-irc/ninja/files/digest-ninja-1.5.9_pre91
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre9.ebuild30
4 files changed, 42 insertions, 2 deletions
diff --git a/net-irc/ninja/ChangeLog b/net-irc/ninja/ChangeLog
new file mode 100644
index 000000000000..a295b51ccfcc
--- /dev/null
+++ b/net-irc/ninja/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-irc/ninja
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ChangeLog,v 1.1 2003/05/12 19:55:30 avenj Exp $
+
+*ninja-1.5.9_pre9.ebuild (12 May 2003)
+
+ 12 May 2003; Jon Portnoy <avenj@gentoo.org> ebuild-1.5.9_pre9.ebuild :
+ Initial import. Ebuild submitted by Burton Samograd
+ <kruhft@kruhft.dyndns.org>. Thanks Burton!
diff --git a/net-irc/ninja/Manifest b/net-irc/ninja/Manifest
index 7e5ee9f3ea26..e5d6855ed899 100644
--- a/net-irc/ninja/Manifest
+++ b/net-irc/ninja/Manifest
@@ -1,3 +1,3 @@
-MD5 901b7320eef886a6fa7bc48448e6ea4a ninja-1.5.9_pre9.ebuild 679
-MD5 0048df8018bbe387f553ba97e8a0ada6 ChangeLog 330
+MD5 106d8159f2f5500cfdca84421a1f553a ninja-1.5.9_pre9.ebuild 778
+MD5 f30e890563f9907c453015462f1e7916 ChangeLog 415
MD5 02be0e2b992a6b7f6fedeaf868630586 files/digest-ninja-1.5.9_pre9 67
diff --git a/net-irc/ninja/files/digest-ninja-1.5.9_pre9 b/net-irc/ninja/files/digest-ninja-1.5.9_pre9
new file mode 100644
index 000000000000..b51f95aa2afb
--- /dev/null
+++ b/net-irc/ninja/files/digest-ninja-1.5.9_pre9
@@ -0,0 +1 @@
+MD5 3c20e06e56907f85c01f42ed02bdd216 ninja-1.5.9pre9.tar.gz 972300
diff --git a/net-irc/ninja/ninja-1.5.9_pre9.ebuild b/net-irc/ninja/ninja-1.5.9_pre9.ebuild
new file mode 100644
index 000000000000..b9b76f8c9897
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre9.ebuild,v 1.1 2003/05/12 19:55:30 avenj Exp $
+
+# Get rid of underscore in package name
+PV=`echo ${PV} | sed -e 's/_.*//'`
+
+S=${WORKDIR}/${PN}-${PV}
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="http://ninja.qoop.org/ftp/sources/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="ncurses ipv6 ssl"
+DEPEND="virtual/glibc
+ ncurses? sys-libs/ncurses
+ ssl? dev-libs/openssl"
+
+src_compile() {
+ local myconf
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ econf ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall
+}
+