summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-01-28 05:03:36 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-01-28 05:03:36 +0000
commit46776f5306a98114630879d20ef0023de51f5544 (patch)
treea73bb4d26bd4938cc49d9f5afec558751f7cb38e /net-irc/vyqchat/vyqchat-0.2.8.ebuild
parentReplacing einfo with elog (diff)
downloadgentoo-2-46776f5306a98114630879d20ef0023de51f5544.tar.gz
gentoo-2-46776f5306a98114630879d20ef0023de51f5544.tar.bz2
gentoo-2-46776f5306a98114630879d20ef0023de51f5544.zip
Fix building with GCC 4.1 and overhaul ebuild.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.2.8.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.2.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.2.8.ebuild b/net-irc/vyqchat/vyqchat-0.2.8.ebuild
new file mode 100644
index 000000000000..ac8a589af5d5
--- /dev/null
+++ b/net-irc/vyqchat/vyqchat-0.2.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.2.8.ebuild,v 1.1 2007/01/28 05:03:36 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="QT based Vypress Chat clone for X."
+HOMEPAGE="http://linux.bydg.org/~yogin/"
+SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="arts"
+
+DEPEND="=x11-libs/qt-3*
+ arts? ( media-libs/libsndfile
+ media-libs/libao
+ kde-base/arts )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
+src_compile() {
+ econf \
+ --with-x \
+ --with-Qt-dir=/usr/qt/3 \
+ $(use_with arts) \
+ $(use_with arts sndfile) \
+ $(use_with arts libao) \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog FAQ NEWS PROTOCOL README README-KEYS \
+ THANKS TODO || die "dodoc failed"
+}