summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-06-19 17:21:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-06-19 17:21:00 +0000
commit635383fb720a86b0f237b4e49ae71450d0bded16 (patch)
tree7a9bc3e12c333539cb84cc5d9de25e35a559f32f /net-irc/xchat-xsys/files
parentversion bump to 2.2.16, marked 2.2.9 stable, and removed old ebuilds (diff)
downloadgentoo-2-635383fb720a86b0f237b4e49ae71450d0bded16.tar.gz
gentoo-2-635383fb720a86b0f237b4e49ae71450d0bded16.tar.bz2
gentoo-2-635383fb720a86b0f237b4e49ae71450d0bded16.zip
Version bump, clean up old ebuilds.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-irc/xchat-xsys/files')
-rw-r--r--net-irc/xchat-xsys/files/1.9.3-ppc-support.patch62
-rw-r--r--net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci-2.patch127
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3-r11
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.0-r11
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.21
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.41
-rw-r--r--net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.61
7 files changed, 1 insertions, 193 deletions
diff --git a/net-irc/xchat-xsys/files/1.9.3-ppc-support.patch b/net-irc/xchat-xsys/files/1.9.3-ppc-support.patch
deleted file mode 100644
index 5464ec54ca7d..000000000000
--- a/net-irc/xchat-xsys/files/1.9.3-ppc-support.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- xsys2/parse.c.orig 2005-05-14 13:29:35.000000000 +0100
-+++ xsys2/parse.c 2005-05-14 13:40:50.000000000 +0100
-@@ -36,6 +36,7 @@
- return 1;
- if(count != NULL) *count = 0;
-
-+ #ifdef __i386__
- while(fgets(buffer, 1024, fp) != NULL)
- {
- if(strstr(buffer, "model name") != NULL && model != NULL)
-@@ -76,7 +77,50 @@
- *count = strtoul(buffer, NULL, 0)+1;
- }
- }
--
-+ #endif
-+ #ifdef __powerpc__
-+ while(fgets(buffer, 1024, fp) != NULL)
-+ {
-+ if(strstr(buffer, "cpu") != NULL && model != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(model, position);
-+ position = strstr(model, "\n");
-+ *(position) = '\0';
-+ }
-+ else if(strstr(buffer, "pmac-generation") != NULL && vendor != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(vendor, position);
-+ position = strstr(vendor, "\n");
-+ *(position) = '\0';
-+ }
-+ else if(strstr(buffer, "clock") != NULL && freq != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ *freq = strtod(position, NULL);
-+ }
-+ else if(strstr(buffer, "L2 cache") != NULL && cache != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ strcpy(cache, position);
-+ position = strstr(cache, "\n");
-+ *(position) = '\0';
-+ }
-+ else if(strstr(buffer, "processor") != NULL && count != NULL)
-+ {
-+ position = strstr(buffer, ":");
-+ position += 2;
-+ if((strtoul(buffer, NULL, 0)+1) > *count)
-+ *count = strtoul(buffer, NULL, 0)+1;
-+ }
-+ }
-+ #endif
-+
- fclose(fp);
-
- return 0;
diff --git a/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci-2.patch b/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci-2.patch
deleted file mode 100644
index f10fd7db6c91..000000000000
--- a/net-irc/xchat-xsys/files/1.9.3-sysfs-instead-of-lspci-2.patch
+++ /dev/null
@@ -1,127 +0,0 @@
---- xsys2/parse.c.orig 2005-04-17 21:01:24.000000000 +0100
-+++ xsys2/parse.c 2005-04-17 23:05:40.000000000 +0100
-@@ -150,19 +150,91 @@
-
- int xs_parse_video(char *vid_card)
- {
-- char *pos = NULL;
-- FILE *pipe = popen(LSPCI" | grep VGA | cut -d\" \" -f5-", "r");
-- if(pipe == NULL)
-- return 1;
-- while(fgets(vid_card, 1024, pipe) != NULL)
-+ char buffer[1024], pcibus[42], vendor[7], device[7], vendorname[128] = "", devicename[128] = "", *position;
-+ int busnr = 0, devnr = 0, cardfound = 0;
-+
-+ while ( busnr <= 20 )
- {
-- if((pos = strchr(vid_card, '\n')) != NULL)
-- *pos = '\0';
-+ while ( devnr <= 20 ) {
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/class", busnr, devnr);
-+ FILE *fp = fopen(pcibus, "r");
-+ if(fp != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strncmp("0x03", buffer, 4) == 0) {
-+ cardfound = 1;
-+ break;
-+ }
-+ fclose(fp);
-+ }
-+ devnr++;
-+ }
-+ if (cardfound == 1)
-+ break;
-+ busnr++;
-+ devnr = 0;
-+ }
-+
-+ if (cardfound == 0) {
-+ strncpy(vid_card, "No AGP card found", 42);
-+ return 0;
- }
-- if(pos == NULL) return 2;
-+
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/device", busnr, devnr);
-+ FILE *fp = fopen(pcibus, "r");
-+ if(fp != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strstr(buffer, "0x") != NULL) {
-+ position = strstr(buffer, "0x");
-+ position += 2;
-+ strncpy(device, position, 7);
-+ position = strstr(device, "\n");
-+ *(position) = '\0';
-+ }
-+ fclose(fp);
-+ }
-+
-+ snprintf(pcibus, 42, "/sys/bus/pci/devices/0000:%.2d:%.2d.0/vendor", busnr, devnr);
-+ FILE *fp2 = fopen(pcibus, "r");
-+ if(fp2 != NULL) {
-+ if(fgets(buffer, 1024, fp) != NULL)
-+ if(strstr(buffer, "0x") != NULL) {
-+ position = strstr(buffer, "0x");
-+ position += 2;
-+ strncpy(vendor, position, 7);
-+ position = strstr(vendor, "\n");
-+ *(position) = '\0';
-+ }
-+ fclose(fp2);
-+ }
-
-- pclose(pipe);
-+ FILE *fp3 = fopen("/usr/share/misc/pci.ids", "r");
-+ if(fp3 == NULL) {
-+ snprintf(vid_card, 42, "Found AGP card %s:%s", vendor, device);
-+ return 0;
-+ }
-
-+ while(fgets(buffer, 1024, fp3) != NULL) {
-+ if (!isspace(buffer[0]) && strstr(buffer, vendor) != NULL) {
-+ position = strstr(buffer, vendor);
-+ position += 6;
-+ strncpy(vendorname, position, 128);
-+ position = strstr(vendorname, "\n");
-+ *(position) = '\0';
-+ break;
-+ }
-+ }
-+ while(fgets(buffer, 1024, fp3) != NULL) {
-+ if(strstr(buffer, device) != NULL) {
-+ position = strstr(buffer, device);
-+ position += 6;
-+ strncpy(devicename, position, 128);
-+ position = strstr(devicename, "\n");
-+ *(position) = '\0';
-+ break;
-+ }
-+ }
-+ fclose(fp3);
-+ snprintf(vid_card, 256, "%s %s", vendorname, devicename);
- return 0;
- }
-
-@@ -389,4 +461,3 @@
- }
- return 0;
- }
--
---- xsys2/Makefile.orig 2005-04-17 21:01:27.000000000 +0100
-+++ xsys2/Makefile 2005-04-17 21:01:31.000000000 +0100
-@@ -1,7 +1,3 @@
--#### SET THIS VALUE TO THE LOCATION OF 'lspci' ####
--LSPCI = /sbin/lspci
--
--
- #### SHOULD NOT NEED TO EDIT BELOW THIS LINE ####
- VER_MAJOR = 1
- VER_MINOR = 9
-@@ -9,7 +5,7 @@
- CC = gcc
- CFLAGS += -O2 -Wall -fPIC
- CFLAGS += -DVER_MINOR=$(VER_MINOR) -DVER_MAJOR=$(VER_MAJOR) -DVER_PATCH=$(VER_PATCH) \
-- -DVER_STRING=\"$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)\" -DLSPCI=\"$(LSPCI)\"
-+ -DVER_STRING=\"$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)\"
- LDFLAGS = $(CFLAGS) -shared
- LIBRARY = xsys-$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH).so
- OBJECTS = xsys.o parse.o
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3-r1 b/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3-r1
deleted file mode 100644
index 717d41bf4a89..000000000000
--- a/net-irc/xchat-xsys/files/digest-xchat-xsys-1.9.3-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7a284ae9aea5f951e8e89e1c846848fb xsys-1.9.3.tar.bz2 10578
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.0-r1 b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.0-r1
deleted file mode 100644
index add2070f83b5..000000000000
--- a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.0-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a0c8726e3486807086d79c5fdd576126 xsys-2.0.0.tar.bz2 11120
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.2 b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.2
deleted file mode 100644
index 4a8c79fa3ad1..000000000000
--- a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c97caae74ee74738fb9de0e3a9f98c32 xsys-2.0.2.tar.bz2 11760
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.4 b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.4
deleted file mode 100644
index a525c1133bc0..000000000000
--- a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3d25caa6b07e3d5d19d5fbe673987693 xsys-2.0.4.tar.bz2 12651
diff --git a/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.6 b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.6
new file mode 100644
index 000000000000..34395b541dd8
--- /dev/null
+++ b/net-irc/xchat-xsys/files/digest-xchat-xsys-2.0.6
@@ -0,0 +1 @@
+MD5 b8dfda189eb5ab4d91aed0718b1697ee xsys-2.0.6.tar.bz2 13845