summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-20 11:27:41 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-20 11:27:41 +0000
commitd6241974c8a4c8bc6d6f783145233eaadff2faf0 (patch)
tree8b7bf111fbd88bdafc3eb3df5f29117033a8d50a /net-irc/znc
parentAdd nomodules USE-flag for net-irc/znc (diff)
downloadgentoo-2-d6241974c8a4c8bc6d6f783145233eaadff2faf0.tar.gz
gentoo-2-d6241974c8a4c8bc6d6f783145233eaadff2faf0.tar.bz2
gentoo-2-d6241974c8a4c8bc6d6f783145233eaadff2faf0.zip
Better handling of CXXFLAGS
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog5
-rw-r--r--net-irc/znc/znc-0.047.ebuild18
2 files changed, 19 insertions, 4 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index a3a635d095ef..baba98bde706 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.1 2007/04/20 10:09:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.2 2007/04/20 11:27:41 armin76 Exp $
+
+ 20 Apr 2007; Raúl Porcel <armin76@gentoo.org> znc-0.047.ebuild:
+ Better handling of CXXFLAGS
*znc-0.047 (20 Apr 2007)
diff --git a/net-irc/znc/znc-0.047.ebuild b/net-irc/znc/znc-0.047.ebuild
index f7f235deb6d0..f72f8204f425 100644
--- a/net-irc/znc/znc-0.047.ebuild
+++ b/net-irc/znc/znc-0.047.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.047.ebuild,v 1.1 2007/04/20 10:09:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.047.ebuild,v 1.2 2007/04/20 11:27:41 armin76 Exp $
+
+inherit autotools
DESCRIPTION="An advanced IRC Bouncer"
HOMEPAGE="http://znc.sourceforge.net"
@@ -15,6 +17,18 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
perl? ( dev-lang/perl )"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS and don't strip
+ sed -i -e "s/-Wall -s -O2 -fomit-frame-pointer/-Wall/g" \
+ -e "s/CXXFLAGS=\"-D_GNU_SOURCE\"/CXXFLAGS=\"${CXXFLAGS} -D_GNU_SOURCE\"/g" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
src_compile() {
econf \
$(use_enable debug) \
@@ -24,8 +38,6 @@ src_compile() {
$(use_enable ssl openssl) \
|| die "econf failed"
- # Remove -s from CXXFLAGS as emerge handles stripping
- sed -e 's/ -s / /' -i Makefile modules/Makefile || die "sed failed"
emake || die "emake failed"
}