summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-05-13 03:53:15 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-05-13 03:53:15 +0000
commit15516bbf28f6172614dfa9b729e90c7513345462 (patch)
tree445c3489f551dfc5961e123417b0d66ec37c3bcf /net-irc
parentVersion bump: 7.3.189 is released (diff)
downloadgentoo-2-15516bbf28f6172614dfa9b729e90c7513345462.tar.gz
gentoo-2-15516bbf28f6172614dfa9b729e90c7513345462.tar.bz2
gentoo-2-15516bbf28f6172614dfa9b729e90c7513345462.zip
Bump to ircii-20110228 with patch allowing compilation on glibc systems.
(Portage version: 2.2.0_alpha30-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ircii/ChangeLog10
-rw-r--r--net-irc/ircii/files/ircii-20110228-glibc.patch29
-rw-r--r--net-irc/ircii/ircii-20110228.ebuild36
3 files changed, 73 insertions, 2 deletions
diff --git a/net-irc/ircii/ChangeLog b/net-irc/ircii/ChangeLog
index 6e9d849830a7..83d16c7b2044 100644
--- a/net-irc/ircii/ChangeLog
+++ b/net-irc/ircii/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/ircii
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.26 2009/07/28 02:11:25 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.27 2011/05/13 03:53:15 binki Exp $
+
+*ircii-20110228 (13 May 2011)
+
+ 13 May 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +ircii-20110228.ebuild, +files/ircii-20110228-glibc.patch:
+ Bump to ircii-20110228 with patch allowing compilation on glibc systems.
28 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org>
ircii-20060725.ebuild:
diff --git a/net-irc/ircii/files/ircii-20110228-glibc.patch b/net-irc/ircii/files/ircii-20110228-glibc.patch
new file mode 100644
index 000000000000..291bf3219eb2
--- /dev/null
+++ b/net-irc/ircii/files/ircii-20110228-glibc.patch
@@ -0,0 +1,29 @@
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+
+Support glibc systems where SIGRTMAX and SIGRTMIN macros can only be fully expanded at runtime.
+
+--- a/source/mksiginc.c
++++ b/source/mksiginc.c
+@@ -191,12 +191,18 @@
+ signames[SIGRETRACT] = "RETRACT";
+ #endif
+
+-#if defined(SIGRTMAX) && SIGRTMAX < MY_MAXSIG
+- signames[SIGRTMAX] = "RTMAX";
++#if defined(SIGRTMAX)
++ /*
++ * In recent glibc, SIGRTMAX and SIGRTMIN macros are runtime
++ * function calls into libc and must be evaluated at runtime.
++ */
++ if (SIGRTMAX < MY_MAXSIG)
++ signames[SIGRTMAX] = "RTMAX";
+ #endif
+
+-#if defined(SIGRTMIN) && SIGRTMIN < MY_MAXSIG
+- signames[SIGRTMIN] = "RTMIN";
++#if defined(SIGRTMIN)
++ if (SIGRTMIN < MY_MAXSIG)
++ signames[SIGRTMIN] = "RTMIN";
+ #endif
+
+ #if defined(SIGSAK) && SIGSAK < MY_MAXSIG
diff --git a/net-irc/ircii/ircii-20110228.ebuild b/net-irc/ircii/ircii-20110228.ebuild
new file mode 100644
index 000000000000..808033336920
--- /dev/null
+++ b/net-irc/ircii/ircii-20110228.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20110228.ebuild,v 1.1 2011/05/13 03:53:15 binki Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
+HOMEPAGE="http://www.eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !!net-irc/irc-client"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc.patch
+}
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}