summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-06-28 12:14:01 +0000
committerSven Wegener <swegener@gentoo.org>2005-06-28 12:14:01 +0000
commit229c82167f8acd961ad9f69c824ff61f4fa51a25 (patch)
tree2cdc3dadd7d3a3bb5ddc7b979928b0f9f4fa83c6 /net-irc
parentfc change needed by policycoreutils-1.24 (diff)
downloadgentoo-2-229c82167f8acd961ad9f69c824ff61f4fa51a25.tar.gz
gentoo-2-229c82167f8acd961ad9f69c824ff61f4fa51a25.tar.bz2
gentoo-2-229c82167f8acd961ad9f69c824ff61f4fa51a25.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchatosd/ChangeLog7
-rw-r--r--net-irc/xchatosd/Manifest12
-rw-r--r--net-irc/xchatosd/files/digest-xchatosd-5.191
-rw-r--r--net-irc/xchatosd/xchatosd-5.19.ebuild42
4 files changed, 51 insertions, 11 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index fb6bb3e03f8e..94e51500087a 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchatosd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.14 2005/06/21 13:18:26 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.15 2005/06/28 12:14:01 swegener Exp $
+
+*xchatosd-5.19 (28 Jun 2005)
+
+ 28 Jun 2005; Sven Wegener <swegener@gentoo.org> +xchatosd-5.19.ebuild:
+ Version bump.
21 Jun 2005; Sven Wegener <swegener@gentoo.org> xchatosd-5.18.ebuild:
Adjusted dependencies to work with net-irc/xchat-gnome.
diff --git a/net-irc/xchatosd/Manifest b/net-irc/xchatosd/Manifest
index 8c20dce278ec..381053ae65db 100644
--- a/net-irc/xchatosd/Manifest
+++ b/net-irc/xchatosd/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 0efb61ad929342299e495897490e8a03 ChangeLog 2114
MD5 4a469b706c4100d15151e114918362f9 files/digest-xchatosd-5.18 64
+MD5 7c7bda25fddb101d0ca9ced34251e234 files/digest-xchatosd-5.19 64
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 eb2f8590f988863dfd44911276a3e282 xchatosd-5.18.ebuild 1179
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCuBO5I1lqEGTUzyQRAlG4AJ4kwJ2ZO1x4JYS9OYnhogUmSYrt1QCg1IlJ
-y2EAymSOuaPU9iXuJOOYNPY=
-=L0lT
------END PGP SIGNATURE-----
+MD5 eb2f8590f988863dfd44911276a3e282 xchatosd-5.19.ebuild 1179
diff --git a/net-irc/xchatosd/files/digest-xchatosd-5.19 b/net-irc/xchatosd/files/digest-xchatosd-5.19
new file mode 100644
index 000000000000..ff846e84be3f
--- /dev/null
+++ b/net-irc/xchatosd/files/digest-xchatosd-5.19
@@ -0,0 +1 @@
+MD5 d95091553dc19e32aefb03ec46ab641d xchatosd-5.19.tar.gz 10778
diff --git a/net-irc/xchatosd/xchatosd-5.19.ebuild b/net-irc/xchatosd/xchatosd-5.19.ebuild
new file mode 100644
index 000000000000..e8c336006183
--- /dev/null
+++ b/net-irc/xchatosd/xchatosd-5.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.19.ebuild,v 1.1 2005/06/28 12:14:01 swegener Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="On-Screen Display for XChat"
+HOMEPAGE="http://sourceforge.net/projects/xchatosd/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~ia64"
+IUSE="iconv"
+
+RDEPEND=">=x11-libs/xosd-2.2.5
+ || (
+ >=net-irc/xchat-2.0.9
+ >=net-irc/xchat-gnome-0.4
+ )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ # We have our own include file in /usr/include/xchat
+ einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"
+ cp -f "${ROOT}"/usr/include/xchat/xchat-plugin.h "${S}"/xchat-plugin.h
+}
+
+src_compile() {
+ append-flags -fPIC -DPIC
+ use iconv || sed -i -e "/^#define ICONV_LIB$/d" xchatosd.h
+
+ emake CC="$(tc-getCXX)" CPP="$(tc-getCXX)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/xchat/plugins
+ doexe xchatosd.so || die "doexe failed"
+ dodoc ChangeLog README || die "dodoc failed"
+}