summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-01-10 06:26:48 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-01-10 06:26:48 +0000
commit641ab7a0b6b4ddd8d9b964682d50b17697f86b33 (patch)
treec6ad020f0f89151ba0aaecafe437adc4780f7bb6 /net-irc
parentAdd python3_3 and python3_4 to PYTHON_COMPAT and update test functionality. (diff)
downloadgentoo-2-641ab7a0b6b4ddd8d9b964682d50b17697f86b33.tar.gz
gentoo-2-641ab7a0b6b4ddd8d9b964682d50b17697f86b33.tar.bz2
gentoo-2-641ab7a0b6b4ddd8d9b964682d50b17697f86b33.zip
Fix bug 518958
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.15/cvs/Linux i686, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-otr/ChangeLog10
-rw-r--r--net-irc/irssi-otr/files/irssi-otr-1.0.0-cflags.patch11
-rw-r--r--net-irc/irssi-otr/irssi-otr-1.0.0.ebuild31
3 files changed, 50 insertions, 2 deletions
diff --git a/net-irc/irssi-otr/ChangeLog b/net-irc/irssi-otr/ChangeLog
index 6e5c4003296f..0c3ff011f822 100644
--- a/net-irc/irssi-otr/ChangeLog
+++ b/net-irc/irssi-otr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/irssi-otr
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.18 2014/11/28 13:34:03 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.19 2015/01/10 06:26:48 bircoph Exp $
+
+*irssi-otr-1.0.0 (10 Jan 2015)
+
+ 10 Jan 2015; Andrew Savchenko <bircoph@gentoo.org> +irssi-otr-1.0.0.ebuild,
+ +files/irssi-otr-1.0.0-cflags.patch:
+ Version bump, this fixes bug 518958 and removes block on libotr-4.
28 Nov 2014; Pacho Ramos <pacho@gentoo.org> irssi-otr-0.3-r1.ebuild:
Support python 3.4
diff --git a/net-irc/irssi-otr/files/irssi-otr-1.0.0-cflags.patch b/net-irc/irssi-otr/files/irssi-otr-1.0.0-cflags.patch
new file mode 100644
index 000000000000..50b57c58e8a4
--- /dev/null
+++ b/net-irc/irssi-otr/files/irssi-otr-1.0.0-cflags.patch
@@ -0,0 +1,11 @@
+--- configure.ac 2014-02-13 04:50:45.000000000 +0400
++++ configure.ac.new 2014-12-07 12:13:17.346849284 +0300
+@@ -64,7 +64,7 @@
+
+ LT_INIT
+
+-CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing -fstack-protector-all -D_FORTIFY_SOURCE=2 -O1 -Wl,-z,relro,-z,now -fPIE -pie $PACKAGE_CFLAGS"
++CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing -fstack-protector-all -D_FORTIFY_SOURCE=2 -Wl,-z,relro,-z,now -fPIE -pie $PACKAGE_CFLAGS"
+
+ DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir) -I\$(top_builddir)/src -I\$(top_builddir)/include"
+ AC_SUBST(DEFAULT_INCLUDES)
diff --git a/net-irc/irssi-otr/irssi-otr-1.0.0.ebuild b/net-irc/irssi-otr/irssi-otr-1.0.0.ebuild
new file mode 100644
index 000000000000..1775e2b07eef
--- /dev/null
+++ b/net-irc/irssi-otr/irssi-otr-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/irssi-otr-1.0.0.ebuild,v 1.1 2015/01/10 06:26:48 bircoph Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
+HOMEPAGE="https://github.com/cryptodotis/irssi-otr"
+SRC_URI="https://github.com/cryptodotis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+# please note >=libotr-4.1.0 is required due to critical bugfix
+# d748757e581b74e7298df155ad49174cb914102b, see README.md
+RDEPEND="
+ >=dev-libs/glib-2.22.0:2
+ >=dev-libs/libgcrypt-1.2.0:0
+ >=net-libs/libotr-4.1.0
+ >=net-irc/irssi-0.8.15"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_AUTORECONF="yes"
+DOCS=( README.md )
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )