summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-08 07:59:02 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-08 07:59:02 +0000
commit6b15e1299489aa95856f8df948dbbb74b6501fb7 (patch)
treeba817bffac9d7e1d547a03bcfafbf4a0d6cf053e /net-irc
parentx86 stable wrt bug #344245 (diff)
downloadgentoo-2-6b15e1299489aa95856f8df948dbbb74b6501fb7.tar.gz
gentoo-2-6b15e1299489aa95856f8df948dbbb74b6501fb7.tar.bz2
gentoo-2-6b15e1299489aa95856f8df948dbbb74b6501fb7.zip
version bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.096.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 9931090d138d..035c4ae6451f 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.44 2010/08/28 23:31:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.45 2010/11/08 07:59:02 wired Exp $
+
+*znc-0.096 (08 Nov 2010)
+
+ 08 Nov 2010; Alex Alexander <wired@gentoo.org> +znc-0.096.ebuild:
+ version bump
28 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> znc-0.094.ebuild:
x86 stable wrt security bug #332535
diff --git a/net-irc/znc/znc-0.096.ebuild b/net-irc/znc/znc-0.096.ebuild
new file mode 100644
index 000000000000..220b51862e98
--- /dev/null
+++ b/net-irc/znc/znc-0.096.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.096.ebuild,v 1.1 2010/11/08 07:59:02 wired Exp $
+
+EAPI=2
+
+inherit base
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ perl? ( dev-lang/swig )
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}