summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-09-05 17:58:57 +0000
committerNed Ludd <solar@gentoo.org>2003-09-05 17:58:57 +0000
commit6cd00c0047cd80e50da22792a1e2f6c7329cf4f1 (patch)
tree3fb1c8d0ab06dec8142116fadc853eccc40fd994 /net-irc
parentper almost every gentoo developers request we are removing the bold out of th... (diff)
downloadgentoo-2-6cd00c0047cd80e50da22792a1e2f6c7329cf4f1.tar.gz
gentoo-2-6cd00c0047cd80e50da22792a1e2f6c7329cf4f1.tar.bz2
gentoo-2-6cd00c0047cd80e50da22792a1e2f6c7329cf4f1.zip
per almost every gentoo developers request we are removing the bold out of the default NICK_COMP fset, and switching freenode to be the default network. two minor patches added added to handle this.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bitchx/ChangeLog11
-rw-r--r--net-irc/bitchx/Manifest4
-rw-r--r--net-irc/bitchx/bitchx-1.0.19-r6.ebuild148
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.19-freenode.patch31
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.19-nickcomp-nocolor.patch13
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.19-r61
6 files changed, 205 insertions, 3 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index 2e1ccd619c8a..3a18d618b34a 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-irc/bitchx
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.26 2003/08/20 02:08:36 gregf Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.27 2003/09/05 17:58:54 solar Exp $
+
+*bitchx-1.0.19-r6 (05 Sep 2003)
+
+ 05 Sep 2003; <solar@gentoo.org> bitchx-1.0.19-r6.ebuild,
+ files/bitchx-1.0.19-freenode.patch,
+ files/bitchx-1.0.19-nickcomp-nocolor.patch:
+ per almost every gentoo developers request we are removing the bold out of the
+ default NICK_COMP fset, and switching freenode to be the default network. two
+ minor patches added added to handle this.
19 Aug 2003; Greg Fitzgerald <gregf@gentoo.org> bitchx-1.0.19-r5.ebuild,
files/bitchx-1.0.19-hebrew.patch:
diff --git a/net-irc/bitchx/Manifest b/net-irc/bitchx/Manifest
index e29890513b65..919abe4f61f4 100644
--- a/net-irc/bitchx/Manifest
+++ b/net-irc/bitchx/Manifest
@@ -1,7 +1,7 @@
-MD5 f899d31f56f435c44ac83f9beae191eb ChangeLog 4512
+MD5 1e9365d968f8c24d95df85fcad9d80fb ChangeLog 4894
MD5 5c7d583f1f3be0370df65dc3f1c3e780 bitchx-1.0.19-r5.ebuild 3671
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
-MD5 3ab6a147f79768601ca659c542a25694 bitchx-1.0.19-r6.ebuild 3847
+MD5 07ba28494e167c6a76ad778d3a1e39d8 bitchx-1.0.19-r6.ebuild 3846
MD5 10a57b14bb58910e1f373fbc1b8b2197 files/bitchx-1.0.19-cjk.patch 7050
MD5 6a18811962d6992f9175f98d771d3d30 files/bitchx-1.0.19-gcc-3.3.patch 472
MD5 2573358b54ae05f8c23a452f657493e3 files/bitchx-1.0.19-security.patch 332
diff --git a/net-irc/bitchx/bitchx-1.0.19-r6.ebuild b/net-irc/bitchx/bitchx-1.0.19-r6.ebuild
new file mode 100644
index 000000000000..5025163ce25f
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.19-r6.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19-r6.ebuild,v 1.1 2003/09/05 17:58:54 solar Exp $
+
+inherit flag-o-matic eutils
+
+IUSE="ssl esd gnome xmms ncurses ipv6 gtk cjk"
+
+MY_P=ircii-pana-${PV/.0./.0c}
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.bitchx.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+replace-flags -O[3-9] -O2
+
+# BitchX needs to be merged with -fPIC on alpha boxes
+# This fixes bug 10932
+[ "${ARCH}" = "alpha" ] && append-flags "-fPIC"
+
+# hppa need -fPIC too
+[ "${ARCH}" = "hppa" ] && append-flags "-fPIC"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ xmms? ( media-sound/xmms )
+ ncurses? ( sys-libs/ncurses )
+ esd? ( >=media-sound/esound-0.2.5
+ >=media-libs/audiofile-0.1.5 )
+ gtk? ( =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+
+ use cjk && epatch ${FILESDIR}/${P}-cjk.patch
+ epatch ${FILESDIR}/${P}-gcc-3.3.patch
+ epatch ${FILESDIR}/${P}-security.patch || die
+ epatch ${FILESDIR}/${P}-security2.patch || die
+ epatch ${FILESDIR}/${P}-hebrew.patch || die
+ epatch ${FILESDIR}/${P}-nickcomp-nocolor.patch || die
+ epatch ${FILESDIR}/${P}-freenode.patch || die
+}
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ einfo "debugging"
+ myconf="${myconf} --enable-debug"
+ fi
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use esd && use gtk \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ use gtk && use gnome\
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use ipv6 \
+ && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ #not tested
+ #use ncurses \
+ # && myconf="${myconf} --without-tgetent" \
+ # || myconf="${myconf} --with-tgetent"
+
+ # lamer@gentoo.org BROKEN, will not work with our socks
+ # implementations, is looking for a SOCKSConnect function that our
+ # dante packages don't have :-(
+ # use socks5 \
+ # && myconf="${myconf} --with-socks=5" \
+ # || myconf="${myconf} --without-socks"
+
+ mv ${S}/include/config.h ${S}/include/config.h.orig
+ sed -e "s/#undef LATIN1/#define LATIN1 ON/;" \
+ ${S}/include/config.h.orig > \
+ ${S}/include/config.h
+ #ugly workaround
+ use gtk && use gnome && ( \
+ einfo "gtkBitchX will be built, if you want BitchX please issue"
+ einfo "USE="-gtk" emerge bitchx"
+ sleep 10
+ ) && CFLAGS="${CFLAGS} -I/usr/include/gnome-1.0"
+
+ econf CFLAGS="${CFLAGS}" \
+ --enable-cdrom \
+ --with-plugins \
+ ${myconf} || die
+ emake || die
+ cd contrib && make vh1
+}
+
+src_install () {
+
+ einstall || die
+ [ -f contrib/vh1 ] && cp contrib/vh1 ${D}/usr/bin/
+ rm ${D}/usr/share/man/man1/BitchX*
+ doman doc/BitchX.1
+
+ use gnome && use gtk && ( \
+ exeinto /usr/bin
+ # newexe ${S}/source/BitchX BitchX-1.0c19
+ dosym gtkBitchX-1.0c19 /usr/bin/gtkBitchX
+ einfo "Installed gtkBitchX"
+ ) || dosym BitchX-1.0c19 /usr/bin/BitchX
+
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ cd ${S}
+ dodoc Changelog README* IPv6-support COPYING
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ dohtml *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ cp acro/README acro/README.acro
+ dodoc acro/README.acro
+ cp arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ cp blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ cp qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/bitchx-1.0.19-freenode.patch b/net-irc/bitchx/files/bitchx-1.0.19-freenode.patch
new file mode 100644
index 000000000000..2d1a66ba8f51
--- /dev/null
+++ b/net-irc/bitchx/files/bitchx-1.0.19-freenode.patch
@@ -0,0 +1,31 @@
+--- include/config.h.orig 2003-09-05 13:22:09.000000000 -0400
++++ include/config.h 2003-09-05 13:28:05.000000000 -0400
+@@ -37,7 +37,27 @@
+ *
+ * List last updated: 03/24/01. -dialtone.
+ */
+-#define DEFAULT_SERVER "[efnet] "\
++#define DEFAULT_SERVER "[freenode]" \
++ "irc.freenode.net "\
++ "vinge.freenode.net "\
++ "truong.freenode.net "\
++ "stephenson.freenode.net "\
++ "simak.freenode.net "\
++ "orwell.freenode.net "\
++ "leguin.freenode.net "\
++ "kornbluth.freenode.net "\
++ "jordan.freenode.net "\
++ "herbert.freenode.net "\
++ "goethe.freenode.net "\
++ "gibson.freenode.net "\
++ "gerrold.freenode.net "\
++ "carter.freenode.net "\
++ "carneiro.freenode.net "\
++ "capek.freenode.net "\
++ "calkins.freenode.net "\
++ "brin.freenode.net "\
++ "adams.freenode.net "\
++ "[efnet] "\
+ "irc.Prison.NET "\
+ "irc.colorado.edu "\
+ "irc.concentric.net "\
diff --git a/net-irc/bitchx/files/bitchx-1.0.19-nickcomp-nocolor.patch b/net-irc/bitchx/files/bitchx-1.0.19-nickcomp-nocolor.patch
new file mode 100644
index 000000000000..72a04dd91166
--- /dev/null
+++ b/net-irc/bitchx/files/bitchx-1.0.19-nickcomp-nocolor.patch
@@ -0,0 +1,13 @@
+--- include/color.h.orig 2001-03-05 14:38:48.000000000 -0500
++++ include/color.h 2003-09-05 13:10:19.000000000 -0400
+@@ -717,8 +717,8 @@
+
+ #define DEFAULT_FORMAT_NICK_MSG_FSET "$0 $1 $2-"
+
+-#define DEFAULT_FORMAT_NICK_COMP_FSET "$0\002:\002$1-"
+-#define DEFAULT_FORMAT_NICK_AUTO_FSET "$0\002:\002$1-"
++#define DEFAULT_FORMAT_NICK_COMP_FSET "$0:$1-"
++#define DEFAULT_FORMAT_NICK_AUTO_FSET "$0:$1-"
+
+ #define DEFAULT_FORMAT_STATUS_FSET "%4%W$0-"
+ #define DEFAULT_FORMAT_STATUS1_FSET "%4%W$0-"
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.19-r6 b/net-irc/bitchx/files/digest-bitchx-1.0.19-r6
new file mode 100644
index 000000000000..733d621134c6
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.19-r6
@@ -0,0 +1 @@
+MD5 79431ff0880e7317049045981fac8adc ircii-pana-1.0c19.tar.gz 2533621