summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2009-05-31 16:13:55 +0000
committerSven Wegener <swegener@gentoo.org>2009-05-31 16:13:55 +0000
commit8ac1ed8bc29a880f98fef141fa67878d264de959 (patch)
tree90b1b985ca06e7ecb27e694baa8067163f0c8476 /net-irc
parentamd64/x86 stable, bug #271815 (diff)
downloadgentoo-2-8ac1ed8bc29a880f98fef141fa67878d264de959.tar.gz
gentoo-2-8ac1ed8bc29a880f98fef141fa67878d264de959.tar.bz2
gentoo-2-8ac1ed8bc29a880f98fef141fa67878d264de959.zip
Security bump for wallop off-by-one heap access, bug #271875.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi/ChangeLog10
-rw-r--r--net-irc/irssi/files/irssi-0.8.13-svn-5068.patch20
-rw-r--r--net-irc/irssi/irssi-0.8.13-r1.ebuild58
3 files changed, 86 insertions, 2 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index 15892ca664c9..838a74f3ce26 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/irssi
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.139 2009/04/01 08:19:09 swegener Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.140 2009/05/31 16:13:54 swegener Exp $
+
+*irssi-0.8.13-r1 (31 May 2009)
+
+ 31 May 2009; Sven Wegener <swegener@gentoo.org> +irssi-0.8.13-r1.ebuild,
+ +files/irssi-0.8.13-svn-5068.patch:
+ Security bump for wallop off-by-one heap access, bug #271875.
*irssi-0.8.13 (01 Apr 2009)
diff --git a/net-irc/irssi/files/irssi-0.8.13-svn-5068.patch b/net-irc/irssi/files/irssi-0.8.13-svn-5068.patch
new file mode 100644
index 000000000000..1c93fda42807
--- /dev/null
+++ b/net-irc/irssi/files/irssi-0.8.13-svn-5068.patch
@@ -0,0 +1,20 @@
+r5068 | jilles | 2009-05-15 11:54:33 +0000 (Fri, 15 May 2009) | 5 lines
+
+Fix out of bounds access in event_wallops().
+
+bug #662
+Submitted by: nemo
+
+Index: irssi/src/fe-common/irc/fe-events.c
+===================================================================
+--- irssi/src/fe-common/irc/fe-events.c (revision 5067)
++++ irssi/src/fe-common/irc/fe-events.c (revision 5068)
+@@ -298,7 +298,7 @@
+
+ tmp = g_strdup(data+8);
+ len = strlen(tmp);
+- if (tmp[len-1] == 1) tmp[len-1] = '\0';
++ if (len >= 1 && tmp[len-1] == 1) tmp[len-1] = '\0';
+ printformat(server, NULL, MSGLEVEL_WALLOPS, IRCTXT_ACTION_WALLOPS, nick, tmp);
+ g_free(tmp);
+ }
diff --git a/net-irc/irssi/irssi-0.8.13-r1.ebuild b/net-irc/irssi/irssi-0.8.13-r1.ebuild
new file mode 100644
index 000000000000..0e3ec8652696
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.13-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.13-r1.ebuild,v 1.1 2009/05/31 16:13:54 swegener Exp $
+
+inherit perl-module
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="http://irssi.org/"
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 perl ssl socks5"
+
+RDEPEND="sys-libs/ncurses
+ >=dev-libs/glib-2.2.1
+ ssl? ( dev-libs/openssl )
+ perl? ( dev-lang/perl )
+ socks5? ( >=net-proxy/dante-1.1.18 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+RDEPEND="${RDEPEND}
+ perl? ( !net-im/silc-client )
+ !net-irc/irssi-svn"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-svn-5068.patch
+
+ epunt_cxx
+}
+
+src_compile() {
+ econf \
+ --with-proxy \
+ --with-ncurses \
+ --with-perl-lib=vendor \
+ $(use_with perl) \
+ $(use_with socks5 socks) \
+ $(use_enable ssl) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ use perl && fixlocalpod
+
+ dodoc AUTHORS ChangeLog README TODO NEWS || die "dodoc failed"
+}