summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-11-04 01:29:29 +0000
committerChuck Short <zul@gentoo.org>2003-11-04 01:29:29 +0000
commit93441b9d458d5b03e86071bd777f6eff3c8dfc10 (patch)
tree41eea7d221de8baba8a0771a6e8c739e1cfd76f6 /net-irc
parentFixed metadata (diff)
downloadgentoo-2-93441b9d458d5b03e86071bd777f6eff3c8dfc10.tar.gz
gentoo-2-93441b9d458d5b03e86071bd777f6eff3c8dfc10.tar.bz2
gentoo-2-93441b9d458d5b03e86071bd777f6eff3c8dfc10.zip
Version bump.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/epic4/epic4-1.1.14.ebuild78
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.142
2 files changed, 80 insertions, 0 deletions
diff --git a/net-irc/epic4/epic4-1.1.14.ebuild b/net-irc/epic4/epic4-1.1.14.ebuild
new file mode 100644
index 000000000000..1722248f8462
--- /dev/null
+++ b/net-irc/epic4/epic4-1.1.14.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.14.ebuild,v 1.1 2003/11/04 01:29:29 zul Exp $
+
+IUSE="ipv6 perl ssl tcltk"
+
+DESCRIPTION="Epic4 IRC Client"
+SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
+HOMEPAGE="http://epicsol.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~ia64 ~alpha ~hppa"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ tcltk? ( dev-lang/tcl )"
+
+inherit flag-o-matic
+replace-flags "-O?" "-O"
+
+src_compile() {
+ myconf=""
+
+ use ipv6 \
+ && myconf="${myconf} --with-ipv6" \
+ || myconf="${myconf} --without-ipv6"
+
+ use perl \
+ && myconf="${myconf} --with-perl" \
+ || myconf="${myconf} --without-perl"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use tcltk \
+ && myconf="${myconf} --with-tcl" \
+ || myconf="${myconf} --without-tcl"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die
+
+ rm -f ${D}/usr/bin/epic
+ dosym epic-EPIC4-${PV} /usr/bin/epic
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+ docinto doc
+ cd doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp server_groups SILLINESS TS4
+
+ dodir /usr/share/epic
+ tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -e /usr/share/epic/script/local ]; then
+ cp ${FILESDIR}/local /usr/share/epic/script/
+ fi
+}
diff --git a/net-irc/epic4/files/digest-epic4-1.1.14 b/net-irc/epic4/files/digest-epic4-1.1.14
new file mode 100644
index 000000000000..782fa69b5800
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-1.1.14
@@ -0,0 +1,2 @@
+MD5 b041aeb0490fd542cd68dacb6f05c425 epic4-1.1.14.tar.bz2 607595
+MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157