summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-14 08:32:02 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-14 08:32:02 +0000
commit9b76e86295b7963534253737ee4469aef65449b6 (patch)
tree24f649b13154094273a7a31262046d20b5db423f /net-irc
parentVersion bump chameleon to 2.4.3. (diff)
downloadgentoo-2-9b76e86295b7963534253737ee4469aef65449b6.tar.gz
gentoo-2-9b76e86295b7963534253737ee4469aef65449b6.tar.bz2
gentoo-2-9b76e86295b7963534253737ee4469aef65449b6.zip
live ebuild
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-9999.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 195a035020df..2f1a64557906 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.50 2011/09/08 20:27:13 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.51 2011/09/14 08:32:02 wired Exp $
+
+*znc-9999 (14 Sep 2011)
+
+ 14 Sep 2011; Alex Alexander <wired@gentoo.org> +znc-9999.ebuild:
+ live ebuild
*znc-0.200 (08 Sep 2011)
diff --git a/net-irc/znc/znc-9999.ebuild b/net-irc/znc/znc-9999.ebuild
new file mode 100644
index 000000000000..e87763c0e49d
--- /dev/null
+++ b/net-irc/znc/znc-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-9999.ebuild,v 1.1 2011/09/14 08:32:02 wired Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 3"
+inherit base git-2 python
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+
+EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/znc/znc.git"}
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="ares debug extras ipv6 perl python ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 3
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use python && echo "--enable-python=python-$(python_get_version)") \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README.md || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}