summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-07-02 06:13:22 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-07-02 06:13:22 +0000
commit9f15d28dbd57d75e4a2e87708208e7c611bfe9a3 (patch)
tree48c84dbc30421ca13a7cfe27ada07dd0e8b21c21 /net-irc
parentVersion bump. (diff)
downloadgentoo-2-9f15d28dbd57d75e4a2e87708208e7c611bfe9a3.tar.gz
gentoo-2-9f15d28dbd57d75e4a2e87708208e7c611bfe9a3.tar.bz2
gentoo-2-9f15d28dbd57d75e4a2e87708208e7c611bfe9a3.zip
Import gentoo-prefix support from the prefix-overlay, including bump to EAPI=3, for xchat-2.8.8-r2.
(Portage version: 2.2.0_alpha41-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/xchat-2.8.4-interix.patch18
-rw-r--r--net-irc/xchat/xchat-2.8.8-r2.ebuild16
3 files changed, 36 insertions, 5 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 5cc297be4040..310a4d1e4734 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.297 2011/03/29 12:50:37 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.298 2011/07/02 06:13:22 binki Exp $
+
+ 02 Jul 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +files/xchat-2.8.4-interix.patch, xchat-2.8.8-r2.ebuild:
+ Import gentoo-prefix support from the prefix-overlay, including bump to
+ EAPI=3, for xchat-2.8.8-r2.
29 Mar 2011; Christoph Mende <angelos@gentoo.org> xchat-2.8.6-r2.ebuild:
Fix gtk+ slot deps
diff --git a/net-irc/xchat/files/xchat-2.8.4-interix.patch b/net-irc/xchat/files/xchat-2.8.4-interix.patch
new file mode 100644
index 000000000000..ce4b76b1d52e
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.8.4-interix.patch
@@ -0,0 +1,18 @@
+diff -ru xchat-2.8.4.orig/src/common/text.c xchat-2.8.4/src/common/text.c
+--- xchat-2.8.4.orig/src/common/text.c 2008-03-12 14:45:26 +0100
++++ xchat-2.8.4/src/common/text.c 2008-03-12 15:04:35 +0100
+@@ -271,10 +271,14 @@
+ {
+ if (buf[0] == 'T')
+ {
++#ifdef HAVE_STRTOULL
+ if (sizeof (time_t) == 4)
+ stamp = strtoul (buf + 2, NULL, 10);
+ else
+ stamp = strtoull (buf + 2, NULL, 10); /* just incase time_t is 64 bits */
++#else
++ stamp = strtoul (buf + 2, NULL, 10);
++#endif
+ text = strchr (buf + 3, ' ');
+ if (text)
+ {
diff --git a/net-irc/xchat/xchat-2.8.8-r2.ebuild b/net-irc/xchat/xchat-2.8.8-r2.ebuild
index 5b6ba9a4b299..3b907f33b103 100644
--- a/net-irc/xchat/xchat-2.8.8-r2.ebuild
+++ b/net-irc/xchat/xchat-2.8.8-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r2.ebuild,v 1.3 2011/03/22 09:54:15 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r2.ebuild,v 1.4 2011/07/02 06:13:22 binki Exp $
-EAPI=2
+EAPI=3
inherit eutils versionator gnome2 autotools
@@ -16,7 +16,7 @@ HOMEPAGE="http://www.xchat.org/"
LICENSE="GPL-2 hires-icons? ( GPL-3 )"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="dbus fastscroll +gtk hires-icons ipv6 libnotify mmx nls ntlm perl python spell ssl tcl xchatdccserver"
RDEPEND=">=dev-libs/glib-2.6.0:2
@@ -45,6 +45,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-input-box4.patch
+ epatch "${FILESDIR}"/${PN}-2.8.4-interix.patch
epatch "${FILESDIR}"/${P}-libnotify07.patch
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
@@ -57,7 +58,7 @@ src_prepare() {
# xchat sourcecode ships with po/Makefile.in.in from gettext-0.17
# which fails with >=gettext-0.18
- cp /usr/share/gettext/po/Makefile.in.in "${S}"/po/ || die
+ cp "${EPREFIX}"/usr/share/gettext/po/Makefile.in.in "${S}"/po/ || die
eautoreconf
}
@@ -67,6 +68,13 @@ src_configure() {
# instead of python-config (#25943)
unset PYTHONPATH
+ if [[ ${CHOST} == *-interix* ]]; then
+ # this -Wl,-E option for the interix ld makes some checks
+ # false positives, so set those here.
+ export ac_cv_func_strtoull=no
+ export ac_cv_func_memrchr=no
+ fi
+
econf \
--enable-shm \
$(use_enable dbus) \