summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-04-13 01:02:35 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-04-13 01:02:35 +0000
commitc64a6ea7c0378155a58e0b824c791eebd2d89771 (patch)
tree2ae7b4ac73157c15a5ccdea31279bac7b11ab75a /net-irc
parentStable on x86 wrt bug #217467 (diff)
downloadgentoo-2-c64a6ea7c0378155a58e0b824c791eebd2d89771.tar.gz
gentoo-2-c64a6ea7c0378155a58e0b824c791eebd2d89771.tar.bz2
gentoo-2-c64a6ea7c0378155a58e0b824c791eebd2d89771.zip
Explicitly separate DEPEND/RDEPEND for bug #217278.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-xsys/ChangeLog6
-rw-r--r--net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild7
-rw-r--r--net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild7
3 files changed, 13 insertions, 7 deletions
diff --git a/net-irc/xchat-xsys/ChangeLog b/net-irc/xchat-xsys/ChangeLog
index f8d966be1fc3..5d7374b97f41 100644
--- a/net-irc/xchat-xsys/ChangeLog
+++ b/net-irc/xchat-xsys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat-xsys
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.66 2008/03/26 14:46:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.67 2008/04/13 01:02:35 chainsaw Exp $
+
+ 13 Apr 2008; Tony Vroon <chainsaw@gentoo.org> xchat-xsys-2.2.0.ebuild,
+ xchat-xsys-2.2.0-r1.ebuild:
+ Explicitly separate DEPEND/RDEPEND for bug #217278.
26 Mar 2008; Tony Vroon <chainsaw@gentoo.org> xchat-xsys-2.2.0-r1.ebuild:
Mark stable on AMD64. Tested on a Core2 Duo laptop.
diff --git a/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild b/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild
index 63d9edac280e..e389359bdae1 100644
--- a/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild
+++ b/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild,v 1.3 2008/03/26 14:46:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.2.0-r1.ebuild,v 1.4 2008/04/13 01:02:35 chainsaw Exp $
inherit toolchain-funcs eutils
@@ -15,13 +15,14 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc x86"
-DEPEND="|| (
+RDEPEND="|| (
>=net-irc/xchat-2.4.0
>=net-irc/xchat-gnome-0.4
)
- dev-util/pkgconfig
sys-apps/pciutils
audacious? ( >=media-sound/audacious-1.4.0 )"
+DEPEND="${RDEPEND}
+ audacious? ( dev-util/pkgconfig )"
src_unpack() {
unpack ${A}
diff --git a/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild b/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild
index 532538bac7a5..2c698c329d8c 100644
--- a/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild
+++ b/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild,v 1.4 2008/01/29 14:03:07 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.2.0.ebuild,v 1.5 2008/04/13 01:02:35 chainsaw Exp $
inherit toolchain-funcs eutils
@@ -14,13 +14,14 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ~ppc64 ~sparc x86"
-DEPEND="|| (
+RDEPEND="|| (
>=net-irc/xchat-2.4.0
>=net-irc/xchat-gnome-0.4
)
- dev-util/pkgconfig
sys-apps/pciutils
>=media-sound/audacious-1.4.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_compile() {
emake -j1 CC="$(tc-getCC)" || die "Compile failed"