summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-12-05 16:46:27 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-12-05 16:46:27 +0000
commitfd32bb802a0e83b2df22e6c58365d51a32f8b4a9 (patch)
treef291c26ae2895c1eecca7a5146d49cc842e3e894 /net-irc
parentDrop local usex now that it is in eutils.eclass. (diff)
downloadgentoo-2-fd32bb802a0e83b2df22e6c58365d51a32f8b4a9.tar.gz
gentoo-2-fd32bb802a0e83b2df22e6c58365d51a32f8b4a9.tar.bz2
gentoo-2-fd32bb802a0e83b2df22e6c58365d51a32f8b4a9.zip
Ensure that ${CHOST}-gcc is called instead of `gcc', fixing bug #393109 by ago.
(Portage version: 2.2.0_alpha78-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ircii/ChangeLog7
-rw-r--r--net-irc/ircii/ircii-20110228.ebuild5
-rw-r--r--net-irc/ircii/ircii-20111115.ebuild5
3 files changed, 12 insertions, 5 deletions
diff --git a/net-irc/ircii/ChangeLog b/net-irc/ircii/ChangeLog
index 74050a434aca..d9914ccd3f8e 100644
--- a/net-irc/ircii/ChangeLog
+++ b/net-irc/ircii/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/ircii
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.30 2011/12/02 00:35:24 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ChangeLog,v 1.31 2011/12/05 16:46:27 binki Exp $
+
+ 05 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> ircii-20110228.ebuild,
+ ircii-20111115.ebuild:
+ Ensure that ${CHOST}-gcc is called instead of `gcc', fixing bug #393109 by
+ ago.
02 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> ircii-20060725.ebuild:
Address bug #247987 by adding blocker on net-irc/irc-client to
diff --git a/net-irc/ircii/ircii-20110228.ebuild b/net-irc/ircii/ircii-20110228.ebuild
index 1d3350339c8e..31e5f5cc9d17 100644
--- a/net-irc/ircii/ircii-20110228.ebuild
+++ b/net-irc/ircii/ircii-20110228.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20110228.ebuild,v 1.2 2011/06/30 03:00:37 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20110228.ebuild,v 1.3 2011/12/05 16:46:27 binki Exp $
EAPI=4
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
@@ -26,6 +26,7 @@ src_prepare() {
}
src_configure() {
+ tc-export CC
use elibc_glibc || append-libs -liconv
econf $(use_enable ipv6)
}
diff --git a/net-irc/ircii/ircii-20111115.ebuild b/net-irc/ircii/ircii-20111115.ebuild
index 003bd365cf26..9a4c76457308 100644
--- a/net-irc/ircii/ircii-20111115.ebuild
+++ b/net-irc/ircii/ircii-20111115.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20111115.ebuild,v 1.1 2011/12/02 00:17:56 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20111115.ebuild,v 1.2 2011/12/05 16:46:27 binki Exp $
EAPI=4
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2
@@ -23,6 +23,7 @@ RDEPEND="${DEPEND}
!!net-irc/irc-client"
src_configure() {
+ tc-export CC
use elibc_glibc || append-libs -liconv
econf $(use_enable ipv6)
}