summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-11-22 08:49:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-11-22 08:49:00 +0000
commitd5754ac60637318be9896a96cd0c6345184a10c7 (patch)
treef7534621a7bb31c41c24b1fadb4a20f92a08e775 /net-libs/adns/adns-1.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-d5754ac60637318be9896a96cd0c6345184a10c7.tar.gz
gentoo-2-d5754ac60637318be9896a96cd0c6345184a10c7.tar.bz2
gentoo-2-d5754ac60637318be9896a96cd0c6345184a10c7.zip
Version bump
Diffstat (limited to 'net-libs/adns/adns-1.1.ebuild')
-rw-r--r--net-libs/adns/adns-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/adns/adns-1.1.ebuild b/net-libs/adns/adns-1.1.ebuild
new file mode 100644
index 000000000000..3247f2a2b5e8
--- /dev/null
+++ b/net-libs/adns/adns-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/adns/adns-1.1.ebuild,v 1.1 2003/11/22 08:48:58 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Advanced, easy to use, asynchronous-capable DNS client library and utilities"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~ian/adns/"
+SRC_URI="ftp://ftp.chiark.greenend.org.uk/users/ian/adns/${P}.tar.gz"
+
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64 ~amd64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install () {
+ dodir /usr/{include,bin,lib}
+ make prefix=${D}/usr install || die
+ dodoc README GPL-vs-LGPL COPYING TODO
+ dohtml *.html
+
+ cd ${D}/usr/lib
+ dosym libadns.so.1 /usr/lib/libadns.so
+}